X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 57: Problem with playback of video: Distorted colors

Posted

After upgrading Firefox to version 57, I am experiencing problems with the playback of video. The included screenshot shows that videos do play but colors are distorted resulting in a pink and green image. The problem does not relate exclusively to Youtube. I observed the problem also on Facebook and other websites.

I did not experience this problem at anytime with versions of Firefox prior to version 57.

After upgrading Firefox to version 57, I am experiencing problems with the playback of video. The included screenshot shows that videos do play but colors are distorted resulting in a pink and green image. The problem does not relate exclusively to Youtube. I observed the problem also on Facebook and other websites. I did not experience this problem at anytime with versions of Firefox prior to version 57.

Modified by phoeniks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 23.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Mkll 314 solutions 1978 answers

Hello, let's try a refresh!

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

Hello, let's try a refresh! The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen. Did this fix the problem? Please report back to us! Thank you.

Helpful Reply

It seems the screenshot did not upload well first time around. So here it is.

It seems the screenshot did not upload well first time around. So here it is.
Mkll 314 solutions 1978 answers

Hello, try the refresh feature from the steps mentioned above.

Hello, try the refresh feature from the steps mentioned above.

Helpful Reply

Hi,

It seems I was to quick in believing the problem was resolved. After restarting Firefox 57 once more the problem returned. I tried the same steps as mentioned above. Problem was again gone.

However, afterwards I restarted Firefox 57 once more (without changing any setting or applying any extension) the problem returned.

Seems the cause of this problem is related to a "cold" start of Firefox.

-- Original -- Hi,

The problem was resolved by executing the steps mentioned above. Videos played without the color distortion. Even after restoring all the extensions.

Many thanks for your quick and swift response and solution.

Hi, It seems I was to quick in believing the problem was resolved. After restarting Firefox 57 once more the problem returned. I tried the same steps as mentioned above. Problem was again gone. However, afterwards I restarted Firefox 57 once more (without changing any setting or applying any extension) the problem returned. Seems the cause of this problem is related to a "cold" start of Firefox. -- Original -- Hi, The problem was resolved by executing the steps mentioned above. Videos played without the color distortion. Even after restoring all the extensions. Many thanks for your quick and swift response and solution.

Modified by phoeniks

Aydi 0 solutions 2 answers

I'm having this problem as well, and have had the same experience post-refresh. Videos and gifv images are distorted.

phoeniks said

Hi, It seems I was to quick in believing the problem was resolved. After restarting Firefox 57 once more the problem returned. I tried the same steps as mentioned above. Problem was again gone. However, afterwards I restarted Firefox 57 once more (with changing any setting or applying any extension) the problem returned. Seems the cause of this problem is related to a "cold" start of Firefox. -- Original -- Hi, The problem was resolved by executing the steps mentioned above. Videos played without the color distortion. Even after restoring all the extensions. Many thanks for your quick and swift response and solution.
I'm having this problem as well, and have had the same experience post-refresh. Videos and gifv images are distorted. ''phoeniks [[#answer-1029276|said]]'' <blockquote> Hi, It seems I was to quick in believing the problem was resolved. After restarting Firefox 57 once more the problem returned. I tried the same steps as mentioned above. Problem was again gone. However, afterwards I restarted Firefox 57 once more (with changing any setting or applying any extension) the problem returned. Seems the cause of this problem is related to a "cold" start of Firefox. -- Original -- Hi, The problem was resolved by executing the steps mentioned above. Videos played without the color distortion. Even after restoring all the extensions. Many thanks for your quick and swift response and solution. </blockquote>

Question owner

Problem with Firefox 57 om my system is now resolved by disabling "Use hardware acceleration when available" in Options > Performance (see attached image).

So I guess the brand-new fast "Quantum Firefox" will not be going all that quantum fast from now on :-(

Problem with Firefox 57 om my system is now resolved by disabling "Use hardware acceleration when available" in Options > Performance (see attached image). So I guess the brand-new fast "Quantum Firefox" will not be going all that quantum fast from now on :-(
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23381 answers

hi, if you have an amd graphics card, please try updating your drivers through https://support.amd.com/en-us/download you might be seeing https://bugzilla.mozilla.org/show_bug.cgi?id=1417442

hi, if you have an amd graphics card, please try updating your drivers through https://support.amd.com/en-us/download you might be seeing https://bugzilla.mozilla.org/show_bug.cgi?id=1417442

Question owner

Hi Philipp,

I am indeed using an AMD R7 200 GPU card.

I updated the driver of that card using the AMD Driver Autodetect tool from AMD website (http://support.amd.com/en-us/download/auto-detect-tool).

The driver now has version 22.19.162.4 released on the 24th of april 2017.

I re-enabled the hardware acceleration and restarted Firefox. No more trouble with video playback :-)!

Hi Philipp, I am indeed using an AMD R7 200 GPU card. I updated the driver of that card using the AMD Driver Autodetect tool from AMD website (http://support.amd.com/en-us/download/auto-detect-tool). The driver now has version 22.19.162.4 released on the 24th of april 2017. I re-enabled the hardware acceleration and restarted Firefox. No more trouble with video playback :-)!
Aydi 0 solutions 2 answers

philipp said

hi, if you have an amd graphics card, please try updating your drivers through https://support.amd.com/en-us/download you might be seeing https://bugzilla.mozilla.org/show_bug.cgi?id=1417442

Yep! That worked for me too. Boy do I feel foolish...

Thanks for the suggestion, Philipp!

''philipp [[#answer-1029534|said]]'' <blockquote> hi, if you have an amd graphics card, please try updating your drivers through https://support.amd.com/en-us/download you might be seeing https://bugzilla.mozilla.org/show_bug.cgi?id=1417442 </blockquote> Yep! That worked for me too. Boy do I feel foolish... Thanks for the suggestion, Philipp!