Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm trying to disable the Firefox Library completely

  • 5 replies
  • 5 have this problem
  • Last reply by RDshift

more options

Hi guys, I'm working on locking down Firefox for some of our corporate machines, and in at least one of our configurations, I need to completely remove access to the Library and all it's components for security reasons, as it could be abused to browse local drives, and these are supposed to be kiosks.

Is there a way to either disable the UI element of the Library (what's the CSS ID, and then I can try to put it in CCK2 to disable that UI element) or to completely disable the Library window/functions/feature itself?

All Replies (5)

more options

Hi RDshift:

Your enterprise related question about a kiosk-like mode has me stumped :-) Luckily there's a mailing list for enterprise stuff that you can subscribe to using the form on this page:

or directly here:

Please ask your question there.

Cheers! ...Roland

Modified by Roland Tanglao

more options

I'm also going to try tweaking browser.uiCustomization.state

I've enrolled and I'll ask away, but I'll leave this open for a bit longer to see if anyone else has any ideas.

I'm particularly interested in remapping or disabling the commands themselves, because that seems to be as "foolproof" as we can get, rather than just turning off UI elements and changing keyboard shortcuts (which is challenging to do without an add-on).

more options
more options

I may have accomplished this. I believe it is either with #places or #PlacesOrganizer (although I also tried #frame)

I'll update with the specific solution once I understand what's going on a bit better.

The outcome is that the Library function appears when invoked, but the window contains no content - just an empty white non-interactive window with only the title bar standard stuff: clickable Firefox icon and resize buttons.

more options

Mkll said

Hello, try headless mode:

Hello MkII, unfortunately headless mode is nice...but doesn't quite provide as much as I want to provide.