Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can no longer use password manager for kaspersky in Firefox. It worked fine up until a couple of days ago

  • 15 replies
  • 5 have this problem
  • 10 views
  • Last reply by Tim

more options

I have had a few issues with Firefox recently which seem to have been resolved but in the last couple of days Kaspersky password manager has stopped working. Kaspersky said go to extensions in firefox and enable it, but there is nothing there. Can anyone help please?

All Replies (15)

more options

Do you know if the add-on works with the 64-bit version of Firefox? Most users with 64-bit Windows were switched over from 32-bit to 64-bit by the Firefox 56.0.1 update a few weeks ago. To check when your updates were, you could try the update history button on the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, you should see an " Update History" row with a button to show when updates were installed. If that doesn't line up with the appearance of the problem, you might try reinstalling Kaspersky to see whether the installer is able to push the extension over to Firefox.

more options

I should also mention -- thank you for sharing your add-ons list -- that you should see two extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then on the right side you should see:

- Kaspersky Protection - Safe Browsing Version 4 (temporary add-on)

I don't know if Kaspersky Protection is related to the password manager.

more options

Your answer was helpful but the addons are present in extensions,so I don't think it makes a difference to password manager. Firefox was updated and Kaspersky was also updated recently to Kaspersky 2018. I think it is one of those problems that will either rectify itself or I will have to start using another browser. Thank you for your help.

more options

Firefox was updated to what ?

Firefox 57 Final Version is on Mozilla servers tomorrow as a full version or as a update. Can think about this : Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. Then Install Full Version 57 from here : https://fileforum.betanews.com/detail/Mozilla-Firefox-for-Windows/1032985422/1 Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

more options

Okay I have uninstalled Firefox and done a clean up disk and reinstalled the latest version of Firefox 57, however I am unable to do anything with it as it keeps telling me I haven't got a secure connection.

our connection is not secure

The owner of www.google.co.uk has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Learn more…

Report errors like this to help Mozilla identify and block malicious sites


So I am unable to do anything. Any suggestions. Is it Google and therefore I should change my search browser. I am operating a secure connection and it is locked etc.

more options

In addition to the above I have just got onto Microsoft support and their suggestion is as followsI'm sorry you had to go through all that, when it likely was some simple adjustments in the browser settings. If you're going to reinstall Firefox, you'll have the latest 46.01 version.


If you still get these warnings, please do following:

Click three bars on upper right hand side--click Options--click Advanced tab--click Network tab--under Connection, click Configure how Firefox connects to the Internet--untick any "proxy" circle, tick No proxy.

Then, please access this tutorial via Firefox:

https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean

To access this page, highlight above URL (hold down mouse button and drag to highlight in blue, right click and select "open link in new tab."

My new version of Mozilla Firefox has now come with no sync or advanced button on the options menu. So I am unable to perform the above suggestion from Microsoft. I have spent ages trying to rectify this problem and I am no further forward. If I cannot resolve it soon I will have to revert to using Edge and see if that works, but installing 56 as made things worse. Any help please would be appreciated otherwise I think I am just going to throw the towel in because every time I try to do something to hopefully improve Firefox's performance it just makes it worse, which is sad because I have been using it for years.

more options

Could you click the Advanced button on the error page and find the ERROR_CODE. The one most commonly reported here is covered in this article:

How to troubleshoot security error codes on secure websites

If none of those issues sound relevant, what code do you get?

more options

Okay since I last posted I have managed to go further and set up my home page so the tabs open on my favorite websites without the message about secure connection. It is looking more like its old self now in terms of how it looks. The secure connection doesn't come up with an error code just a message. The first line is as follows as stated above with full description. The owner of www.google.co.uk has configured their website improperly. The other thing is I am still unable to use Kaspersky password manager. The key is missing. In addons it has Kaspersky protection listed but nothing else. There is clearly a problem with Kaspersky password manager.

more options

If you see the error page again, could you check below the "Learn more" for an "Advanced" button as pictured in the support article: What do the security warning codes mean? The error code is hidden in the panel opened by the Advanced button.

more options

Okay will do. Any thoughts on the password manager issue?

more options

I have also noticed there is no refresh icon when you have been in a website like the BBC news for sometime. You know the little arrow at the end of the browser box. I am going now before I drive you up the wall. Thanks for your help.

more options

Yes got to https://forum.kaspersky.com/index.php?/search/ use search term Firefox password manager there is a number of entries you need to go through and read.

more options

Thunderbird01886 said

I have also noticed there is no refresh icon when you have been in a website like the BBC news for sometime. You know the little arrow at the end of the browser box.

In Firefox 57, the reload arrow moved to the left of the address bar, no longer inside the bar. You can use Customize to move it to the right side of the box if that's more intuitive after all these years. See: Customize Firefox controls, buttons and toolbars.

more options

Thanks everyone for your help. Following the download yesterday to the new version and the patch that kaspersky did today, I can say hand on heart that password manager is back on line and working okay. Everything seems fine. It has taken just over a week to get there but hey, it is working. Thank you everyone for all your suggestions and help it is much appreciated.

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.