X
Tap here to go to the mobile version of the site.

Support Forum

Bookmarks are opening too quickly

Posted

When I open from bookmarks (with "Open All in tabs") many pages of the same site, some sites block access because of too intensive page loading. How can I slow down opening each bookmark - add 1 sec. pause ?

When I open from bookmarks (with "Open All in tabs") many pages of the same site, some sites block access because of too intensive page loading. How can I slow down opening each bookmark - add 1 sec. pause ?

Chosen solution

Decreasing network.http.max-persistent-connections-per-server mainly solves the problem. Thanks!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Foxit Reader Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5309 solutions 39394 answers

Fewer bookmarks in each folder would work, as there is no way of setting a delay or a pause per bookmark.

Fewer bookmarks in each folder would work, as there is no way of setting a delay or a pause per bookmark.
jscher2000
  • Top 10 Contributor
7676 solutions 62504 answers

Helpful Reply

Firefox has a setting that might help.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste max- and pause while the list is filtered

(3) Maybe: Double-click the network.http.max-persistent-connections-per-server preference and try 4 instead of the default value of 6?

The source code file has some notes on each of the different network.http.max-... settings which may or may not be helpful:

https://dxr.mozilla.org/mozilla-release/source/modules/libpref/init/all.js#1608

Firefox has a setting that ''might'' help. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''max-''' and pause while the list is filtered (3) Maybe: Double-click the '''network.http.max-persistent-connections-per-server''' preference and try 4 instead of the default value of 6? The source code file has some notes on each of the different network.http.max-... settings which may or may not be helpful: https://dxr.mozilla.org/mozilla-release/source/modules/libpref/init/all.js#1608

Chosen Solution

Decreasing network.http.max-persistent-connections-per-server mainly solves the problem. Thanks!

Decreasing '''network.http.max-persistent-connections-per-server''' mainly solves the problem. Thanks!