X
Tap here to go to the mobile version of the site.

Support Forum

Windows 10 Firewall created block incoming rules for firefox

Posted

I was browsing the web with Firefox 56.0.2 when Windows popped up a security dialog asking me to allow incoming connections, I canceled the dialog and Windows Firewall created two block rules for incoming connections, one for all TCP connections to Firefox.exe and another for all UDP connections to Firefox.exe. The only addon I have installed is AdBlock Plus.

Any idea why this suddenly happened after months of normal use?

I was browsing the web with Firefox 56.0.2 when Windows popped up a security dialog asking me to allow incoming connections, I canceled the dialog and Windows Firewall created two block rules for incoming connections, one for all TCP connections to Firefox.exe and another for all UDP connections to Firefox.exe. The only addon I have installed is AdBlock Plus. Any idea why this suddenly happened after months of normal use?

Chosen solution

Please consider turning on send info to Mozilla before posting a question. This helps us help you.

If you check your Update History it is possible you received a update to Windows Defender. Or it just realized that your Firefox is now a different version since running the current version.

Microsoft wants it to be your A/V & Firewall. It does none of it very well. Since found the rules, delete them and create a rule to allow or wait for it to again popup and this time make the appropriate choice to allow for both TCP/UDP.

I strongly suggest getting a proper Firewall that monitors TCP/UDP to Firefox and blocks ones that are in their rules that are actually malicious. I run Norton Security and am blocking thousands of malicious requests daily to both ports. It is also advisable to run a anti-malware program at the same time. I run Malwarebytes and it blocks stuff that Norton does not catch.

Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

More Information

Pkshadow
  • Top 10 Contributor
1058 solutions 14665 answers

Chosen Solution

Please consider turning on send info to Mozilla before posting a question. This helps us help you.

If you check your Update History it is possible you received a update to Windows Defender. Or it just realized that your Firefox is now a different version since running the current version.

Microsoft wants it to be your A/V & Firewall. It does none of it very well. Since found the rules, delete them and create a rule to allow or wait for it to again popup and this time make the appropriate choice to allow for both TCP/UDP.

I strongly suggest getting a proper Firewall that monitors TCP/UDP to Firefox and blocks ones that are in their rules that are actually malicious. I run Norton Security and am blocking thousands of malicious requests daily to both ports. It is also advisable to run a anti-malware program at the same time. I run Malwarebytes and it blocks stuff that Norton does not catch.

Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

Please consider turning on send info to Mozilla before posting a question. This helps us help you. If you check your Update History it is possible you received a update to Windows Defender. Or it just realized that your Firefox is now a different version since running the current version. Microsoft wants it to be your A/V & Firewall. It does none of it very well. Since found the rules, delete them and create a rule to allow or wait for it to again popup and this time make the appropriate choice to allow for both TCP/UDP. I strongly suggest getting a proper Firewall that monitors TCP/UDP to Firefox and blocks ones that are in their rules that are actually malicious. I run Norton Security and am blocking thousands of malicious requests daily to both ports. It is also advisable to run a anti-malware program at the same time. I run Malwarebytes and it blocks stuff that Norton does not catch. Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed. Please let us know if this solved your issue or if need further assistance.
cor-el
  • Top 10 Contributor
  • Moderator
16553 solutions 149454 answers

Helpful Reply

See also: *https://support.mozilla.org/en-US/kb/Firefox+makes+unrequested+connections