Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot get flash player to work. I am on the latest version.

  • 5 replies
  • 1 has this problem
  • 49 views
  • Last reply by FredMcD

more options

I have install the latest version of flash play for Firefox, version 27.0.0.170. When I try to play a video from a web page I get the following message "We're sorry but your browser does not support this video. Please install Adobe Flash version 10 or later".

All Replies (5)

more options
more options

This was not the problem. I am running the current drivers.

more options

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

more options

I disabled hardware acceleration but it did not fix the problem.

more options

I think it's time to ask here; Adobe Support https://forums.adobe.com/community/flashplayer