X
Tap here to go to the mobile version of the site.

Support Forum

mp4 color is different on Firefox

Posted

We're experiencing a strange bug. We created a page with an embedded mp4. Both of them have the same background color. On Chrome and IE the background color stays the same, but on Firefox, the video has different colors.

We created this demo so you can view the bug as well: http://downloads.perplex.eu/firefox/index.html


Hope you can help.

Kind regards,

Henk van der Velden

We're experiencing a strange bug. We created a page with an embedded mp4. Both of them have the same background color. On Chrome and IE the background color stays the same, but on Firefox, the video has different colors. We created this demo so you can view the bug as well: http://downloads.perplex.eu/firefox/index.html Hope you can help. Kind regards, Henk van der Velden

Modified by henkvandervelden

Chosen solution

Solution: We ended up running our video through http://www.videosmaller.com/ which strips the video of its colorprofile.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

More Information

Pkshadow
  • Top 10 Contributor
228 solutions 2392 answers

HI, could you please edit out identifiable info. Thank You.

Sorry I see no difference what so ever in the video in Seamonkey, Edge or Firefox.

HI, could you please edit out identifiable info. Thank You. Sorry I see no difference what so ever in the video in Seamonkey, Edge or Firefox.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15572 solutions 141014 answers

On what page on the website can we see this MP4 video?

You can try to disable hardware acceleration in Firefox.

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

On what page on the website can we see this MP4 video? You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Was this helpful to you? 0
Quote

Question owner

@cor-el I turned of the performance settings and the hardware acceleration, still have the same problem.

I've added a screenshot for comparison.

@cor-el I turned of the performance settings and the hardware acceleration, still have the same problem. I've added a screenshot for comparison.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15572 solutions 141014 answers

Try to set the gfx.color_management.mode pref to 0 (zero) on the about:config page to disable Color Management.

You need to close and restart Firefox to make the change effective. See:

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Try to set the gfx.color_management.mode pref to 0 (zero) on the about:config page to disable Color Management. You need to close and restart Firefox to make the change effective. See: * http://kb.mozillazine.org/gfx.color_management.mode You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you? 0
Quote

Question owner

@cor-el I turned the color management mode to 0, still no effect I'm afraid.

@cor-el I turned the color management mode to 0, still no effect I'm afraid.
Was this helpful to you?
Quote
smorele
  • Top 25 Contributor
34 solutions 252 answers

Hi, do you have a transparent mask in your video?

Hi, do you have a transparent mask in your video?
Was this helpful to you?
Quote

Question owner

smorele said

Hi, do you have a transparent mask in your video?

At the moment I do not, I have been looking at examples that use a mask, it could be an option,

''smorele [[#answer-1021267|said]]'' <blockquote> Hi, do you have a transparent mask in your video? </blockquote> At the moment I do not, I have been looking at examples that use a mask, it could be an option,
Was this helpful to you?
Quote

Chosen Solution

Solution: We ended up running our video through http://www.videosmaller.com/ which strips the video of its colorprofile.

'''Solution: We ended up running our video through http://www.videosmaller.com/ which strips the video of its colorprofile.'''
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.