X
Tap here to go to the mobile version of the site.

Support Forum

Make firefox patient again ? #dns

Posted

Modify anything in about:config so that firefox becomes more tolerant to slow dns servers, before emmiting 'server not found'. I'm using OpenNIC servers for privacy, and i need to repeatedly hit ctrl+r before website loads. It is clear to me that firefox has a very small waiting period before deciding that a 'server was not found' ie. dns server was slow to respond. I don't want to use another dns server because either my privacy will be compromised or it's slow. No proxies, firewall, etc are a problem. My router caches dns queries, but some entries like facebook have very small TTL values like 1-2min which makes you go to the remote dns server periodically, with the above mentioned problems. I looked up dns in about config, but nothing seems relevant. So can we make firefox a little more patient?

Modify anything in about:config so that firefox becomes more tolerant to slow dns servers, before emmiting 'server not found'. I'm using OpenNIC servers for privacy, and i need to repeatedly hit ctrl+r before website loads. It is clear to me that firefox has a very small waiting period before deciding that a 'server was not found' ie. dns server was slow to respond. I don't want to use another dns server because either my privacy will be compromised or it's slow. No proxies, firewall, etc are a problem. My router caches dns queries, but some entries like facebook have very small TTL values like 1-2min which makes you go to the remote dns server periodically, with the above mentioned problems. I looked up dns in about config, but nothing seems relevant. So can we make firefox a little more patient?

Chosen solution

Hello, can you try to play with this 2 options in about:config:

  • accessibility.typeaheadfind.enabletimeout to enable or disable the timeout. Value is set to True by default.
  • accessibility.typeaheadfind.timeout to increase or decrease the timeout value

Hope this helps.

Read this answer in context 2
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

More Information

smorele 44 solutions 310 answers

Chosen Solution

Hello, can you try to play with this 2 options in about:config:

  • accessibility.typeaheadfind.enabletimeout to enable or disable the timeout. Value is set to True by default.
  • accessibility.typeaheadfind.timeout to increase or decrease the timeout value

Hope this helps.

Hello, can you try to play with this 2 options in '''about:config''': * '''accessibility.typeaheadfind.enabletimeout''' to enable or disable the timeout. Value is set to True by default. * '''accessibility.typeaheadfind.timeout''' to increase or decrease the timeout value Hope this helps.
Was this helpful to you? 2
Quote
alanem 0 solutions 5 answers

This solution doesn't do anything for me.

This solution doesn't do anything for me.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15983 solutions 144453 answers

See this old blog post about modifying a registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DNSQueryTimeouts
Multi String: "1 2 2 4 8 0" -> "4 8 8 16 32 0"
See this old blog post about modifying a registry key: *http://drewthaler.blogspot.com/2005/09/changing-dns-query-timeout-in-windows.html HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DNSQueryTimeouts Multi String: "1 2 2 4 8 0" -> "4 8 8 16 32 0"
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.