X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashing certain websites/Ubuntu

Posted

Hello everyone.

I'm trying this again. Firefox crashed when I was logged in so I'm doing this in Chromiun now. I'm running Ubuntu 14.04 LTS 64 bit. Firefox is 56.0 64 bit. About one week ago, I received a notice about an Ubuntu update so I installed the update as always. After the update, on certain websites, they start to load then Firefox crashes. I was on this site eailer and typing this when I opened another tab to see what plugins were installed and it crashed. I was using Adblock, Noscripts and other plug-ins. I disabled each one, one at a time, and it still crashed. I then did a refresh on Firefox to have only the minimum orginal plug-ins installed. It still crashes. I then totally removed Firefox and deleted the /.mozilla directory and reinstalled. No change.

Now, The default plugins are: OpenH264 Video Codec provided by Cisco Systems, Inc & Shockwave Flash

    The default Extensions are: Safe Browsing Version 4 (temporary add-in) & Ubuntu Modifications Legacy

If I disable them each by hand, Firefox will still crash. If I disable them by restarting in safe mode, Firefox will work as normal. Here are at least two sites that won't load:

https://www.dxengineering.com/ http://www.earthcam.com/usa/michigan/grandhaven/lakemichigan/?cam=lakemichigan

Hope this helps. Many thanks all. Mike

Hello everyone. I'm trying this again. Firefox crashed when I was logged in so I'm doing this in Chromiun now. I'm running Ubuntu 14.04 LTS 64 bit. Firefox is 56.0 64 bit. About one week ago, I received a notice about an Ubuntu update so I installed the update as always. After the update, on certain websites, they start to load then Firefox crashes. I was on this site eailer and typing this when I opened another tab to see what plugins were installed and it crashed. I was using Adblock, Noscripts and other plug-ins. I disabled each one, one at a time, and it still crashed. I then did a refresh on Firefox to have only the minimum orginal plug-ins installed. It still crashes. I then totally removed Firefox and deleted the /.mozilla directory and reinstalled. No change. Now, The default plugins are: OpenH264 Video Codec provided by Cisco Systems, Inc & Shockwave Flash The default Extensions are: Safe Browsing Version 4 (temporary add-in) & Ubuntu Modifications Legacy If I disable them each by hand, Firefox will still crash. If I disable them by restarting in safe mode, Firefox will work as normal. Here are at least two sites that won't load: https://www.dxengineering.com/ http://www.earthcam.com/usa/michigan/grandhaven/lakemichigan/?cam=lakemichigan Hope this helps. Many thanks all. Mike
Attached screenshots

Chosen solution

It is video card drivers doing the crashing it seems by the report "libnvidia-glcore.so.304.135". https://www.google.ca/search?q=firefox+libnvidia-glcore.so.304.135&ie=utf-8&oe=utf-8&gws_rd=cr&dcr=0&ei=uibjWeDTAYGDjwT_jLvwAg Is a older card I would be guessing from what I see from the search. Can you please do if you can running that OS https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try No Hardware Acceleration.

As per what FredMcD said you did not answer so post is above again. That should be the solution and if it does not work you might need to go to the Extended Release Version https://www.mozilla.org/en-US/firefox/organizations/ as your vid card might not be able to handle things anymore.

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/61.0.3163.100 Chrome/61.0.3163.100 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
3215 solutions 43389 answers

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15669 solutions 141732 answers

Did you send the crash report?

If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-".

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page".

  • click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.

Alternatively you can open about:crashes via the location/address bar.

See also:

Did you send the crash report? If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-". *bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page". *click the "All Crash Reports" button on this page to open the <b>about:crashes</b> page and see all crash reports. Alternatively you can open about:crashes via the location/address bar. See also: *http://kb.mozillazine.org/Mozilla_Crash_Reporter *https://support.mozilla.org/en-US/kb/Mozilla+Crash+Reporter
Was this helpful to you?
Quote

Question owner

This did not help. I sent a crash report bp-da64d2eb-3289-48ca-82e6-e70b01171014.

Thanks so far. Mike

This did not help. I sent a crash report bp-da64d2eb-3289-48ca-82e6-e70b01171014. Thanks so far. Mike
Was this helpful to you?
Quote
Pkshadow
  • Top 10 Contributor
375 solutions 3974 answers

Chosen Solution

It is video card drivers doing the crashing it seems by the report "libnvidia-glcore.so.304.135". https://www.google.ca/search?q=firefox+libnvidia-glcore.so.304.135&ie=utf-8&oe=utf-8&gws_rd=cr&dcr=0&ei=uibjWeDTAYGDjwT_jLvwAg Is a older card I would be guessing from what I see from the search. Can you please do if you can running that OS https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try No Hardware Acceleration.

As per what FredMcD said you did not answer so post is above again. That should be the solution and if it does not work you might need to go to the Extended Release Version https://www.mozilla.org/en-US/firefox/organizations/ as your vid card might not be able to handle things anymore.

Please let us know if this solved your issue or if need further assistance.

It is video card drivers doing the crashing it seems by the report "libnvidia-glcore.so.304.135". https://www.google.ca/search?q=firefox+libnvidia-glcore.so.304.135&ie=utf-8&oe=utf-8&gws_rd=cr&dcr=0&ei=uibjWeDTAYGDjwT_jLvwAg Is a older card I would be guessing from what I see from the search. Can you please do if you can running that OS https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try No Hardware Acceleration. As per what FredMcD said you did not answer so post is above again. That should be the solution and if it does not work you might need to go to the Extended Release Version https://www.mozilla.org/en-US/firefox/organizations/ as your vid card might not be able to handle things anymore. Please let us know if this solved your issue or if need further assistance.

Modified by Pkshadow

Was this helpful to you? 1
Quote

Question owner

Thank you very much FredMcD and Pkshadow. I changed the video driver and it appears to be working. Many, many thanks again. This can be marked as solved. Mike

Thank you very much FredMcD and Pkshadow. I changed the video driver and it appears to be working. Many, many thanks again. This can be marked as solved. Mike
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.