X
Tap here to go to the mobile version of the site.

Support Forum

all text on certain websites appears in question marks

Posted

hello,

since today I notice that all text in firefox (56.0 mac-version) on certain sites appears only in question marks (in suqares). looks like that on sites like mozilla support (busy right now in safari) google.com, my banking site, tmobile, gmail and a lot other ones too. all those sites show totally normal in other brouwsers.

did the following troubleshoot 1) view > text encoding > unicode = OK 2) preferences Font & Color > advanced > checked 'allow pages to choose their own font' = OK

any other suggestions? (:

tried to enclose some screenshots (small jpg and png files) but the upload keeps spinning for ever... never mind.

thanks in advance for any help on the questionmark problem.

hello, since today I notice that all text in firefox (56.0 mac-version) on certain sites appears only in question marks (in suqares). looks like that on sites like mozilla support (busy right now in safari) google.com, my banking site, tmobile, gmail and a lot other ones too. all those sites show totally normal in other brouwsers. did the following troubleshoot 1) view > text encoding > unicode = OK 2) preferences Font & Color > advanced > checked 'allow pages to choose their own font' = OK any other suggestions? (: tried to enclose some screenshots (small jpg and png files) but the upload keeps spinning for ever... never mind. thanks in advance for any help on the questionmark problem.

Chosen solution

This bug might be relevant:

Fonts don't display correctly since update due to content-process sandboxing on macOS (#1404919)

Key points:

(A) One workaround is to reduce sandboxing as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and reduce the value from its default value of 3 to 1 and click OK

This reverts the sandbox level in Firefox 56 to what it was in Firefox 52-55 on Mac

That won't take effect until the next time you quit and restart Firefox.

(B) One possible reason for the problem is fonts in a "suitcase" or "Postscript Type 1" format

According to a comment in the bug, Firefox currently will only load fonts with certain file extensions (.otf, .ttf, .ttc, .otc, and .dfont). Other fonts will not load and Firefox will need to use a fallback fonts. There may need to be a change in a future version of Firefox to handle other common font extensions, or to do a better job choosing a fallback font.

Read this answer in context 11

Additional System Details

Installed Plug-ins

uBlock origin noscript https everywhere browsing protection savefromnet helper

all enabled since the problem appeared

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/604.1.38 (KHTML, like Gecko) Version/11.0 Safari/604.1.38

More Information

jscher2000
  • Top 10 Contributor
8790 solutions 71884 answers

Hi jonahleewalker, I suggest adding a comment to your bug that the workaround in

https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c1

worked for you. They probably will mark your bug as a duplicate of the earlier one, and they might ask you for more information about your system. If you look at

https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c7

there's a method to extract a list of your fonts that might be helpful since they are researching which file extensions the font files have. That could be helpful.

Hi jonahleewalker, I suggest adding a comment to your bug that the workaround in https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c1 worked for you. They probably will mark your bug as a duplicate of the earlier one, and they might ask you for more information about your system. If you look at https://bugzilla.mozilla.org/show_bug.cgi?id=1404919#c7 there's a method to extract a list of your fonts that might be helpful since they are researching which file extensions the font files have. That could be helpful.

Modified by jscher2000

Question owner

THIS IS REALLY GREAT!

The sandboxing-thing as explained under (A) from jscher2000 fixed the problem for me as well! all text on all sites shows now properly under 56.0., NoScript enabled, no more question marks.

befor I did the sandboxing-attempt though, I run a font-test first to check (B) as presumed by jscher2000 that there might be the reason of the problem. as soon as I closed the activated Arial postscript T1 version (running font-program: LinotypeFontexplorerX) everything showed normally readable as well!

so here we go: the problem is narrowed down and temporary fixable even for technical-dumbos like myself!

A solution without workaround and/or a firefox version that would solve that problem is definately needed thoug for the future.

THANK YOU all for all your help!

THIS IS REALLY GREAT! The sandboxing-thing as explained under (A) from jscher2000 fixed the problem for me as well! all text on all sites shows now properly under 56.0., NoScript enabled, no more question marks. befor I did the sandboxing-attempt though, I run a font-test first to check (B) as presumed by jscher2000 that there might be the reason of the problem. as soon as I closed the activated Arial postscript T1 version (running font-program: LinotypeFontexplorerX) everything showed normally readable as well! so here we go: the problem is narrowed down and temporary fixable even for technical-dumbos like myself! A solution without workaround and/or a firefox version that would solve that problem is definately needed thoug for the future. THANK YOU all for all your help!

Modified by slaws2