Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get the message: You will need the location services enabled for your browser. How do I do this?

  • 2 replies
  • 2 have this problem
  • 3 views
  • Last reply by Kullaroo

more options

When I try to change the store nearest to me in my Club website, I get the error: "You will need the location services enabled for your browser." I cannot find any reference to "location services" in the Firefox option (v55.0.3). How can I find and set this option, please?

All Replies (2)

more options

Might want to update Firefox to latest Version 56.0 From Help --> About

Once updated see if that fixes your issue.

Actually can not find you is wonderful, wish I had that issue or was a option.

Just to let you know there is by seeing your Graphic Card info that there is updated drivers released 6/23/17 https://downloadcenter.intel.com/product/86210/Intel-HD-Graphics-5500

Please let us know if this solved your issue or if need further assistance.

more options

Thanks for that. I did the update to v56 but still have the same issue with the same web site.

The Intel download center referred to the manufacturer's support site. I went there but my model was not listed in ASUSPro series (I have P2520LA, but the only model listed was the P2520SJ). I'll do more checking to see if there is an update for my machine.