X
Tap here to go to the mobile version of the site.

Support Forum

My Firefox browser doesn't do auto login when I enter the websites, anybody know how to fix it?

Posted

When I enter some site such as Facebook or Youtube, the browser doesn't auto login. I have to manually type the username and password myself.

When I enter some site such as Facebook or Youtube, the browser doesn't auto login. I have to manually type the username and password myself.

Chosen solution

I think I just fixed it. I went to Preferences > Privacy. Then, in the History section, I changed the Firefox will: from "Use custom settings for history" to "Remember History", and it works.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

Happy112 561 solutions 5694 answers

Hi   !

Would you make sure that you're not in permanent Private Browsing mode :

3-bar menu (or 'Tools') => Options => Privacy => Firefox will : 'Use custom settings for history' Uncheck : 'Always use private browsing mode'

And in Options => Security => under 'Logins': make sure that 'Remember logins for sites' is checked.

https://support.mozilla.org/kb/Private+Browsing

Hi   ! Would you make sure that you're not in permanent Private Browsing mode : 3-bar menu (or 'Tools') => Options => Privacy => Firefox will : 'Use custom settings for history' Uncheck : 'Always use private browsing mode' And in Options => Security => under 'Logins': make sure that 'Remember logins for sites' is checked. https://support.mozilla.org/kb/Private+Browsing

Helpful Reply

Yes, the private browsing is unchecked and the 'Remember logins' is enabled, but the browser still not doing an auto login.

Yes, the private browsing is unchecked and the 'Remember logins' is enabled, but the browser still not doing an auto login.
Happy112 561 solutions 5694 answers

Would you check this setting :

Type in the address bar about:config (press Enter) (promise to be careful, if asked) Type in the search bar signon and look for the preference : signon.rememberSignons it's value should be set to true

Would you check this setting : Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type in the search bar '''signon''' and look for the preference : '''signon.rememberSignons''' it's value should be set to '''true'''

Question owner

I checked it, it marks as 'true'.

Is it possible that it might be some sort of settings? Since when I signing in my Firefox account to the browser in another computer, it also doesn't auto login.

Also, I have a Tor browser installed in my computer, not sure if this causing the problem.

I checked it, it marks as 'true'. Is it possible that it might be some sort of settings? Since when I signing in my Firefox account to the browser in another computer, it also doesn't auto login. Also, I have a Tor browser installed in my computer, not sure if this causing the problem.
Happy112 561 solutions 5694 answers

Boyd951 said

Is it possible that it might be some sort of settings?

You checked the settings and they were all correct .....

Would you consider this add-on :

https://addons.mozilla.org/en-US/firefox/addon/secure-login-webextension/

''Boyd951 [[#answer-1008290|said]]'' <blockquote> Is it possible that it might be some sort of settings? </blockquote> You checked the settings and they were all correct ..... Would you consider this add-on : https://addons.mozilla.org/en-US/firefox/addon/secure-login-webextension/

Question owner

Hi,

The add-on automatically fill the username and password when I click the lock icon at the top left. However, in the past time, the site automatically login after I open it, and does the same after I reopen the browser. But now, after I reopen the browser, the site is signing off and I have to login again. Is there any Firefox changes that I don't know?

Hi, The add-on automatically fill the username and password when I click the lock icon at the top left. However, in the past time, the site automatically login after I open it, and does the same after I reopen the browser. But now, after I reopen the browser, the site is signing off and I have to login again. Is there any Firefox changes that I don't know?
Happy112 561 solutions 5694 answers

Boyd951 said

Also, I have a Tor browser installed in my computer, not sure if this causing the problem.

That shouldn't have any effect :

https://ssd.eff.org/en/module/how-use-tor-macos

''Boyd951 [[#answer-1008290|said]]'' <blockquote> Also, I have a Tor browser installed in my computer, not sure if this causing the problem. </blockquote> That shouldn't have any effect : https://ssd.eff.org/en/module/how-use-tor-macos
Happy112 561 solutions 5694 answers

You can check in the Password Manager if you have multiple names saved from the domain because that will prevent Firefox from filling the name automatically.

3-bar menu (or 'Tools') => Options => Security : Passwords : 'Saved Passwords' => 'Show Passwords'

You could also check in 'about:config' the preference :

signon.autofillForms Its value should be set to true

You can check in the Password Manager if you have multiple names saved from the domain because that will prevent Firefox from filling the name automatically. 3-bar menu (or 'Tools') => Options => Security : Passwords : 'Saved Passwords' => 'Show Passwords' You could also check in 'about:config' the preference : '''signon.autofillForms''' Its value should be set to '''true'''

Question owner

The Password Manager Looks fine and the signon.autofillForms is already set to true. Should the signon.autofillForms.http and signon.autologin.proxy be set to true as well?

The Password Manager Looks fine and the '''signon.autofillForms''' is already set to true. Should the '''signon.autofillForms.http '''and '''signon.autologin.proxy''' be set to true as well?
Happy112 561 solutions 5694 answers

Not giving up just yet .......

Let's start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem.

If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

And also : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Not giving up just yet ....... Let's start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem. If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !) See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode And also : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

Still not auto login in the safe mode. Even when all the add-ons, hardware acceleration and extension turning off.

Still not auto login in the safe mode. Even when all the add-ons, hardware acceleration and extension turning off.

Question owner

The reason why I suspect the Tor browser is because this happens after I've installed the Tor browser. There also have some Tor sites bookmark automatically added to Firefox.

The reason why I suspect the Tor browser is because this happens after I've installed the Tor browser. There also have some Tor sites bookmark automatically added to Firefox.
Happy112 561 solutions 5694 answers

Boyd951 said

The reason why I suspect the Tor browser is because this happens after I've installed the Tor browser. There also have some Tor sites bookmark automatically added to Firefox.

Only one way to find out ...... (Firefox acting like a woman scorned, since you installed another browser)


Running completely out of ideas, but giving it one more shot :

In case you use "Clear history when Firefox closes" or otherwise clear history :

do not clear the Cookies do not clear the Site Preferences

Options => Privacy => Firefox will : "Use custom settings for history" : [X] "Clear history when Firefox closes" => Settings

https://support.mozilla.org/kb/remove-recent-browsing-search-and-download-history

Clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data.

Clearing cookies will remove all selected cookies including cookies with an "Allow" exception you may want to keep.

''Boyd951 [[#answer-1008341|said]]'' <blockquote> The reason why I suspect the Tor browser is because this happens after I've installed the Tor browser. There also have some Tor sites bookmark automatically added to Firefox. </blockquote> Only one way to find out ...... (Firefox acting like a woman scorned, since you installed another browser) ----------------------------------------------------------------------------------------------------------- Running completely out of ideas, but giving it one more shot : In case you use "Clear history when Firefox closes" or otherwise clear history : do not clear the Cookies do not clear the Site Preferences Options => Privacy => Firefox will : "Use custom settings for history" : [X] "Clear history when Firefox closes" => Settings https://support.mozilla.org/kb/remove-recent-browsing-search-and-download-history Clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data. Clearing cookies will remove all selected cookies including cookies with an "Allow" exception you may want to keep.

Modified by Happy112

Question owner

A little miracle happened here. I signed in my Firefox sync account to the browser in my another computer but unchecked the add-ons and preference syncing, the another computer doesn't have a problem. So, the problem seems to be the settings or add-ons.

A little miracle happened here. I signed in my Firefox sync account to the browser in my another computer but unchecked the add-ons and preference syncing, the another computer doesn't have a problem. So, the problem seems to be the settings or add-ons.

Question owner

This is weird since the cookies and site preferences are both unchecked.

This is weird since the '''cookies''' and '''site preferences''' are both unchecked.
Happy112 561 solutions 5694 answers

Boyd951 said

A little miracle happened here. I signed in my Firefox sync account to the browser in my another computer but unchecked the add-ons and preference syncing, the another computer doesn't have a problem. So, the problem seems to be the settings or add-ons.

Then, would you disable them again (Safe Mode will do that for you) and then re-enable them one by one till you find the culprit  ? And when you find it : let us know ......

''Boyd951 [[#answer-1008353|said]]'' <blockquote> A little miracle happened here. I signed in my Firefox sync account to the browser in my another computer but unchecked the add-ons and preference syncing, the another computer doesn't have a problem. So, the problem seems to be the settings or add-ons. </blockquote> Then, would you disable them again (Safe Mode will do that for you) and then re-enable them one by one till you find the culprit ? And when you find it : let us know ......

Chosen Solution

I think I just fixed it. I went to Preferences > Privacy. Then, in the History section, I changed the Firefox will: from "Use custom settings for history" to "Remember History", and it works.

I think I just fixed it. I went to '''Preferences''' > '''Privacy'''. Then, in the '''History''' section, I changed the '''Firefox will:''' from "Use custom settings for history" to "Remember History", and it works.
Happy112 561 solutions 5694 answers

Boyd951 said

I think I just fixed it. I went to Preferences > Privacy. Then, in the History section, I changed the Firefox will: from "Use custom settings for history" to "Remember History", and it works.

Yay  !   Finally  ! Would you be a dear and mark your last post as 'Chosen Solution' - that way others will know and might benefit from it.

Well done  !

''Boyd951 [[#answer-1008357|said]]'' <blockquote> I think I just fixed it. I went to '''Preferences''' > '''Privacy'''. Then, in the '''History''' section, I changed the '''Firefox will:''' from "Use custom settings for history" to "Remember History", and it works. </blockquote> Yay ! &nbsp; Finally ! Would you be a dear and mark your last post as 'Chosen Solution' - that way others will know and might benefit from it. Well done !

Question owner

Thanks for the help!!!

Thanks for the help!!!
Happy112 561 solutions 5694 answers

Boyd951 said

Thanks for the help!!!

My pleasure   !

One little thing though : You inadvertenly marked my post as 'Chosen Solution', while it was you who solved the problem ...... You can rectify that by clicking the Undo button to the right, and then mark your post (the one that says what solved the problem) as such.

You've done a great job  !

''Boyd951 [[#answer-1008360|said]]'' <blockquote> Thanks for the help!!! </blockquote> My pleasure &nbsp; ! One little thing though : You inadvertenly marked my post as 'Chosen Solution', while it was '''you''' who solved the problem ...... You can rectify that by clicking the ''Undo'' button to the right, and then mark '''your''' post (the one that says what solved the problem) as such. You've done a great job !