X
Tap here to go to the mobile version of the site.

Support Forum

Why does single click on a background tab almost always close the tab?

Posted

Environment: - Firefox v. 55 - macOS Sierra 10.12.6 - Typical browser session = 5 to 20 tabs

Behavior change: When I single click a background tab to bring it forward, the tab closes 3 out of 5 times.

I am careful to not click the X in the tab's right-hand corner. While there's an obvious risk of hitting that bullseye when I have 20+ tabs open (e.g., can't even see the X), the tab "crash" occurs when I have as few as 3 tabs open and am clicking right in the middle of that wide thing.

I would prefer to not have to pin or protect every tab I open. And while I can easily recover a closed tab, there is data loss if I was in the middle of editing or composing something on that closed page.

I checked my mouse settings in System Preferences, but there's only an option to change the double-click speed. There is no setting for single click behavior that I can find, and internet searches haven't helped. I am perplexed.

Environment: - Firefox v. 55 - macOS Sierra 10.12.6 - Typical browser session = 5 to 20 tabs Behavior change: When I single click a background tab to bring it forward, the tab closes 3 out of 5 times. I am careful to not click the X in the tab's right-hand corner. While there's an obvious risk of hitting that bullseye when I have 20+ tabs open (e.g., can't even see the X), the tab "crash" occurs when I have as few as 3 tabs open and am clicking right in the middle of that wide thing. I would prefer to not have to pin or protect every tab I open. And while I can easily recover a closed tab, there is data loss if I was in the middle of editing or composing something on that closed page. I checked my mouse settings in System Preferences, but there's only an option to change the double-click speed. There is no setting for single click behavior that I can find, and internet searches haven't helped. I am perplexed.

Chosen solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

FredMcD
  • Top 10 Contributor
3668 solutions 50315 answers

Chosen Solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

That worked. After the restart without addons, I examined my extensions and saw all those new LEGACY labels. Tabs Mix Plus was likely the problem. Thanks.

That worked. After the restart without addons, I examined my extensions and saw all those new LEGACY labels. Tabs Mix Plus was likely the problem. Thanks.
FredMcD
  • Top 10 Contributor
3668 solutions 50315 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

Legacy just means that in a future version, those add-oms will not work in Firefox. They will need to be rewritten or replaced.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know. Legacy just means that in a future version, those add-oms will not work in Firefox. They will need to be rewritten or replaced.