Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The color of video playback on Firefox is inaccurate as compared to Chrome & Safari, can this be fixed?

  • 2 replies
  • 2 have this problem
  • 5 views
  • Last reply by cor-el

more options

I'm a video content creator & Firefox (my personal fav browser) consistently plays back inaccurate colors on Vimeo and other streaming destinations. Chrome & Safari playback colors match my original source videos, but Firefox injects a ton of incorrect color. My understanding is the video decoding happens in the browser, is there an awareness of this problem and are there any plans for Firefox to address this? If fixing it requires any lifting on the part of the end user that'd be disappointing since the average user will just see the incorrect video colors and move on.

The attached screengrab shows correct color in Chrome on the left, and altered Firefox color on the right.

Thanks!

I'm a video content creator & Firefox (my personal fav browser) consistently plays back inaccurate colors on Vimeo and other streaming destinations. Chrome & Safari playback colors match my original source videos, but Firefox injects a ton of incorrect color. My understanding is the video decoding happens in the browser, is there an awareness of this problem and are there any plans for Firefox to address this? If fixing it requires any lifting on the part of the end user that'd be disappointing since the average user will just see the incorrect video colors and move on. The attached screengrab shows correct color in Chrome on the left, and altered Firefox color on the right. Thanks!
Attached screenshots

All Replies (2)

more options
more options

Are you using a special color profile for your monitor/

Try to disable color management to test if it is caused by a problem with color management. You can set the gfx.color_management.mode pref to 0 on the about:config page to disable Color Management. You need to close and restart Firefox to make the change effective.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.