Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does thunderbird convert links to plain text?

  • 20 replies
  • 3 have this problem
  • 31 views
  • Last reply by eddleetham

more options

On emails that originate from the Android email app, hyperlinks arrive as plain text in Thuderbird only. If i go to the web site for the email account, the links are active. Links sent from other sources and apps seem fine. Given that the links are present everywhere but Thuderbird when missing, it has to be Thunderbird.

All Replies (20)

more options

Given many mail programs look for what looks like links and linkify them it may well be the links are not links, or the colour of links is set in such a way as to not be apparent unless you hover over them with the mouse and the cursor changes.

more options

The problem is that some mobile mail apps do not have the option to send mail as plain text, so a link that is typed directly as http://url.lnk is not clickable when received by TB. If the sender embeds the link in text, such as link, i.e. they send in 'rich text' format, then that link is clickable in TB. Ask an Android or other mobile user to send you links embedded in text if this is a common event.

There is an add-on for handling such links.

more options

I don't understand the assumption that when I said the links were 'active', that that meant I had only seen them as blue text.

Bottom line: the links are active and real everywhere EXCEPT in Thunderbird.

more options

I think that the answer here is not so much that Thunderbird converts links to plain text, but rather that it fails to convert plain text that looks like a link into an actual link.

As said, there are addons that will repair i.e. "linkify" appropriately constructed text.

more options

The add-on mentioned above is "URL Link", but this only works as an add-on in Firefox. Which is no use if it's Thunderbird that is not displaying a link.

This displaying of a link as plain text only happens with mail from one sender, which suggests it's their fault. However if I view the email in my 1and1 online email viewer before I download it to Thunderbird, it's shown as a working clickable link.

So why is the link not clickable when it reaches Thunderbird? The sender has told me that no-one else has reported a problem with the links.

more options

So, what's different about these non-working links?

Do they have an http:// or a www? Some protocol prefixes, like ftp: are not universally recognized as URLs. Thunderbird is slightly picky (read: "standards compliant") and needs a full explicit valid URL e.g. file:// needed when sending links to files on a local server, mailto: needed to make an active phone number link.

Other programs may be more prone to guessing and attempting auto-completion. You may be the only one of this person's correspondents using Thunderbird.

I just sent myself a link from my Android (Motorola G5) phone, using the default Gmail app, to an account that I use in Thunderbird. The link received looked like this:

www.bbc.co.uk/news

but when I sniff it with the cursor, Thunderbird shows it as

http://www.bbc.co.uk/news

so Thunderbird has, in this case, filled in the missing bits it wanted. The same seems to happen on this forum too. Or maybe that's my browser (Vivaldi) doing it.

I'm not sure what "the Android email app" means. Manufacturers like Samsung tend to load in their own proprietary variations of standard apps. I don't like the Google UX, so I seek alternatives where possible, so I use TypeApp on my tablet. So, who knows what your correspondent us actually using?

more options

And the intervening servers can affect things too. That same message was relayed via a googlemail account and read in Thunderbird, where it was rendered as www.bbc.co.uk/news<http://www.bbc.co.uk/news> so Google have actually "linkified" it for me.

Modified by Zenos

more options

"URL Link is a small Firefox and Thunderbird extension that allows you to select a non-URL in a mail/news message or web-page, and open it in a browser window."

Are you saying it won't install into Thunderbird, or does but then doesn't work?

more options

I simply followed the link and read this:

URL Link has been wholly re-written to be a WebExtension. This new version will not work on Thunderbird as it does not support WebExtensions.

more options

I got mine from here:

https://addons.mozilla.org/en-US/firefox/addon/url-link/versions/?page=1#version-2.04.5

Most add-ons have a "versions" page where you can find previous versions.

The "about" page still goes on about the new web extensions design, but the add-on itself is of the previous and compatible design.

When installed, if you select the supposed link's text and right-click, there is a "open with" option. Actually it's hardly any easier than copy and pasting to a browser, if it's not so broken that your browser couldn't work with it. But this add-on will help with supplying any missing parts.

more options

Zenos said

So, what's different about these non-working links? Do they have an http:// or a www? Some protocol prefixes, like ftp: are not universally recognized as URLs. Thunderbird is slightly picky (read: "standards compliant") and needs a full explicit valid URL e.g. file:// needed when sending links to files on a local server, mailto: needed to make an active phone number link.

No it seems to be a complete link address:- http://thenantwichnews.co.uk/2017/12/12/residents-fears-over-welsh-row-traffic-plans-in-nantwich/

more options

That's quite a long URL. Is it wrapping to fit screen width and thereby being broken?

It certainly looks (and behaves) as a valid link here.

more options

The emails URLs have been that long for several years, but it's only very recently that they stopped behaving as links. Something changed, but I can't work out what or where.

more options

eddleetham said

The emails URLs have been that long for several years, but it's only very recently that they stopped behaving as links. Something changed, but I can't work out what or where.

I have just checked back through old emails and up to 30th November the links display as clickable links, but from 2nd December they are just plain text. So did anything change in Thunderbird at that time?

The links are clickable on my web host inbox, but they are not when they arrive in Thunderbird. My web host says it's fine leaving them, so it must be a problem with Thunderbird. What do others think?

more options

There's one other problem that started around the same time. When I receive a message from a group, and hit reply, it went to the Reply to: address. Now it's sent to the From: address, which is very annoying.

Could these two problems be connected or should I raise a separate query?

more options

A change in replying to mailing lists was introduced in TB 52, and you can read about how to revert to the old behaviour here.

As to whether the issue with links appeared in an update to TB around Nov. 30, that might be tested by installing a TB 52.* version, all of which are available here.

more options

Right, on looking at the source of the latest email I found this line: Content-Type: text/html; charset=UTF-8

while the source of the older email, which does display the links, shows: Content-Type: text/plain; charset=UTF-8

Also the source of the older email contains this line, while the newer one does not: Content-Transfer-Encoding: quoted-printable

Does this suggest an answer to anyone?

more options

sfhowes said

A change in replying to mailing lists was introduced in TB 52, and you can read about how to revert to the old behaviour here. As to whether the issue with links appeared in an update to TB around Nov. 30, that might be tested by installing a TB 52.* version, all of which are available here.

Yes, I've discovered that I now have to click Reply All in the email section, rather than Reply in the main menu.

But I would rather revert to the previous behaviour. I can't find this option in Preferences, so can you tell me how to find it please? Thanks.

more options

Open Tools/Options/Advanced/General/Config. editor, double-click the preference mail.override_list_reply_to to change it to false.

more options

Fantastic. That's just what I wanted. Many thanks.