X
Tap here to go to the mobile version of the site.

Support Forum

"detect portal"

Posted

Did a recent upgrade from 49 something 54.0.1, and now I am getting traffic (according to my logs and some Wire-shark sniffing) that is going to a "detect portal" at firefox dot com. This is going out as a "DNS query" according to the sniffer... and this causes some response traffic where a CNAME is being set for a couple of akamai dot net addresses (in my case, its a1089.d.akamai.net at 24.244.3.32 and a1089.d.akamai.net at 24.244.3.18.

This is traffic I do not want, and I have a ton of the "akamai dot net" addresses blocked (mostly from the OS boot process, which also goes out to do a DNS query and returns many other CNAME aliases. And yes, I do have my SHAW ISP's DNS servers defined so I am not even sure why THAT happens..

Anyway, getting a dozen or so outgoing attempts that are being blocked by PeerBlock. Not sure why this is needed, and I would like to be able to disable this, or turn it off totally...

Solutions? :) Thanks kindly in advance.

Did a recent upgrade from 49 something 54.0.1, and now I am getting traffic (according to my logs and some Wire-shark sniffing) that is going to a "detect portal" at firefox dot com. This is going out as a "DNS query" according to the sniffer... and this causes some response traffic where a CNAME is being set for a couple of akamai dot net addresses (in my case, its a1089.d.akamai.net at 24.244.3.32 and a1089.d.akamai.net at 24.244.3.18. This is traffic I do not want, and I have a ton of the "akamai dot net" addresses blocked (mostly from the OS boot process, which also goes out to do a DNS query and returns many other CNAME aliases. And yes, I do have my SHAW ISP's DNS servers defined so I am not even sure why THAT happens.. Anyway, getting a dozen or so outgoing attempts that are being blocked by PeerBlock. Not sure why this is needed, and I would like to be able to disable this, or turn it off totally... Solutions? :) Thanks kindly in advance.

Chosen solution

hi, this is part of captive portal detection which was introduced in firefox 52 - in order to disable that, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named network.captive-portal-service.enabled. double-click it and change its value to false.

Read this answer in context 11

Additional System Details

Installed Plug-ins

  • Shockwave Flash 24.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5150 solutions 22807 answers

Chosen Solution

hi, this is part of captive portal detection which was introduced in firefox 52 - in order to disable that, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named network.captive-portal-service.enabled. double-click it and change its value to false.

hi, this is part of captive portal detection which was introduced in firefox 52 - in order to disable that, enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''network.captive-portal-service.enabled'''. double-click it and change its value to '''false'''.

Helpful Reply

Perfect. Thanks very much.. I did do the 'config' and searched for 'detect' and noticed several things "captive" related but didn't find the on/off switch. Guess I didn't dig deep enough. :)

Perfect. Thanks very much.. I did do the 'config' and searched for 'detect' and noticed several things "captive" related but didn't find the on/off switch. Guess I didn't dig deep enough. :)