X
Tap here to go to the mobile version of the site.

Support Forum

My mouse slow down dramatically when I start Firefox.

Posted

I use Win XP on my Quad Core PC with 3GB RAM. All programs run fine. Just when I start Firefox, it runs so slow, that I wait 2-3 seconds for something to happen after I do it. Happens when I am typing something in Google search line, also now when I enter this text. The mouse also jumps from a position to a position 2-3 cm apart, there is no smooth movement. Installing updates did not help. I am running the latest version of Firefox. I also use Thunderbird, no problems there.

I use Win XP on my Quad Core PC with 3GB RAM. All programs run fine. Just when I start Firefox, it runs so slow, that I wait 2-3 seconds for something to happen after I do it. Happens when I am typing something in Google search line, also now when I enter this text. The mouse also jumps from a position to a position 2-3 cm apart, there is no smooth movement. Installing updates did not help. I am running the latest version of Firefox. I also use Thunderbird, no problems there.

Chosen solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Shockwave Flash 25.0 r0
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
3598 solutions 49161 answers

Chosen Solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?