Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't set Firefox as default browser Windows 10

  • 3 replies
  • 23 have this problem
  • 6799 views
  • Last reply by spb1957

more options

Hi guys My brother just got a new laptop which I have been setting up for him as he's not very computer literate. Problem I'm having is setting Firefox as the default browser because when I ask it to, I get taken to Windows default settings but Firefox is not on the list to change it to.......I only have options to set IE or Edge as default browser. Any ideas ? I tried searching the apps option, but Firefox is not in there either (unless I select the film!!). Seems to me Windows 10 doesn't recognise the fact that Firefox is installed on the computer (pre-installed, not downloaded)

Chosen solution

After some more Googling, I found the answer, so here it is for anyone else with the same problem. If you go in through Control Panel>Programs>Default Programs>Set Default Programs , you can then select Firefox (or whatever) from that list. The pic I have lifted from another site shows a slightly different path but the basis is the same.

Trying to use the system/set defaults just doesn't give the option.

Read this answer in context 👍 10

All Replies (3)

more options

Hi, sorry to hear you are having a problem; please see if you've missed any steps out - How to change your default browser in Windows 10.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Thanks for the reply, but no, I hadn't missed anything. The problem remains that Firefox is not in the list of options in Windows defaults settings

more options

Chosen Solution

After some more Googling, I found the answer, so here it is for anyone else with the same problem. If you go in through Control Panel>Programs>Default Programs>Set Default Programs , you can then select Firefox (or whatever) from that list. The pic I have lifted from another site shows a slightly different path but the basis is the same.

Trying to use the system/set defaults just doesn't give the option.