X
Tap here to go to the mobile version of the site.

Support Forum

Firefox still looking for proxy after changing system proxy to None in Linux

Posted

I work in an environment where I'm always switching between networks, one with a proxy and one without. I have a script that sets up the system proxy on my CentOS 7 workstation (Gnome 3.14.4) to either None or the URL of the PAC file. In specific situations, that happen frequently to me, Firefox (v.52.2 64-bit ESR) will remember the PAC settings and will give an "Unable to find the proxy server" error until I log out of the Gnome session and log back in with the system proxy set to none.

Steps to reproduce: 1. Connect to a network that has an automatic proxy configuration (PAC file). 2. Configure Firefox to use the system proxy. 2. Log in to Gnome and start Firefox. It will read the PAC file and start to do its thing. 3. Close Firefox and switch networks to one without a proxy server. I do this with gsettings commands in a shell script and verify the configuration in the Network app. 4. Start Firefox back up. It will fail to load up any pages, showing the proxy error instead. The only way to get it working again is to either set the proxy server in Firefox to None or log out of Gnome or log back in.

In my testing, when I set up the system proxy but I wasn't connected to the network to pull the PAC file, Firefox worked fine. Once the PAC file is read, however, Firefox will remember it until either a manual configuration or re-login.

FYI, I also have Chrome running on the same workstation and it doesn't exhibit this problem so I'm sure it's something in Firefox.

Thanks in advance.

I work in an environment where I'm always switching between networks, one with a proxy and one without. I have a script that sets up the system proxy on my CentOS 7 workstation (Gnome 3.14.4) to either None or the URL of the PAC file. In specific situations, that happen frequently to me, Firefox (v.52.2 64-bit ESR) will remember the PAC settings and will give an "Unable to find the proxy server" error until I log out of the Gnome session and log back in with the system proxy set to none. Steps to reproduce: 1. Connect to a network that has an automatic proxy configuration (PAC file). 2. Configure Firefox to use the system proxy. 2. Log in to Gnome and start Firefox. It will read the PAC file and start to do its thing. 3. Close Firefox and switch networks to one without a proxy server. I do this with gsettings commands in a shell script and verify the configuration in the Network app. 4. Start Firefox back up. It will fail to load up any pages, showing the proxy error instead. The only way to get it working again is to either set the proxy server in Firefox to None or log out of Gnome or log back in. In my testing, when I set up the system proxy but I wasn't connected to the network to pull the PAC file, Firefox worked fine. Once the PAC file is read, however, Firefox will remember it until either a manual configuration or re-login. FYI, I also have Chrome running on the same workstation and it doesn't exhibit this problem so I'm sure it's something in Firefox. Thanks in advance.

Additional System Details

Installed Plug-ins

  • The IcedTea-Web Plugin executes Java applets.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 52.2.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.2.0/Linux/en-US/

Extensions

  • Adblock Plus 2.9.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Proxy Switcher 0.1.9 (jid0-hjBdm7jJii7llLkqacvGnd3gHge@jetpack)
  • RESTClient 2.0.5 ({ad0d925d-88f8-47f1-85ea-8463569e756e})
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Humper -- Chromium
  • adapterDeviceID: Chromium
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Humper
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 2.1 Chromium 1.9
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Failed to create H264 decoder
  • webgl2Renderer: WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: * Exhausted GL driver options.
  • webglRenderer: WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: * Exhausted GL driver options.
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Tonnes
  • Locale Leader
246 solutions 1454 answers

It looks like you are using the Proxy Switcher add-on, so my first question would be: does the same thing happen when uninstalling that add-on, or when starting Firefox in Safe Mode (=ignoring all add-ons)? And, if you change settings using the gsettings commands, why would you need the add-on anyway, perhaps for switching manually?

It would make sense to assume Firefox does not pick up the changes made by the script but uses some cached settings instead, either from itself or from the add-on, so you should check the latter first. You may be able to add the -purgecaches option to start Firefox in order to pinpoint if this is caused by Firefox and work around it (source).

Additionally, this page shows several configuration options related to proxies (such as network.http.proxy.pipelining) that may cause the issue.

Could you report back?

It looks like you are using the Proxy Switcher add-on, so my first question would be: does the same thing happen when uninstalling that add-on, or when starting Firefox in Safe Mode (=ignoring all add-ons)? And, if you change settings using the gsettings commands, why would you need the add-on anyway, perhaps for switching manually? It would make sense to assume Firefox does not pick up the changes made by the script but uses some cached settings instead, either from itself or from the add-on, so you should check the latter first. You may be able to add the ''-purgecaches'' option to start Firefox in order to pinpoint if this is caused by Firefox and work around it ([https://developer.mozilla.org/en-US/Add-ons/Setting_up_extension_development_environment source]). Additionally, [http://kb.mozillazine.org/Firefox_:_FAQs_:_About:config_Entries this page] shows several configuration options related to proxies (such as ''network.http.proxy.pipelining'') that may cause the issue. Could you report back?
cor-el
  • Top 10 Contributor
  • Moderator
17681 solutions 159964 answers

You can also try to toggle Work Offline mode off/on to see if that has effect. For a PAC file there is a Reload button in "Options/Preferences -> Advanced -> Network -> Settings"

You can also try to toggle Work Offline mode off/on to see if that has effect. For a PAC file there is a Reload button in "Options/Preferences -> Advanced -> Network -> Settings"

Question owner

Tonnes said

It looks like you are using the Proxy Switcher add-on, so my first question would be: does the same thing happen when uninstalling that add-on, or when starting Firefox in Safe Mode (=ignoring all add-ons)? And, if you change settings using the gsettings commands, why would you need the add-on anyway, perhaps for switching manually? It would make sense to assume Firefox does not pick up the changes made by the script but uses some cached settings instead, either from itself or from the add-on, so you should check the latter first. You may be able to add the -purgecaches option to start Firefox in order to pinpoint if this is caused by Firefox and work around it (source). Additionally, this page shows several configuration options related to proxies (such as network.http.proxy.pipelining) that may cause the issue. Could you report back?

Actually I installed the add-on today after getting fed up with the situation. I'll check the other items and get back to you.

''Tonnes [[#answer-985054|said]]'' <blockquote> It looks like you are using the Proxy Switcher add-on, so my first question would be: does the same thing happen when uninstalling that add-on, or when starting Firefox in Safe Mode (=ignoring all add-ons)? And, if you change settings using the gsettings commands, why would you need the add-on anyway, perhaps for switching manually? It would make sense to assume Firefox does not pick up the changes made by the script but uses some cached settings instead, either from itself or from the add-on, so you should check the latter first. You may be able to add the ''-purgecaches'' option to start Firefox in order to pinpoint if this is caused by Firefox and work around it ([https://developer.mozilla.org/en-US/Add-ons/Setting_up_extension_development_environment source]). Additionally, [http://kb.mozillazine.org/Firefox_:_FAQs_:_About:config_Entries this page] shows several configuration options related to proxies (such as ''network.http.proxy.pipelining'') that may cause the issue. Could you report back? </blockquote> Actually I installed the add-on today after getting fed up with the situation. I'll check the other items and get back to you.

Question owner

cor-el said

You can also try to toggle Work Offline mode off/on to see if that has effect. For a PAC file there is a Reload button in "Options/Preferences -> Advanced -> Network -> Settings"

When you use the system proxy setting, there is no reload. Remember, I'm not setting up Firefox with the proxy settings.

''cor-el [[#answer-985064|said]]'' <blockquote> You can also try to toggle Work Offline mode off/on to see if that has effect. For a PAC file there is a Reload button in "Options/Preferences -> Advanced -> Network -> Settings" </blockquote> When you use the system proxy setting, there is no reload. Remember, I'm not setting up Firefox with the proxy settings.

Question owner

Tonnes said

Additionally, this page shows several configuration options related to proxies (such as network.http.proxy.pipelining) that may cause the issue. Could you report back?

Tried with and without proxy pipelining. Same problem.

''Tonnes [[#answer-985054|said]]'' <blockquote> Additionally, [http://kb.mozillazine.org/Firefox_:_FAQs_:_About:config_Entries this page] shows several configuration options related to proxies (such as ''network.http.proxy.pipelining'') that may cause the issue. Could you report back? </blockquote> Tried with and without proxy pipelining. Same problem.
Tonnes
  • Locale Leader
246 solutions 1454 answers

I suggest you try this:

  1. Open Internet connection settings in the OS, set it to use the pac file
  2. Open Firefox, set to use system proxy settings, and to use session restore, and load one or more pages
  3. Switch the OS’es connection settings to None (no proxy)
  4. Reload one or more pages in Firefox

Does the change get picked up immediately? It does for me in Windows, which tells Firefox actually follows them as it should.

Then try the same, but relaunch Firefox after step 3. Do the pages load with an error? Assuming yes (this is your issue), but what happens when refreshing the page using F5, and perhaps (when needed) when pressing Ctrl+F5 (=bypassing cache)?

On my system, I see pages as loaded by the pac script previously, but pressing F5 reloads them properly. This indicates it just loads cached pages at startup.

The way to avoid that is to toggle browser.cache.disk.enable to false. Can you try that? It may also be required to do the same for browser.cache.memory.enable.

I suggest you try this: # Open Internet connection settings in the OS, set it to use the pac file # Open Firefox, set to use system proxy settings, and to use session restore, and load one or more pages # Switch the OS’es connection settings to None (no proxy) # Reload one or more pages in Firefox Does the change get picked up immediately? It does for me in Windows, which tells Firefox actually follows them as it should. Then try the same, but relaunch Firefox after step 3. Do the pages load with an error? Assuming yes (this is your issue), but what happens when refreshing the page using F5, and perhaps (when needed) when pressing Ctrl+F5 (=bypassing cache)? On my system, I see pages as loaded by the pac script previously, but pressing F5 reloads them properly. This indicates it just loads cached pages at startup. The way to avoid that is to toggle '''browser.cache.disk.enable''' to ''false''. Can you try that? It may also be required to do the same for '''browser.cache.memory.enable'''.

Question owner

Tonnes said

I suggest you try this:
  1. Open Internet connection settings in the OS, set it to use the pac file
  2. Open Firefox, set to use system proxy settings, and to use session restore, and load one or more pages
  3. Switch the OS’es connection settings to None (no proxy)
  4. Reload one or more pages in Firefox
Does the change get picked up immediately? It does for me in Windows, which tells Firefox actually follows them as it should.

If I refresh a page with Ctrl-F5, I get "Unable to find the proxy server," meaning that FF isn't reloading the information from Gnome (or is getting back the wrong information).

Then try the same, but relaunch Firefox after step 3. Do the pages load with an error? Assuming yes (this is your issue), but what happens when refreshing the page using F5, and perhaps (when needed) when pressing Ctrl+F5 (=bypassing cache)?

Same result as above.

What's troubling is that even restarting FF doesn't help, only changing the browser setting to "None" or re-login to Gnome.

The same set of tests with Chrome work correctly but I'm not required nor have the desire to use it. FF is my daily driver, has been since v.1.0, and I'd like to keep it that way.

Thanks for your help but it seems this is a Linux specific problem.

''Tonnes [[#answer-985298|said]]'' <blockquote> I suggest you try this: # Open Internet connection settings in the OS, set it to use the pac file # Open Firefox, set to use system proxy settings, and to use session restore, and load one or more pages # Switch the OS’es connection settings to None (no proxy) # Reload one or more pages in Firefox Does the change get picked up immediately? It does for me in Windows, which tells Firefox actually follows them as it should. </blockquote> If I refresh a page with Ctrl-F5, I get "Unable to find the proxy server," meaning that FF isn't reloading the information from Gnome (or is getting back the wrong information). <blockquote> Then try the same, but relaunch Firefox after step 3. Do the pages load with an error? Assuming yes (this is your issue), but what happens when refreshing the page using F5, and perhaps (when needed) when pressing Ctrl+F5 (=bypassing cache)? </blockquote> Same result as above. What's troubling is that even restarting FF doesn't help, only changing the browser setting to "None" or re-login to Gnome. The same set of tests with Chrome work correctly but I'm not required nor have the desire to use it. FF is my daily driver, has been since v.1.0, and I'd like to keep it that way. Thanks for your help but it seems this is a Linux specific problem.
Tonnes
  • Locale Leader
246 solutions 1454 answers

sregev said

Tonnes said
I suggest you try this:
  1. Open Internet connection settings in the OS, set it to use the pac file
  2. Open Firefox, set to use system proxy settings, and to use session restore, and load one or more pages
  3. Switch the OS’es connection settings to None (no proxy)
  4. Reload one or more pages in Firefox
Does the change get picked up immediately? It does for me in Windows, which tells Firefox actually follows them as it should.

If I refresh a page with Ctrl-F5, I get "Unable to find the proxy server," meaning that FF isn't reloading the information from Gnome (or is getting back the wrong information).

That’s interesting. Sorry for asking again, but this is important info. Are you saying that when only changing the connection setting in the OS’s connection dialog in step 3 - so not by your script - does not affect Firefox at all, i.e. reloading a page in step 4 without leaving Firefox - either by F5 or ctrl+F5 - makes it still wants to connect to the proxy? Additionally and if so, does the exact same thing happen with the 2 cache related prefs set to false in this scenario?

I find it hard to believe that this would be Linux-only issue, though there have been bugs with regard to Gnome and proxies in the past so I can imagine the proxy mechanism to work in a slightly different way for Gnome, also when looking at some previous bugs such as this one. By the way, is there any proxy authentication involved?

I must say I tested with Firefox Nightly AND my proxy (pointed to in the system’s pac file) was still accessible, but the same happened when testing in FF 54 release and when changing the pac script to use an inaccessible proxy as part of step 3. Interestingly perhaps, when only changing the pac file to use an inaccessible proxy, Firefox requires a restart or change in its preferences (e.g. to None and back, as if it could use a Reload button too) in order to discover the proxy is not accessible, so then it acts like at your end. But then again, it does respect an OS’es connection settings change in Windows(7) right away. It seems obvious that does not happen for you, i.e. it still uses cached settings as defined by the pac file.

Could you please answer the above questions, and also have a look at this bug reported recently to see if you think this is the issue described? The behavior described there appears to be very similar and despite being filed for Mac and 53, it could very well affect Linux too and have been an issue before.

What I think is also interesting is the bug confirmation for Windows 10 and 7, but it could be because the OS’s pac setting itself may not have been changed, only the network connection itself.

With regard to the reported version: do you know of a previous Firefox version that did not suffer the issue, and are you willing to test any older Firefox version by using a zip build for instance (in order to do test quickly without reinstalls)? Of course you are also welcome to add your comment in the bug and vote for it if you think it’s applicable.

''sregev [[#answer-985593|said]]'' <blockquote> ''Tonnes [[#answer-985298|said]]'' <blockquote> I suggest you try this: # Open Internet connection settings in the OS, set it to use the pac file # Open Firefox, set to use system proxy settings, and to use session restore, and load one or more pages # Switch the OS’es connection settings to None (no proxy) # Reload one or more pages in Firefox Does the change get picked up immediately? It does for me in Windows, which tells Firefox actually follows them as it should. </blockquote> If I refresh a page with Ctrl-F5, I get "Unable to find the proxy server," meaning that FF isn't reloading the information from Gnome (or is getting back the wrong information). </blockquote> That’s interesting. Sorry for asking again, but this is important info. Are you saying that when ''only'' changing the connection setting ''in the OS’s connection dialog'' in step 3 - so not by your script - does not affect Firefox at all, i.e. reloading a page in step 4 without leaving Firefox - either by F5 or ctrl+F5 - makes it still wants to connect to the proxy? Additionally and if so, does the exact same thing happen with the 2 cache related prefs set to false in this scenario? I find it hard to believe that this would be Linux-only issue, though there have been bugs with regard to Gnome and proxies in the past so I can imagine the proxy mechanism to work in a slightly different way for Gnome, also when looking at some previous bugs such as [https://bugzilla.mozilla.org/show_bug.cgi?id=242897 this one]. By the way, is there any proxy authentication involved? I must say I tested with Firefox Nightly AND my proxy (pointed to in the system’s pac file) was still accessible, but the same happened when testing in FF 54 release and when changing the pac script to use an inaccessible proxy as part of step 3. Interestingly perhaps, when ''only'' changing the pac file to use an inaccessible proxy, Firefox requires a restart or change in its preferences (e.g. to None and back, as if it could use a Reload button too) in order to discover the proxy is not accessible, so then it acts like at your end. But then again, it ''does'' respect an OS’es connection settings change in Windows(7) right away. It seems obvious that does not happen for you, i.e. it still uses cached settings as defined by the pac file. Could you please answer the above questions, and also have a look at [https://bugzilla.mozilla.org/show_bug.cgi?id=1366772 this bug] reported recently to see if you think this is the issue described? The behavior described there appears to be very similar and despite being filed for Mac and 53, it could very well affect Linux too and have been an issue before. What I think is also interesting is the bug confirmation for Windows 10 and 7, but it could be because the OS’s pac setting itself may not have been changed, only the network connection itself. With regard to the reported version: do you know of a previous Firefox version that did not suffer the issue, and are you willing to test any older Firefox version by using a zip build for instance (in order to do test quickly without reinstalls)? Of course you are also welcome to add your comment in the bug and vote for it if you think it’s applicable.

Question owner

Sorry for the delay, here are the answers to your questions.

Tonnes said

Are you saying that when only changing the connection setting in the OS’s connection dialog in step 3 - so not by your script - does not affect Firefox at all, i.e. reloading a page in step 4 without leaving Firefox - either by F5 or ctrl+F5 - makes it still wants to connect to the proxy? Additionally and if so, does the exact same thing happen with the 2 cache related prefs set to false in this scenario?

That's what I'm saying. Firefox will continue to try to use the proxy until I log out of Gnome and log back in.

By the way, is there any proxy authentication involved?

No proxy authentication.

and also have a look at this bug reported recently to see if you think this is the issue described? The behavior described there appears to be very similar and despite being filed for Mac and 53, it could very well affect Linux too and have been an issue before.

This bug is very similar but restarting Firefox caused it to re-read the system proxy setting and that fixed it. In my case, restarting Firefox does not help. Only logging out of Gnome and logging back in forced Firefox to use the correct setting.

With regard to the reported version: do you know of a previous Firefox version that did not suffer the issue, and are you willing to test any older Firefox version by using a zip build for instance (in order to do test quickly without reinstalls)?

I haven't tried older versions under CentOS but I'd like to get to the bottom of the issue.

To add more confusion to the mix, I performed the same tests in a fully updated Ubuntu 16.04.2, with the same Firefox version, and the problem did not occur. But remember that under CentOS, Chrome doesn't exhibit this problem at all. So it might also be a problem in Gnome as well as Firefox, something that I suspected initially since logging out and back in caused Firefox to use the correct setting.

Sorry for the delay, here are the answers to your questions. ''Tonnes [[#answer-985616|said]]'' <blockquote> Are you saying that when ''only'' changing the connection setting ''in the OS’s connection dialog'' in step 3 - so not by your script - does not affect Firefox at all, i.e. reloading a page in step 4 without leaving Firefox - either by F5 or ctrl+F5 - makes it still wants to connect to the proxy? Additionally and if so, does the exact same thing happen with the 2 cache related prefs set to false in this scenario? </blockquote> That's what I'm saying. Firefox will continue to try to use the proxy until I log out of Gnome and log back in. <blockquote> By the way, is there any proxy authentication involved? </blockquote> No proxy authentication. <blockquote> and also have a look at [https://bugzilla.mozilla.org/show_bug.cgi?id=1366772 this bug] reported recently to see if you think this is the issue described? The behavior described there appears to be very similar and despite being filed for Mac and 53, it could very well affect Linux too and have been an issue before. </blockquote> This bug is very similar but restarting Firefox caused it to re-read the system proxy setting and that fixed it. In my case, restarting Firefox does not help. Only logging out of Gnome and logging back in forced Firefox to use the correct setting. <blockquote> With regard to the reported version: do you know of a previous Firefox version that did not suffer the issue, and are you willing to test any older Firefox version by using a zip build for instance (in order to do test quickly without reinstalls)? </blockquote> I haven't tried older versions under CentOS but I'd like to get to the bottom of the issue. To add more confusion to the mix, I performed the same tests in a fully updated Ubuntu 16.04.2, with the same Firefox version, and the problem did not occur. But remember that under CentOS, Chrome doesn't exhibit this problem at all. So it might also be a problem in Gnome as well as Firefox, something that I suspected initially since logging out and back in caused Firefox to use the correct setting.
Tonnes
  • Locale Leader
246 solutions 1454 answers

Thanks for your feedback.

I’m not a real expert on this, but understand Firefox should use the Gnome proxy settings whereas other (command line) applications may look for environment variables, or at least other ones. Now I don’t know how your script works, but perhaps it modifies CentOS’s proxy settings, but just not the (or all) Gnome settings/variables that should be inherited from them? Logging out and back to Gnome may cause Gnome to re-read these higher privileged CentOS settings. That would also explain why the Ubuntu setup does not suffer the issue.

This thought came up when reading this, this, this (look for "issue", pointing to an old bug), this (note "Gnome3") and this page.

So in short: perhaps you need to modify your script a bit so that one or more variables used by Gnome are adapted as well, not just the ones for CentOS? I can’t tell which files and variables to modify/add exactly but assume you can find out. It should be as easy as checking which ones have changed after a new login and make the script do the same.

Thanks for your feedback. I’m not a real expert on this, but understand Firefox should use the Gnome proxy settings whereas other (command line) applications may look for environment variables, or at least other ones. Now I don’t know how your script works, but perhaps it modifies CentOS’s proxy settings, but just not the (or all) Gnome settings/variables that should be inherited from them? Logging out and back to Gnome may cause Gnome to re-read these higher privileged CentOS settings. That would also explain why the Ubuntu setup does not suffer the issue. This thought came up when reading [https://www.centos.org/forums/viewtopic.php?t=8075 this], [https://www.server-world.info/en/note?os=CentOS_7&p=squid&f=2 this], [https://superuser.com/questions/357688/how-to-configure-proxy-settings-on-linux-xfce this] (look for "issue", pointing to an old bug), [https://wiki.archlinux.org/index.php/proxy_settings this] (note "Gnome3") and [http://mumblestiltskin.blogspot.nl/2009/07/install-linux-centos-for-windows-sys_20.html this page]. So in short: perhaps you need to modify your script a bit so that one or more variables used by Gnome are adapted as well, not just the ones for CentOS? I can’t tell which files and variables to modify/add exactly but assume you can find out. It should be as easy as checking which ones have changed after a new login and make the script do the same.

Question owner

Thanks for the suggestion. My script already makes all the relevant changes to the environment, yum, git, applications, you name it. That's why I put it in a script. The fact that Firefox is the only application that has trouble with the system configuration when changing proxy settings makes me think that the problem is the browser and not the environment.

With all due respect to Windows, it behaves nothing like Linux, which vary between distributions. Is there any way someone familiar with the way Firefox accesses the system proxy settings in Linux can chime in with their suggestions?

Thanks for the suggestion. My script already makes all the relevant changes to the environment, yum, git, applications, you name it. That's why I put it in a script. The fact that Firefox is the only application that has trouble with the system configuration when changing proxy settings makes me think that the problem is the browser and not the environment. With all due respect to Windows, it behaves nothing like Linux, which vary between distributions. Is there any way someone familiar with the way Firefox accesses the system proxy settings in Linux can chime in with their suggestions?
Tonnes
  • Locale Leader
246 solutions 1454 answers

I trust your script to be OK then. One thing that I’m not sure of is whether Firefox "caches" proxy settings or its required variables returned by "Use system proxy settings", even though it is set to use them and so expected to follow connection changes instantly. But knowing the issue does not occur in Gnome on Ubuntu for you, I doubt if this is a general Linux issue or related to CentOS, or some distro.

Perhaps you could add your comment to the bug, slightly describing your specific issue or by pointing to this question?

Remember that bug is not filed for Windows - Mac and Linux apparently differ slightly with regard to behavior (according to the bug), and a commenter experiences this using a VPN, though not with CentOS, and regardless of a Firefox restart "fixing" this either on Windows or Mac. Some developers may see your issue as a separate one, but I think this could be fixed by that bug in general, i.e. for any setup or OS. If not, at least some discussion would come up and a specific and related bug could be filed from there.

Come to think of it now, I presume you also tested with Firefox set to use the pac file by itself instead of via the OS, and altering the script? And the same for manual proxy settings perhaps? You could also check what the Reload button does for the first option. I understand this is not how you would like your setup/script to be, but it would be for testing only to see where this fails, so it can be useful info for developers in a bug too.

Finally, don’t forget to test for reproduction of the issue without any add-ons (as opposed to disabling them only manually or by Safe Mode), and to make sure there is no user.js file involved. There have been reports of add-ons that do not get disabled entirely (see here), so the best would be to create a separate profile for it without any modifications and add-ons.

I trust your script to be OK then. One thing that I’m not sure of is whether Firefox "caches" proxy settings or its required variables returned by "Use system proxy settings", even though it is set to use them and so expected to follow connection changes instantly. But knowing the issue does not occur in Gnome on Ubuntu for you, I doubt if this is a general Linux issue or related to CentOS, or some distro. Perhaps you could add your comment to [https://bugzilla.mozilla.org/show_bug.cgi?id=1366772 the bug], slightly describing your specific issue or by pointing to this question? Remember that bug is not filed for Windows - Mac and Linux apparently differ slightly with regard to behavior (according to the bug), and a commenter experiences this using a VPN, though not with CentOS, and regardless of a Firefox restart "fixing" this either on Windows or Mac. Some developers may see your issue as a separate one, but I think this could be fixed by that bug in general, i.e. for any setup or OS. If not, at least some discussion would come up and a specific and related bug could be filed from there. Come to think of it now, I presume you also tested with Firefox set to use the pac file by itself instead of via the OS, and altering the script? And the same for manual proxy settings perhaps? You could also check what the Reload button does for the first option. I understand this is not how you would like your setup/script to be, but it would be for testing only to see where this fails, so it can be useful info for developers in a bug too. Finally, don’t forget to test for reproduction of the issue without any add-ons (as opposed to disabling them only manually or by Safe Mode), and to make sure there is no user.js file involved. There have been reports of add-ons that do not get disabled entirely (see [/questions/848905 here]), so the best would be to create a separate [[Use the Profile Manager to create and remove Firefox profiles|profile]] for it without any modifications and add-ons.