X
Tap here to go to the mobile version of the site.

Support Forum

Why is firefox so slow on linux?

Posted

Using Adobe flash and Firefox build 49 worked fine with thesettlersonline.com, great even until it was updated to 52. Now is is sooooo slow, scrolling around the island on settlers online is almost impossible the "lag" is so extreme. Tried deleting cashe and temp files, even re-imaged the machine - again great until Firefox is updated. Something has gone desperately wrong with the coding. Installed Chrome and that flies. Get it sorted.

Using Adobe flash and Firefox build 49 worked fine with thesettlersonline.com, great even until it was updated to 52. Now is is sooooo slow, scrolling around the island on settlers online is almost impossible the "lag" is so extreme. Tried deleting cashe and temp files, even re-imaged the machine - again great until Firefox is updated. Something has gone desperately wrong with the coding. Installed Chrome and that flies. Get it sorted.
Tonnes
  • Locale Leader
246 solutions 1454 answers

Did or could you try creating a new profile and/or removing Flash as a test to see how that performs?

Did or could you try [[Use the Profile Manager to create and remove Firefox profiles|creating a new profile]] and/or removing Flash as a test to see how that performs?

Question owner

I've just as a trial reimaged the laptop with Manjaro Linux (XFCE) so a totally empty disk with a brand new Operating system installed.

As we speak it comes with; Firefox 52.0.2 (64-bit) running Shockwave Flash 26.0 r0

Everything is working perfectly. No lagging at all with Settlers Online. I am installling ALL updates EXCEPT the update to Firefox (and Flash)

The upgrade I have held back is Firefox 54.0.1-1 (64-bit).

After all the other updates have been installed I will restart the laptop and confirm Settlers Online works OK with no lag.

I've just as a trial reimaged the laptop with Manjaro Linux (XFCE) so a totally empty disk with a brand new Operating system installed. As we speak it comes with; Firefox 52.0.2 (64-bit) running Shockwave Flash 26.0 r0 Everything is working perfectly. No lagging at all with Settlers Online. I am installling ALL updates EXCEPT the update to Firefox (and Flash) The upgrade I have held back is Firefox 54.0.1-1 (64-bit). After all the other updates have been installed I will restart the laptop and confirm Settlers Online works OK with no lag.

Question owner

Sadly after the update the lag has appeared. Not major but noticable especially when scrolling.

I have also installed Chromium and papper-flash and thats working just as fast as Firefox before the update.

Sadly after the update the lag has appeared. Not major but noticable especially when scrolling. I have also installed Chromium and papper-flash and thats working just as fast as Firefox before the update.
Shadow110 1072 solutions 14836 answers

Helpful Reply

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

You can try to disable hardware acceleration in Firefox.

Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" 

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes

All I can think of for now.

Please let us know if this solved your issue or if need further assistance.

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster You can try to disable hardware acceleration in Firefox. Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes All I can think of for now. Please let us know if this solved your issue or if need further assistance.

Question owner

After many rebuilds and playing i think I may be onto something.

"Flash 26 + FF 54 worked fine. Flash 26 + FF 56 dropping packets"?

Why?

In tests both Chrom(ium) and FF used the same Flash plugin installation from Adobe on the machine. Using Ubuntu & Manjaro Linux, both latest releases downloaded and installed via USB pen drive. Systems updated (except FF) with all updates. Flash Player 26 was downloaded direct from the Adobe website and installed. A Windows 10 machine using Edge Running flash 26.

The Settlers Online (TSO) uses Flash intensively. No performance issues with FF 54, Chromium and the windows 10 machine

After the upgrade to FF 56 at TSO logon page (Flash based) it is "hit and miss" if authentication is performed. I am left with "Please Wait" which displays when authentication should be happening.

I gave it 10 seconds for authentication to perform. If logon attempt failed I clearing temp files and all cookies, restarting the browser.

FF 54 authenticated instantly and game play started. FF 56 took on average 7 attempts to logon and then laggy game play started.

I have tried disabling Hardware acceleration Changed setting gfx.direct2d.disabled to True in About:Config Changed setting layers.acceleration.disabled to True Removed the Firefox version that came with the distribution and downloading version 54. It worked great until it auto updated to 56 and the problems appeared.

is there anything else I can try?

Firefox has never given me problems in the past its only this update to version 56. Please sort it.

After many rebuilds and playing i think I may be onto something. "Flash 26 + FF 54 worked fine. Flash 26 + FF 56 dropping packets"? Why? In tests both Chrom(ium) and FF used the same Flash plugin installation from Adobe on the machine. Using Ubuntu & Manjaro Linux, both latest releases downloaded and installed via USB pen drive. Systems updated (except FF) with all updates. Flash Player 26 was downloaded direct from the Adobe website and installed. A Windows 10 machine using Edge Running flash 26. The Settlers Online (TSO) uses Flash intensively. No performance issues with FF 54, Chromium and the windows 10 machine After the upgrade to FF 56 at TSO logon page (Flash based) it is "hit and miss" if authentication is performed. I am left with "Please Wait" which displays when authentication should be happening. I gave it 10 seconds for authentication to perform. If logon attempt failed I clearing temp files and all cookies, restarting the browser. FF 54 authenticated instantly and game play started. FF 56 took on average 7 attempts to logon and then laggy game play started. I have tried disabling Hardware acceleration Changed setting gfx.direct2d.disabled to True in About:Config Changed setting layers.acceleration.disabled to True Removed the Firefox version that came with the distribution and downloading version 54. It worked great until it auto updated to 56 and the problems appeared. is there anything else I can try? Firefox has never given me problems in the past its only this update to version 56. Please sort it.

Question owner

Pkshadow said

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster You can try to disable hardware acceleration in Firefox. Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes All I can think of for now. Please let us know if this solved your issue or if need further assistance.

Sorry I hadn't tried all in your list. I was busy rebuilding a 101 times, I've covered the hardware acceleration but will try the others tonight.

''Pkshadow [[#answer-983925|said]]'' <blockquote> https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster You can try to disable hardware acceleration in Firefox. Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes All I can think of for now. Please let us know if this solved your issue or if need further assistance. </blockquote> Sorry I hadn't tried all in your list. I was busy rebuilding a 101 times, I've covered the hardware acceleration but will try the others tonight.
TyDraniu
  • Top 25 Contributor
316 solutions 1783 answers

Try entering about:config into the url bar and set dom.ipc.plugins.asyncdrawing.enabled = false

Try entering ''about:config'' into the url bar and set ''dom.ipc.plugins.asyncdrawing.enabled'' = '''false'''

Question owner

Thanks guys I'll get back to you tomorrow.

Thanks guys I'll get back to you tomorrow.

Question owner

TyDraniu said

Try entering about:config into the url bar and set dom.ipc.plugins.asyncdrawing.enabled = false

Thats already set to False

''TyDraniu [[#answer-984278|said]]'' <blockquote> Try entering ''about:config'' into the url bar and set ''dom.ipc.plugins.asyncdrawing.enabled'' = '''false''' </blockquote> Thats already set to False

Question owner

Sorry I got my FF versions wrong. FF 56 is means to be Firefox 54, and FF 54 is meant to be Firefox 52 - I'm hoping you already worked that one out! ;)

Sorry I got my FF versions wrong. FF 56 is means to be Firefox 54, and FF 54 is meant to be Firefox 52 - I'm hoping you already worked that one out! ;)
cor-el
  • Top 10 Contributor
  • Moderator
17481 solutions 157978 answers

You wrote:

Removed the Firefox version that came with the distribution and downloading version 54.
It worked great until it auto updated to 56 and the problems appeared.

Did you install the Firefox Nightly build and not the current release?

A release version would never update to Firefox 56. You can check the update channel on in "Help -> About".

You will have to create a new profile if the profile you currently use has been used with a 56 version.


When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect.

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You wrote: <blockquote><pre>Removed the Firefox version that came with the distribution and downloading version 54. It worked great until it auto updated to 56 and the problems appeared. </pre></blockquote> Did you install the Firefox Nightly build and not the current release? A release version would never update to Firefox 56. You can check the update channel on in "Help -> About". You will have to create a new profile if the profile you currently use has been used with a 56 version. *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles ---- When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect. You can disable multi-process windows in Firefox by setting these prefs to false on the <b>about:config</b> page. *browser.tabs.remote.autostart = false *browser.tabs.remote.autostart.2 = false You can open the <b>about:config</b> page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config *http://www.ghacks.net/2016/07/22/multi-process-firefox/

Question owner

I tried

    browser.tabs.remote.autostart = false
   browser.tabs.remote.autostart.2 = false 

Actually browser.tabs.remote.autostart = false was already set to false.

I tried the nightly build with no improvement. Even downloaded Fedora linux which came with FF 49. Again working great under flash 26 until the update to FF 54 when the problem occurred again.

Is there no one else having the problem?

I tried browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false Actually browser.tabs.remote.autostart = false was already set to false. I tried the nightly build with no improvement. Even downloaded Fedora linux which came with FF 49. Again working great under flash 26 until the update to FF 54 when the problem occurred again. Is there no one else having the problem?

Question owner

Right may have come across the solution. It seems my old Latitude E6410 is just "old". I've got a 4th Generation i3 laptop and although not perfect it is a lot better.

In summery it seems FF has put on quite a lot of bloatware somehow between FF 52 and FF 54. The difference between the two on my 1st gen i5 is striking.

Right may have come across the solution. It seems my old Latitude E6410 is just "old". I've got a 4th Generation i3 laptop and although not perfect it is a lot better. In summery it seems FF has put on quite a lot of bloatware somehow between FF 52 and FF 54. The difference between the two on my 1st gen i5 is striking.