X
Tap here to go to the mobile version of the site.

Support Forum

opening a PDF document closes underyling window

Posted

Hi,

Since Firefox 54.0 we've noticed whenever a PDF document is opened it'll close the underlying window. The user then has to go back and re-open the original window.

We've prepared a short video outlining the problem (first 1.5 minutes should give you an idea). http://indivica.com/wp-content/uploads/video/Indivica_Firefox_Refresh-2017-03-23.mp4

The PDF handler is set to "Open with Adobe Reader". Towards the latter part of the video we describe which Preference were updated.

After Refreshing Firefox the issues appears to be resolved. However, it is not persistent, i.e., whenever the computer is rebooted it'll go back to closing the underlying window.

'Any thoughts?

Hi, Since Firefox 54.0 we've noticed whenever a PDF document is opened it'll close the underlying window. The user then has to go back and re-open the original window. We've prepared a short video outlining the problem (first 1.5 minutes should give you an idea). http://indivica.com/wp-content/uploads/video/Indivica_Firefox_Refresh-2017-03-23.mp4 The PDF handler is set to "Open with Adobe Reader". Towards the latter part of the video we describe which Preference were updated. After Refreshing Firefox the issues appears to be resolved. However, it is not persistent, i.e., whenever the computer is rebooted it'll go back to closing the underlying window. 'Any thoughts?

Chosen solution

First, thank you for providing so much detail.

Second, one of the underlying changes in Firefox 54 was to enable more individual content processes. In Firefox 49-53, the Firefox multiprocess feature would create one process for the UI and one process for content. Now Firefox will aim for four content processes. Perhaps this is a side effect of this change?

One reason I think that might be the case is when you use Refresh, Firefox starts up in the legacy single process mode. During the first run, Firefox assesses whether your system is compatible with multiprocess and then that takes effect in your next Firefox session.

Could you test rolling back the number of content processes to 1? If this doesn't work, you may need to revert to single-process mode. Here's how you can try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste ipc and pause while the list is filtered

(3) If the dom.ipc.processCount preference is bolded and "user set" to 4, double-click it and edit the value to 1, then click OK

Presumably that will not take effect until the next startup, at which time you should check it to make sure it hasn't reverted back. Any difference?

Alternately, you can disable multiprocess mode using a different preference:

(4) In the search box above the list, type or paste autos and pause while the list is filtered

(5) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Read this answer in context 3
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 24.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

jscher2000
  • Top 10 Contributor
6605 solutions 54024 answers

Chosen Solution

First, thank you for providing so much detail.

Second, one of the underlying changes in Firefox 54 was to enable more individual content processes. In Firefox 49-53, the Firefox multiprocess feature would create one process for the UI and one process for content. Now Firefox will aim for four content processes. Perhaps this is a side effect of this change?

One reason I think that might be the case is when you use Refresh, Firefox starts up in the legacy single process mode. During the first run, Firefox assesses whether your system is compatible with multiprocess and then that takes effect in your next Firefox session.

Could you test rolling back the number of content processes to 1? If this doesn't work, you may need to revert to single-process mode. Here's how you can try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste ipc and pause while the list is filtered

(3) If the dom.ipc.processCount preference is bolded and "user set" to 4, double-click it and edit the value to 1, then click OK

Presumably that will not take effect until the next startup, at which time you should check it to make sure it hasn't reverted back. Any difference?

Alternately, you can disable multiprocess mode using a different preference:

(4) In the search box above the list, type or paste autos and pause while the list is filtered

(5) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

First, thank you for providing so much detail. Second, one of the underlying changes in Firefox 54 was to enable more individual content processes. In Firefox 49-53, the Firefox multiprocess feature would create one process for the UI and one process for content. Now Firefox will aim for four content processes. Perhaps this is a side effect of this change? One reason I think that might be the case is when you use Refresh, Firefox starts up in the legacy single process mode. During the first run, Firefox assesses whether your system is compatible with multiprocess and then that takes effect in your ''next'' Firefox session. Could you test rolling back the number of content processes to 1? If this doesn't work, you may need to revert to single-process mode. Here's how you can try this: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''ipc''' and pause while the list is filtered (3) If the '''dom.ipc.processCount''' preference is bolded and "user set" to 4, double-click it and edit the value to 1, then click OK Presumably that will not take effect until the next startup, at which time you should check it to make sure it hasn't reverted back. Any difference? Alternately, you can disable multiprocess mode using a different preference: <p>(4) In the search box above the list, type or paste <strong>autos</strong> and pause while the list is filtered</p> <p>(5) Double-click the <strong>browser.tabs.remote.autostart.2</strong> preference to switch the value from true to false</p> <p><em>Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart</em></p> <p>At your next Firefox startup, it should run in the traditional way. Any difference?</p>
Was this helpful to you? 3
Quote

Helpful Reply

Thank you for the detailed answer! Really appreciate the response and the background story. It makes it a bit easier to put together a 'complete' story to end-users.

The first method did not work, it was not persistent.

However, method 2 yielded something interesting.

Before altering anything the dom.ipc.processCount.web (a string value?) had value=4

After updating browser.tabs.remote.autostart.2=false the dom.ipc.processCount.web no longer even appears.

In turn, this appears to fix the issue and is persistent.

Here is a short write up:

Open Firefox and navigate to about:config and click I accept the risk! https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-09-17-46b393.png https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-09-10-413a0c.png

In the search box type in browser.tabs.remote.autostart and change value(s) from true to false. It's possible you may see only 1 item, that's fine, just make sure any instances of browser.tabs.remote.autostart are set to false.

https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-11-04-1745fb.png

Once both of the above fields are set to false, completely close Firefox. Then open it up and see if it's persistent.

https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-10-45-8a7ef1.png

Thank you for the detailed answer! Really appreciate the response and the background story. It makes it a bit easier to put together a 'complete' story to end-users. The first method did not work, it was not persistent. However, method 2 yielded something interesting. Before altering anything the '''dom.ipc.processCount.web''' (a string value?) had '''value=4''' After updating '''browser.tabs.remote.autostart.2=false''' the dom.ipc.processCount.web no longer even appears. In turn, this appears to fix the issue and is persistent. Here is a short write up: Open Firefox and navigate to about:config and click I accept the risk! https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-09-17-46b393.png https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-09-10-413a0c.png In the search box type in '''browser.tabs.remote.autostart''' and change value(s) from true to false. It's possible you may see only 1 item, that's fine, just make sure any instances of '''browser.tabs.remote.autostart''' are set to '''false'''. https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-11-04-1745fb.png Once both of the above fields are set to false, completely close Firefox. Then open it up and see if it's persistent. https://support.cdn.mozilla.net/media/uploads/images/2017-06-27-13-10-45-8a7ef1.png

Modified by mfridman

Was this helpful to you? 3
Quote
jscher2000
  • Top 10 Contributor
6605 solutions 54024 answers

A fix for this is included in today's .1 update. It's the "Fix a tab display issue when downloading files" line in the release notes (and associated issue in the bug tracking system): https://www.mozilla.org/firefox/54.0.1/releasenotes/

A fix for this is included in today's .1 update. It's the "Fix a tab display issue when downloading files" line in the release notes (and associated issue in the bug tracking system): https://www.mozilla.org/firefox/54.0.1/releasenotes/
Was this helpful to you? 1
Quote
cmd1234 1 solutions 5 answers

javacsipt code that will get around the problem is.

var parentOpener = window.opener; window.opener = null; window.open(url you want to use,"_blank"); window.opener = parentOpener;

javacsipt code that will get around the problem is. var parentOpener = window.opener; window.opener = null; window.open(url you want to use,"_blank"); window.opener = parentOpener;
Was this helpful to you? 1
Quote

Question owner

@jscher2000 thanks for the update. I tested 54.0.1 today with

browser.tabs.remote.autostart.2 set to true

and it worked just fine. PDF handler opens without closing the underlying window(s).

I believe it was fixed with https://bugzilla.mozilla.org/show_bug.cgi?id=1373109

@jscher2000 thanks for the update. I tested 54.0.1 today with browser.tabs.remote.autostart.2 set to '''true''' and it worked just fine. PDF handler opens without closing the underlying window(s). I believe it was fixed with https://bugzilla.mozilla.org/show_bug.cgi?id=1373109

Modified by mfridman

Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.