Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get Firefox to use an older copy of places.sqlite to show deleted history?

  • 4 replies
  • 5 have this problem
  • 3974 views
  • Last reply by cbucci28

more options

I have my history set to delete when I close Firefox. Last week I visited a site that I forgot to bookmark and now cannot recall what the URL was. I have read the various entries about how to locate and recover places.sqlite posted here in Mozilla Support. Can someone please explain the next step after finding the previous version of the file? How do I get Firefox to use this restored version of the file?

Windows 7, Firefox 52.2

Chosen solution

Could I suggest:

(A) Create a new Firefox profile, and switch over to it (B) Replace the empty places.sqlite database in the new profile with the one you want to explore (C) Complete your research in the new profile and then switch back to your normal one

That should involve the least risk of severe breakage. Here's how:

Create a New Profile

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like June2017, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but I think those are still "under construction" so please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new.

If you normally use Firefox Sync, do NOT set up Sync in this profile. Also, do not change the settings for history.

Swap the Database

Open your new profile's Firefox profile folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" or "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename places.sqlite to something like places-old.sqlite. If you see files named places.sqlite-shm or places.sqlite-wal, which normally would not be there while Firefox is closed, delete those files.

Next, copy the old places.sqlite file from your backup into this folder. It should appear in alphabetical order right after or right before the places-old.sqlite file.

When you start Firefox, it should have the history and bookmarks from that swapped-in file instead of the stuff that a brand new Firefox has.

Create a Desktop Shortcut to the Site

When you figure out what site you wanted to bookmark, drag the "i-in-a-circle" icon to the Windows desktop and drop it there to create a shortcut. The reason for this is that creating a bookmark in your new profile won't help you after the next step...

Back to Normal

When you are done with the research, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it. Now you can use that desktop shortcut to load the site in your regular profile and bookmark it.

Success?

Read this answer in context 👍 1

All Replies (4)

more options

Those are recovering data using backup files. If your data was removed without any backups . . . . . . . . .

more options

Chosen Solution

Could I suggest:

(A) Create a new Firefox profile, and switch over to it (B) Replace the empty places.sqlite database in the new profile with the one you want to explore (C) Complete your research in the new profile and then switch back to your normal one

That should involve the least risk of severe breakage. Here's how:

Create a New Profile

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like June2017, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but I think those are still "under construction" so please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new.

If you normally use Firefox Sync, do NOT set up Sync in this profile. Also, do not change the settings for history.

Swap the Database

Open your new profile's Firefox profile folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" or "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename places.sqlite to something like places-old.sqlite. If you see files named places.sqlite-shm or places.sqlite-wal, which normally would not be there while Firefox is closed, delete those files.

Next, copy the old places.sqlite file from your backup into this folder. It should appear in alphabetical order right after or right before the places-old.sqlite file.

When you start Firefox, it should have the history and bookmarks from that swapped-in file instead of the stuff that a brand new Firefox has.

Create a Desktop Shortcut to the Site

When you figure out what site you wanted to bookmark, drag the "i-in-a-circle" icon to the Windows desktop and drop it there to create a shortcut. The reason for this is that creating a bookmark in your new profile won't help you after the next step...

Back to Normal

When you are done with the research, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it. Now you can use that desktop shortcut to load the site in your regular profile and bookmark it.

Success?

more options

If you do not clear the disk cache then you might have more luck there (about:cache). It is not very likely that you can recover this history via an older copy of places.sqlite if you use "Clear history when Firefox closes". Firefox may also be keeping data in memory, so it might not have been saved at all.

more options

Thanks, jscher2000. Recovery successful.