Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I do not want "recently bookmarked" to appear with my Bookmarks. How can I remove it? I have a Mac mouse and cannot "right click".

  • 2 replies
  • 22 have this problem
  • 2561 views
  • Last reply by jscher2000

more options

I do not want "recently bookmarked" to appear with my Bookmarks. How can I remove it? I have a Mac mouse and cannot "right click". I am using Firefox 53.0.3./

Chosen solution

I assume you mean the section near the top of the Bookmarks menu. You can hide it using one of these methods:

(1) Context Menu

Windows: Right-click the "Recently Bookmarked" text and choose Hide Recently Bookmarked from the bottom of the right-click context menu.

Mac: Ctrl+click the "Recently Bookmarked" text and choose Hide Recently Bookmarked from the bottom of the right-click context menu.

Note: A user reported this doesn't work on the Bookmarks Menu on the main menu bar on Mac, only the bookmarks menu that drops from the toolbar button, which is pictured in the screenshot.

(2) Directly Edit a Preference

The menu item switches a hidden preference from true to false, and you can do that directly as follows:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste book and pause while the list is filtered

(C) Double-click the browser.bookmarks.showRecentlyBookmarked preference to switch the value from true to false

Read this answer in context 👍 13

All Replies (2)

more options

open Library, on the left you should see "recently bookmarked", click it, press delete

more options

Chosen Solution

I assume you mean the section near the top of the Bookmarks menu. You can hide it using one of these methods:

(1) Context Menu

Windows: Right-click the "Recently Bookmarked" text and choose Hide Recently Bookmarked from the bottom of the right-click context menu.

Mac: Ctrl+click the "Recently Bookmarked" text and choose Hide Recently Bookmarked from the bottom of the right-click context menu.

Note: A user reported this doesn't work on the Bookmarks Menu on the main menu bar on Mac, only the bookmarks menu that drops from the toolbar button, which is pictured in the screenshot.

(2) Directly Edit a Preference

The menu item switches a hidden preference from true to false, and you can do that directly as follows:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste book and pause while the list is filtered

(C) Double-click the browser.bookmarks.showRecentlyBookmarked preference to switch the value from true to false