X
Tap here to go to the mobile version of the site.

Support Forum

How to Delete Extension: Adobe Acrobat - Create PDF

Posted

I am at the end of my rope here with this and am hoping someone out there might be able to help. I've deleted and reinstalled the browser countless times (using Mac OS X Sierra) and no matter what I do I cannot get rid of this extension. I've manually dug into every preference I could find & deleted every trace, yet this darn thing won't go away. I am assuming it is the reason I can't escape that bug where Firefox consumes 97% of my CPU resources and basically grinds my system to a halt. It is rendering Firefox useless, which is really tough for me because I rely so much on Firebug. I found a post that discusses a solution to this problem in Windows, and tried to follow the instructions as best I could on my Mac, but I can't make it happen.

Please help!

I am at the end of my rope here with this and am hoping someone out there might be able to help. I've deleted and reinstalled the browser countless times (using Mac OS X Sierra) and no matter what I do I cannot get rid of this extension. I've manually dug into every preference I could find & deleted every trace, yet this darn thing won't go away. I am assuming it is the reason I can't escape that bug where Firefox consumes 97% of my CPU resources and basically grinds my system to a halt. It is rendering Firefox useless, which is really tough for me because I rely so much on Firebug. I found a post that discusses a solution to this problem in Windows, and tried to follow the instructions as best I could on my Mac, but I can't make it happen. Please help!
Attached screenshots

Chosen solution

So I spent some time monkeying around with extensions.json,prefs.js, blocklist.xml, and deleted anything related to PDFs. But every time I'd save the files and restart Firefox, the offending items would return. Then I noticed a string in the profile configuration showing a path to a Firefox profile that was seemingly a duplicate, with that one folder in the 'extensions' directory. I'd disconnected my sync account and cleared that all out, but in the end all I had to do was delete that random folder. Check out the attached screenshots...it's profile_path2.gif that was where the little bugger was hiding.

Thanks for your help!!

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/603.1.30 (KHTML, like Gecko) Version/10.1 Safari/603.1.30

More Information

FredMcD
  • Top 10 Contributor
3085 solutions 41762 answers

That is a plugin. Plugins are from programs that Firefox finds already on your system.

An extension without a Remove button is really a plugin. The only way to remove a plugin is to remove its program from your system. However, you can disable plugins if you want.


Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key;’’'<Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Find that plugin and set it to Never.

That is a plugin. Plugins are from programs that Firefox finds already on your system. An extension without a '''Remove''' button is really a plugin. The only way to remove a plugin is to remove its program from your system. However, you can disable plugins if you want. ------------ Type '''about:addons'''<enter> in the address bar to open the Add-ons Manager. Hot key;’’'<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins. ''' Find that plugin and set it to '''Never.'''
Was this helpful to you? 1
Quote

Helpful Reply

I'm afraid that doesn't help...there is no option to select. I attached screenshots of the add-ons manager & the plugins page, which doesn't even list the offending item where I'd be able to select 'never activate'.

I'm afraid that doesn't help...there is no option to select. I attached screenshots of the add-ons manager & the plugins page, which doesn't even list the offending item where I'd be able to select 'never activate'.
Was this helpful to you? 3
Quote
Fiz 13 solutions 106 answers

Helpful Reply

Looks like the OP here solved the same problem: http://forums.mozillazine.org/viewtopic.php?f=38&t=2060147

Looks like the OP here solved the same problem: http://forums.mozillazine.org/viewtopic.php?f=38&t=2060147
Was this helpful to you? 3
Quote
jscher2000
  • Top 10 Contributor
6434 solutions 52695 answers

The "Create PDF" extension is installed by the paid version of Adobe Acrobat. If yours is not verified, it probably is an older version; you need at least Adobe Acrobat XI (11) with the latest quarterly updates to use this extension.

Since it is disabled, I do not think it is related to the problem you mentioned, but to answer your question...

Firefox does not display a Remove button for an extension if it was installed into a "shared" location (that is, not in your currently active profile folder). In this case, it is stored under the Adobe Acrobat program folder. On Windows, I could point you to that, but on Mac...

To find the file, you can research the location in a Firefox settings file named extensions.json. Here's a somewhat roundabout way to look in that file:

Access the File

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show in Finder" button. This should launch a new window listing your settings files.

Scroll down and find extensions.json and make a copy somewhere convenient, such as your Documents folder or Desktop. You can close out of the Finder window after that.

View the File

Back in Firefox, open that copy of extensions.json in Firefox's "Scratchpad" tool as follows. Launch the Scratchpad from the Developer menu, either:

  • "3-bar" menu button > Developer > Scratchpad
  • (menu bar) Tools > Web Developer > Scratchpad

Use the Open button on the Scratchpad's toolbar to open the backup copy you made of extensions.json and then click the Pretty Print button on the toolbar to re-layout the data in a more readable format.

Then use Find (Command+f) to search for some part of the name of the unwanted extension, and you should see various information about it. The descriptor gives its location on disk.

(On Windows, the \ in folder paths is doubled in this file due to the way it is processed. When exploring your disk, read \\ as \. Not sure about Mac.)

You can use Finder to locate and remove the extension file.

Note: you don't need to save the changes to the file when you close the Scratchpad unless you want to keep the "pretty" version for future reference.

The next time you quit Firefox and start it up again, it should discover that the extension is gone and update extensions.json accordingly.

The "Create PDF" extension is installed by the paid version of Adobe Acrobat. If yours is not verified, it probably is an older version; you need at least Adobe Acrobat XI (11) with the latest quarterly updates to use this extension. Since it is disabled, I do not think it is related to the problem you mentioned, but to answer your question... Firefox does not display a Remove button for an extension if it was installed into a "shared" location (that is, not in your currently active profile folder). In this case, it is stored under the Adobe Acrobat program folder. On Windows, I could point you to that, but on Mac... To find the file, you can research the location in a Firefox settings file named '''extensions.json'''. Here's a somewhat roundabout way to look in that file: '''''Access the File''''' Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, click the "Show in Finder" button. This should launch a new window listing your settings files. Scroll down and find '''extensions.json''' and make a copy somewhere convenient, such as your Documents folder or Desktop. You can close out of the Finder window after that. '''''View the File''''' Back in Firefox, open that copy of extensions.json in Firefox's "Scratchpad" tool as follows. Launch the Scratchpad from the Developer menu, either: * "3-bar" menu button > Developer > Scratchpad * (menu bar) Tools > Web Developer > Scratchpad Use the Open button on the Scratchpad's toolbar to open the backup copy you made of extensions.json and then click the Pretty Print button on the toolbar to re-layout the data in a more readable format. Then use Find (<u>Command+f</u>) to search for some part of the name of the unwanted extension, and you should see various information about it. The '''descriptor''' gives its location on disk. (On Windows, the \ in folder paths is doubled in this file due to the way it is processed. When exploring your disk, read \\ as \. Not sure about Mac.) You can use Finder to locate and remove the extension file. ''Note: you don't need to save the changes to the file when you close the Scratchpad unless you want to keep the "pretty" version for future reference.'' The next time you quit Firefox and start it up again, it should discover that the extension is gone and update extensions.json accordingly.
Was this helpful to you? 1
Quote

Chosen Solution

So I spent some time monkeying around with extensions.json,prefs.js, blocklist.xml, and deleted anything related to PDFs. But every time I'd save the files and restart Firefox, the offending items would return. Then I noticed a string in the profile configuration showing a path to a Firefox profile that was seemingly a duplicate, with that one folder in the 'extensions' directory. I'd disconnected my sync account and cleared that all out, but in the end all I had to do was delete that random folder. Check out the attached screenshots...it's profile_path2.gif that was where the little bugger was hiding.

Thanks for your help!!

So I spent some time monkeying around with extensions.json,prefs.js, blocklist.xml, and deleted anything related to PDFs. But every time I'd save the files and restart Firefox, the offending items would return. Then I noticed a string in the profile configuration showing a path to a Firefox profile that was seemingly a duplicate, with that one folder in the 'extensions' directory. I'd disconnected my sync account and cleared that all out, but in the end all I had to do was delete that random folder. Check out the attached screenshots...it's profile_path2.gif that was where the little bugger was hiding. '''Thanks for your help!!'''
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
3085 solutions 41762 answers

Good work. Well done.

Good work. Well done.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.