Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why the .. developers don't make firefox multiprocess ?

  • 6 replies
  • 2 have this problem
  • 91 views
  • Last reply by Yaketty Yak

more options

I've a .. powerful pc, that means I don't give .. how much RAM or CPU or any .. resources firefox is using. So why you don't develop this .. browser just like chrome, and make it .. multiprocess instead of you .. .. multi thread idea ? Every .. single time I use firefox I feel like I taking .. in my pc. Low .. speed, .. hangs, you developers ... is this that hard to make it multi process?

Modified by James

All Replies (6)

more options

Modified by James

more options

Would you please moderate your language   ?

You can check whether you have this feature   (e10s)   turned on as follows :
• '3-bar' menu button => ' ? ' button => Troubleshooting Information • type 'about:support ' (without the commas) in the address bar and press Enter/Return
In the first table on the page, check the row for 'Multiprocess Windows' and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s - otherwise it should read : 0/1 (Disabled).
If you are not using e10s: You could turn it on as follows : Type in the address bar about:config (promise to be careful, if asked) Type and search for the preferences : browser.tabs.remote.autostart and set it's value to true browser.tabs.remote.autostart.2 and set it's value to true

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

more options

Note that you have a lot of extensions installed if I look at the System Details list. It is likely that a lot of them aren't multi-process compatible and thus will prevent Firefox from enabling multi-process. You can see this on the "Help -> Troubleshooting Information" (about:support) page (disabled by add-ons). You can use consider to create a new profile if you want to check out multi-process windows. See the about:profiles page.

more options

Happy112:

setting browser.tabs.remote.autostart to true

 did not invoke FF multiprocess on my config: 
 FF 53.0.2 / Windows 7 Pro / Dell Optiplex 9010

however setting

 extensions.e10SBlocksenabling to false  
 did start FF multiprocess

See M_W99 supportneeded thread of 11/19 11/20 and 11/25 . year: 2016

more options

@Katzenjammer :
'Glad that worked for you   !
There are even more prefs in about:config that can be used   -   all depends on whether or not certain extensions block or interfere with e10s.
One can even create a new pref to force-enable Multiprocess   (not recommended, though) : browser.tabs.remote.force-enable and set it's value to 'true'.

more options

Thanks Happy