X
Tap here to go to the mobile version of the site.

Support Forum

Address Bar doesn't search with google after messing with settings

Posted

When I search with the address bar it no longer searches with Google. This started to occur after I messed with settings in the about:config page and in the firefox settings. It treats it like I'm searching "http://example" instead of just searching "example" in google search

When I search with the address bar it no longer searches with Google. This started to occur after I messed with settings in the about:config page and in the firefox settings. It treats it like I'm searching "http://example" instead of just searching "example" in google search

Modified by PremiumPillow

Chosen solution

Is keyword.enabled still set to true if you check that on the about:config page?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 23.0 r0

Application

  • Firefox 50.1.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.1.0/WINNT/en-US/

Extensions

  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • BetterTTV 6.8.5 (firefox@betterttv.net)
  • Grammarly for Firefox 8.727.647 (87677a2c52b84ad3a151a4a72f5bd3c4@jetpack)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Stylish 2.0.7 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Twitch Now 1.1.187 (jid1-jwVSihNsgAw5jA@jetpack)
  • uBlock Origin 1.10.4 (uBlock0@raymondhill.net)
  • Valence 0.3.6 (fxdevtools-adapters@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 1070
  • adapterDescription2:
  • adapterDeviceID: 0x1b81
  • adapterDeviceID2:
  • adapterDrivers: C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvd3dumx,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2umx,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2umx,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2umx C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvd3dum,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2um,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2um,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_3f929cc119e3b994\nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 8192
  • adapterRAM2:
  • adapterSubsysID: 37011458
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.14393.351
  • driverDate: 12-11-2016
  • driverDate2:
  • driverVersion: 21.21.13.7633
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'available', u'type': u'default'}]}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'available', u'type': u'default'}]}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D11 API
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 1070 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17683 solutions 159973 answers

You can set the search engine via "Options/Preferences > Search" (about:preferences#search).

See also:

You can set the search engine via "Options/Preferences > Search" (about:preferences#search). See also: *https://support.mozilla.org/kb/Search+bar

Question owner

My default search engine is set, and I never touched the settings dealing with it. It has been set to Google and hasn't changed. If I search something along the lines of "Youtube", instead of going to a Google page of search suggestions, it will go to a page like this http://search.suddenlink.net/index.php?origURL=http%3A//youtube/&r=&bc=

It is taking my searches ot suddenlink recommended websites, even though my browser is set to Google as my default search engine.

My default search engine is set, and I never touched the settings dealing with it. It has been set to Google and hasn't changed. If I search something along the lines of "Youtube", instead of going to a Google page of search suggestions, it will go to a page like this http://search.suddenlink.net/index.php?origURL=http%3A//youtube/&r=&bc= It is taking my searches ot suddenlink recommended websites, even though my browser is set to Google as my default search engine.
cor-el
  • Top 10 Contributor
  • Moderator
17683 solutions 159973 answers

Helpful Reply

Is that your ISP? See also: *https://productforums.google.com/forum/#!msg/websearch/8syvhUpdrig/pU9T6SzdAJMJ

Question owner

Yes, Suddenlink is my ISP. Nothing in the link has solved my issue either.

Yes, Suddenlink is my ISP. Nothing in the link has solved my issue either.
cor-el
  • Top 10 Contributor
  • Moderator
17683 solutions 159973 answers

Helpful Reply

You likely have an ISP that automatically redirects you to a search page if a DNS look up fails. This takes the control from Firefox to do a search. You can contact your ISP and ask for a DNS server to opt-out of that feature. You can check if there is a link on the search results page to go to your ISP and opt-out. You can try alternative DNS servers like Google Public DNS (8.8.8.8 and 8.8.4.4) (ncpa.cpl).

You likely have an ISP that automatically redirects you to a search page if a DNS look up fails. This takes the control from Firefox to do a search. You can contact your ISP and ask for a DNS server to opt-out of that feature. You can check if there is a link on the search results page to go to your ISP and opt-out. You can try alternative DNS servers like Google Public DNS (8.8.8.8 and 8.8.4.4) (ncpa.cpl).

Question owner

I opted out, but now when I search with the address bar it goes to a "server not found" page.

I opted out, but now when I search with the address bar it goes to a "server not found" page.
cor-el
  • Top 10 Contributor
  • Moderator
17683 solutions 159973 answers

Chosen Solution

Is keyword.enabled still set to true if you check that on the about:config page?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Is keyword.enabled still set to true if you check that on the <b>about:config</b> page? You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

Yeah that seemed to be the problem. I thought it would have been something I edited in the about:config page. Thank you so much for your help!

Yeah that seemed to be the problem. I thought it would have been something I edited in the about:config page. Thank you so much for your help!
cor-el
  • Top 10 Contributor
  • Moderator
17683 solutions 159973 answers

You're welcome

You're welcome