X
Tap here to go to the mobile version of the site.

Support Forum

Audio files play instead of downloading.

Posted

In my experience, the browser opens and plays the audio files on another tab instead of directly downloading. For a long time now, I've put up with this by right clicking and selecting "save audio as..." OR opening the page info and downloading the file from the list of medias; but there are some sites that doesn't allow this (like hive.co right now). Selecting "save ausio as..." again defaults to an .htm file, and selecting "all files" and downloading it as "file.mp3" only yields an unplayable file. As I've observed this problem occurs where the url doesn't end with the file format e.g. "site.com/file.mp3/lkjdflsjdflks" instead of "site.com/file.mp3". And no, removing that extra lkjdflsjdflks doesn't do anything.

There are similar problems posted here in the forums but all the solutions given didn't solve the problem. I've already set media.directshow.enabled, went to Applications and set all mp3 format sound files to "save file". Even restarted my pc.

I installed chrome and christ, the file downloaded with a single click (as it should always have been). There's got to be fix for this, I'm not switching to chrome as I've settle with firefox for a long time now, mind you. Also Third party addons is a big no.

In my experience, the browser opens and plays the audio files on another tab instead of directly downloading. For a long time now, I've put up with this by right clicking and selecting "save audio as..." OR opening the page info and downloading the file from the list of medias; but there are some sites that doesn't allow this (like hive.co right now). Selecting "save ausio as..." again defaults to an .htm file, and selecting "all files" and downloading it as "file.mp3" only yields an unplayable file. As I've observed this problem occurs where the url doesn't end with the file format e.g. "site.com/file.mp3/lkjdflsjdflks" instead of "site.com/file.mp3". And no, removing that extra lkjdflsjdflks doesn't do anything. There are similar problems posted here in the forums but all the solutions given didn't solve the problem. I've already set media.directshow.enabled, went to Applications and set all mp3 format sound files to "save file". Even restarted my pc. I installed chrome and christ, the file downloaded with a single click (as it should always have been). There's got to be fix for this, I'm not switching to chrome as I've settle with firefox for a long time now, mind you. Also Third party addons is a big no.

Chosen solution

hi, first of all please go to about:config and right-click and reset any media-related preferences like media.directshow.enabled that you have customized, as those will be detrimental to web compatibility.

you can disable the built-in mediaplayer and download files instead like this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.play-stand-alone. double-click it and change its value to false, then restart the browser once.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Plugin for Wacom tablets.

Application

  • Firefox 50.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.0/WINNT/en-US/

Extensions

  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Classic Theme Restorer 1.6.0.1 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Greasemonkey 3.9 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • HideScrollbars 1.1 (Hidescrollbars@ArisT2Noia4dev)
  • HTTPS Everywhere 5.2.9 (https-everywhere@eff.org)
  • Image Search Options 2.0.3.1-signed ({4a313247-8330-4a81-948e-b79936516f78})
  • InlineDisposition 1.0.2.4.1-signed.1-signed ({123647d5-da43-4344-bfe2-fc093bdf8f5e})
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • New Tab Override (browser.newtab.url replacement) 6.0.1 (newtaboverride@agenedia.com)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Reddit Enhancement Suite 5.2.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • uBlock Origin 1.10.4 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • YouTube Video and Audio Downloader 0.5.6 (feca4b87-3be4-43da-a1b1-137c24220968@jetpack)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce 840M
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2: 0x1341
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 16cd1043
  • adapterSubsysID2: 16cd1043
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.18468
  • driverDate: 3-7-2014
  • driverDate2: 4-8-2014
  • driverVersion: 10.18.10.3496
  • driverVersion2: 9.18.13.3302
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; D3D11 blacklisted with DLL igd10iumd32.dll (10.18.10.3496); Using D3D9 API
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5330 solutions 23534 answers

Chosen Solution

hi, first of all please go to about:config and right-click and reset any media-related preferences like media.directshow.enabled that you have customized, as those will be detrimental to web compatibility.

you can disable the built-in mediaplayer and download files instead like this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.play-stand-alone. double-click it and change its value to false, then restart the browser once.

hi, first of all please go to about:config and right-click and reset any media-related preferences like ''media.directshow.enabled'' that you have customized, as those will be detrimental to web compatibility. you can disable the built-in mediaplayer and download files instead like this: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.play-stand-alone'''. double-click it and change its value to '''false''', then restart the browser once.

Helpful Reply

philipp said

hi, first of all please go to about:config and right-click and reset any media-related preferences like media.directshow.enabled that you have customized, as those will be detrimental to web compatibility. you can disable the built-in mediaplayer and download files instead like this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.play-stand-alone. double-click it and change its value to false, then restart the browser once.

Thanks for the reply. Problem's finally gone. Cheers.

''philipp [[#answer-948479|said]]'' <blockquote> hi, first of all please go to about:config and right-click and reset any media-related preferences like ''media.directshow.enabled'' that you have customized, as those will be detrimental to web compatibility. you can disable the built-in mediaplayer and download files instead like this: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''media.play-stand-alone'''. double-click it and change its value to '''false''', then restart the browser once. </blockquote> Thanks for the reply. Problem's finally gone. Cheers.