Search Support

Fonts on websites are not defaulting to my preference they are all condensed

  • 3 replies
  • 1 has this problem
  • 553 views
  • Last reply by grisha219

more options

After the last 2 updates with Firefox the fonts have been condensed by default. When I go into the preferences and check default fonts it says Arial, I have even gone in and changed it to other san serif and serif fonts but it still condenses it. I go into Advanced and uncheck the box "Allow pages to choose their own fonts, instead of my selections above". This fixes most of the pages I can't read but then it messes other pages that actually do use a narrow font, like the timer app in freshbooks. Main sites I am using that this is messing with are wrike and dropbox. How do I fix this so it goes back to using the websites default fonts?

Attached screenshots

Chosen solution

Dropbox uses the downloadable font "Open Sans" as its preferred typeface. (That's also the default font on this site.) The fallback font is Lucida Grande, then Segoe UI, and then Arial:

font-family: "Open Sans","lucida grande","Segoe UI",arial,verdana,"lucida sans unicode",tahoma,sans-serif

Since we know Arial looks normal in your Firefox, one of the previous three fonts may be corrupted. Could you:

(1) Clear Firefox's cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

(2) Check for a "local" copy of Open Sans that might be substituting for the downloaded version -- I don't know how to do this on a Mac

Read this answer in context 👍 1

All Replies (3)

more options

Here is the image of the same screenshot when I uncheck the box of wrike. Also 2 screenshots of the freshbook timer and dropbox.

more options

Chosen Solution

Dropbox uses the downloadable font "Open Sans" as its preferred typeface. (That's also the default font on this site.) The fallback font is Lucida Grande, then Segoe UI, and then Arial:

font-family: "Open Sans","lucida grande","Segoe UI",arial,verdana,"lucida sans unicode",tahoma,sans-serif

Since we know Arial looks normal in your Firefox, one of the previous three fonts may be corrupted. Could you:

(1) Clear Firefox's cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Command+r to check progress.

(2) Check for a "local" copy of Open Sans that might be substituting for the downloaded version -- I don't know how to do this on a Mac

more options

I had a local copy of Open Sans.

On mac, I opened Font Book and searched for it then "Removed Family"

Thank you!