Search Support

Check boxes in dialog boxes are missing

  • 11 replies
  • 3 have this problem
  • 1937 views
  • Last reply by gacl

more options

When clicking on a file that is to be downloaded from the internet a dialog box opens. The dialog box offers a few choices but there is no way to choose because the radio buttons are missing. Also, there is a scroll bar but is not visible; you have to "guess" where it is to find it. Safe mode displays the same behavior. A reset didn't help. I'm using openSUSE 42.2. Thanks.

Modified by gacl

Chosen solution

I just found out how to make checkboxes appear: Search for a page with checkboxes and open it, click and hold on an image on the same page that the checkbox is, place it on top of where a checkbox should be, and release. The checkbox should appear, along with the scrollbar and all other related functions. Really strange behavior, but it works. Not the best solution but that's all I got.

Read this answer in context 👍 0

All Replies (11)

more options

OK. Firefox just crashed and upon restart the issue was fixed. Thanks anyway. You guys are doing a good thing.

more options

After a restart the problem came back. So I deleted .Mozilla and .cache/Mozilla, removed Firefox, and installed Firefox. But the problem's still there.

Modified by gacl

more options

Try a different theme and icon pack in your Linux distribution.

more options

Chosen Solution

I just found out how to make checkboxes appear: Search for a page with checkboxes and open it, click and hold on an image on the same page that the checkbox is, place it on top of where a checkbox should be, and release. The checkbox should appear, along with the scrollbar and all other related functions. Really strange behavior, but it works. Not the best solution but that's all I got.

more options

Firefox since 46.0 has required GTK 3.4 at minimum to run so as a result it needs a GTK3 theme to theme Firefox. It looks like you have a GTK2 theme in use as to why Firefox looks unthemed and some things are missing in Firefox.

more options

The GTK version installed in my machine is 3.2, according to YaST.

more options

gacl said

The GTK version installed in my machine is 3.2, according to YaST.

openSUSE 14.1 has GTK 3.16.7 so for openSUSE 14.2 you likely mean GTK 3.20 (3.20.9 ?) (three.twenty).

Your Firefox looks like it is unthemed white and if you are missing scrollbar arrows, so either you are using XFCE which uses GTK2 Themes or KDE.

Modified by James

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

James said

gacl said
The GTK version installed in my machine is 3.2, according to YaST.

openSUSE 14.1 has GTK 3.16.7 so for openSUSE 14.2 you likely mean GTK 3.20 (3.20.9 ?) (three.twenty).

Your Firefox looks like it is unthemed white and if you are missing scrollbar arrows, so either you are using XFCE which uses GTK2 Themes or KDE.

Sorry, 3.20.9 is correct. This is the latest version of openSUSE, though: 42.2. It comes standard with KDE.

more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

The default theme is the only theme available.

more options

Even easier than my previous "solution" is to drag whatever image is there on a particular page that I may be visiting and drag-and-drop it on top of the scroll bar. The scrollbar appears as if with magic. Hopefully openSUSE will upgrade GTK - I don't want to mess with it and break something. The solution is easy enough although it has to be done every time the browser is started. I'm going to mark it as solved even if it's not really solved.