Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unresponsive script: chrome://browser/content/ext-utils.js:638

  • 11 replies
  • 2 have this problem
  • 973 views
  • Last reply by scottish2

more options

Hi

The last week or two I have been getting a pop up with the below script number. I googled it but have not found this specific number. I do seem to feel it has something to do with the browser itself as I notice if I click on the STOP SCRIPT button then I can't seem to use buttons in the browser such as tabs and bookmark bar buttons and such. I have to then shut down the browser and restart it when this occurs.

Any ideas what this script number 638 is and how to fix it as it pops up almost every time I start my browser and sometimes when I am browsing

Unresponsive script: chrome://browser/content/ext-utils.js:638

Thanks Dave

Chosen solution

I resolved it was an addon called HONEY it's a coupon code search engine that is good as it checks the net for coupon codes when you are checking out but seems it has an error in that line 638 as I disabled everything except that and the line came up exact. When it is disabled FF loads fine.

Thanks!!!

Read this answer in context 👍 0

All Replies (11)

more options

Hi Dave, 638 is the number of the line of the ext-utils.js script where Firefox is stalled.

We have a general support article addressing potential solutions to this issue: Warning Unresponsive script - What it means and how to fix it.

Another common cause of unresponsive script errors on Windows 7 is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

Hi

Thanks again!

Just so you know for the moment am going to test the FLASH option to see if that resolves this will let you know one way or the other.

Thanks Dave

more options

Well the flash option didn't work. Seems this is happening when I start up Firefox only so it is something to do with the start up part and I feel it is related to the top of the browser cause if I click stop script it disables the top of the browser but if I click continue it loads it just fine right away.

Will check out the other options in little bit when I get caught up on things.

more options

scottish2 said

Seems this is happening when I start up Firefox only so it is something to do with the start up part and I feel it is related to the top of the browser cause if I click stop script it disables the top of the browser but if I click continue it loads it just fine right away.

Interesting. The multiprocess feature of Firefox 48+ runs the interface and the content is separate processes. Perhaps there is a problem with an add-on that affects the interface?

more options

Well I am using Stylish as suggested from our last conversation out here but I just rechecked that and it only has one edit but the code in that is only 80 lines long where as the error is on line 638 so unsure if this could still be causing it or not.

Would it if so I can try disabling it and then restart the browser?

The tweak we added to stylish was for the address bar to get it longer and centered under the bar itself type edit.

Update I tried disabling Stylish and same thing same error line

Modified by scottish2

more options

I haven't tried Stylish with multiprocess. (In my main profile, multiprocess is impossible due to incompatible extensions.) Do you want to test with multiprocess disabled?

Multiprocess (e10s)

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. More and more users are gradually having this multiprocess feature switched on. The performance impact of this can vary a lot between systems: many users find it faster, some find it slower, for many it's neutral.

Mozilla is tracking extension compatibility (http://arewee10syet.com/), but there may be undiscovered glitches with some extensions believed to be compatible...

Are you using e10s?

You can confirm you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

If you think Firefox is not performing well or is using an unreasonable amount of resources now, you could evaluate whether e10s is causing this problem by turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

more options

This is what my line says when going into the trouble shooting info tab

Multiprocess Windows 0/1 (Disabled by add-ons)

more options

I think it's one of the add ones I disabled them all and it loaded fine so am turning them on one by one until I get the error

more options

Chosen Solution

I resolved it was an addon called HONEY it's a coupon code search engine that is good as it checks the net for coupon codes when you are checking out but seems it has an error in that line 638 as I disabled everything except that and the line came up exact. When it is disabled FF loads fine.

Thanks!!!

more options

Hi scottish2, congrats on solving it and thanks for naming names! I didn't realize you had other extensions (other than Stylish), and I should have suggested checking those sooner.

more options

yeah luckily when I disabled them all it came up fine so was just a matter or re-enabling them one at a time and restarting the browser until the error popped up so I knew the culprit. I have also e-mails the makers of Honey to advise them of the issue so they can look into it!