X
Tap here to go to the mobile version of the site.

Support Forum

Firefox is slow on startup

Posted

Hi Firefox is working well

But in the first execution (startup),it is very slow and after 3 second or more,speed is good

How do I fix it?

Thanks

Hi Firefox is working well But in the first execution (startup),it is very slow and after 3 second or more,speed is good How do I fix it? Thanks

Modified by omid_student

Chosen solution

Hi I disable some Add-ons and firefox startup speed is good Do you have a solution for best performance?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 23.0 r0
  • global user id

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

Adriel 13 solutions 138 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Question owner

Hi No it is same problem now. I think it takes time to load plugins

Hi No it is same problem now. I think it takes time to load plugins

Chosen Solution

Hi I disable some Add-ons and firefox startup speed is good Do you have a solution for best performance?

Hi I disable some Add-ons and firefox startup speed is good Do you have a solution for best performance?
FredMcD
  • Top 10 Contributor
4254 solutions 59575 answers

Hi there. What add-ons did you disable? Re-enable the add-ons one at a time and restart Firefox after each enable. This may find the problem.

Hi there. What add-ons did you disable? Re-enable the add-ons '''one at a time''' and '''restart Firefox''' after each enable. This may find the problem.

Question owner

My problem solved Thanks I attach screenshot that show disable add-ons

My problem solved Thanks I attach screenshot that show disable add-ons
FredMcD
  • Top 10 Contributor
4254 solutions 59575 answers

FredMcD said

Re-enable the add-ons one at a time and restart Firefox after each enable. This may find the problem.
''FredMcD [[#answer-934386|said]]'' <blockquote> Re-enable the add-ons '''one at a time''' and '''restart Firefox''' after each enable. This may find the problem. </blockquote>

Question owner

Thanks. Solved

Thanks. Solved
FredMcD
  • Top 10 Contributor
4254 solutions 59575 answers

And what was the troublemaker?

And what was the troublemaker?

Question owner

the disabled add-on is : Wappalyzer XSS Me FlashGot referer add-on is affect on speed together

the disabled add-on is : Wappalyzer XSS Me FlashGot referer add-on is affect on speed together