Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

wont accept password for gmail account

  • 7 replies
  • 5 have this problem
  • 11136 views
  • Last reply by Tonnes

more options

I want to add another gmail account. All goes well until Tbird checks my gmail password. I then see the gmail sign in dialogue which I complete but the nothing happens. I have checked that my gmail settings are correct and can accept and compose messages. Any thoghts

Chosen solution

Google sometimes blocks a login, for instance when your IP-address or device has changed. Google then decides that the attempt wasn't safe. You can verify this by logging in to your gmail via https://mail.google.com . You should see a message stating that Google has prevented that login, giving you the option to authorize it anyway. After that, the login should work again, also from the new IP-address or device/

Read this answer in context 👍 0

All Replies (7)

more options

Did you enable fetching email over POP/IMAIP in Gmail’s settings?

https://support.google.com/mail/answer/7104828?hl=en

more options

Make sure you do allow cookies for https://accounts.google.com in Thunderbird.

more options

Just got a note from Gmail saying that they stopped the attempted logon. They advised me to change my settings under sign in and security> allowing less secure apps access to my accounts. When I changed it to less secure, it worked.

more options

keithinoz said

Just got a note from Gmail saying that they stopped the attempted logon. They advised me to change my settings under sign in and security> allowing less secure apps access to my accounts. When I changed it to less secure, it worked.

Thanks for reporting back. As there are more reports mentioning this option to be required, it was the most obvious solution to expect to make it work since Gmail requires 2-Step verification these days. Sorry I didn’t point you to the Can't sign in to my email app link in the top right ones of the URL given (or its Troubleshoot problems section) covering it.

more options

This relates to an archived article #1029976. Gmail has now decided that it needs a user name and/or password for my account that previously downloaded seamlessly into Thunderbird at the same time "normal" emails were received. The above archived question said Mozilla were fixing this problem that is apparently something to do with Windows 10, and as that was back in March I'm wondering if it has been remedied. At present, when Thnderbird starts up it collects my emails then I get a popup from Google saying password etc. needed for my Gmail, but try though I may, entering the correct password, it doesn't work. What has changed? How do I fix it, please?

more options

Chosen Solution

Google sometimes blocks a login, for instance when your IP-address or device has changed. Google then decides that the attempt wasn't safe. You can verify this by logging in to your gmail via https://mail.google.com . You should see a message stating that Google has prevented that login, giving you the option to authorize it anyway. After that, the login should work again, also from the new IP-address or device/

more options

For reference: the original issue was solved.

Bruce: I assume you tried the above, and you’re not using OAuth2? Also,

  • Did/can you try removing the stored Gmail password in Thunderbird first, close the dialogs and see what happens when it asks for it?
  • What happens when you clear the cache in Options > Advanced > Network & Disk Space > Clear Now ?
  • Are you using IMAP or POP, and did you check the settings at Gmail for allowing their access?
  • If nothing helps, could you try adding a master password (if not set yet) and remove it a bit later, or change it when you have one set?

As for the other question you referred to, OAuth2 is a Gmail option, and not related to Windows 10.