Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Every time I exit Firefox it clears my active logins, but I have it set to not clear them. How can I fix this?

  • 15 replies
  • 1 has this problem
  • 15 views
  • Last reply by jscher2000

more options

My settings are as follows...

Use custom settings for history Remember my browsing and download history Remember search and form history Accept cookies from sites Accept third party cookies "Always" Keep until "I close Firefox" Clear history when Firefox closes

One example of an exception I have is hotmail http://outlook.live.com "allow" It still clears active login when I close Firefox. This is the site I'd like to keep the active login going.

Settings for clearing history Cookies and Cache are the only two with check marks

I have gone to the hotmail website, right clicked the page and clicked view page info. I have clicked the permissions tab and set cookies from default to allow.

Nothing I have done is keeping my hotmail active login.

All Replies (15)

more options

Type about:preferences#privacy<enter> in the address bar.

The button next to History, select Use Custom Settings.

Turn off Always use private browsing mode Turn on Remember my browsing and download history At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

I have to have cookies check marked and form and search history unchecked. Everything else you suggested I have already done. Are the cookies being cleared making my active logins disappear?

more options

There are two types of cookies ( actually there are more but not important). The first type stores information for the website like options. The second are the login cookies. These, if removed, log you out.

Set cookies to Save Until They Expire to fix this issue.

more options

It didn't work. I think my computer/firefox/something is glitched. UGH. Thanks for your help.

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

I don't have anything like that. I use Panda antivirus and have gone through all of the settings so it's not that. I just recently had to start clearing cookies because of Inbox Dollars, InstaGC, and Swagbucks websites. Ever since then none of my saved logins will actually save. I'm frustrated, but I can live with it...

more options

Hi april1820, you can have what you want. Here's how I do it:

(1) Set the default cookie lifetime to "Keep until: I close Firefox"

(2) For sites that I want to remember me, I add an "Allow" exception. Some ways to do this later in this reply.

The tricky part is that this may not immediately extend the lifetime of already-set cookies. Those might remain session-only cookies until you close Firefox and set new persistent cookies (or until you remove the cookies manually).

(3) Firefox is set NOT to clear history at shutdown (and if I was clearing some history items at shutdown, I would not clear cookies)


Managing individual site cookie exceptions can involve many trips to the Options page. Here are two other ways that may be more convenient:

Permissions panel of the Page Info dialog

While viewing the site, you can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Set Cookies" and uncheck the "Use default" box, and then select the permission you prefer. This is saved immediately, so you can close the dialog now.

Add-on such as Cookie Monster

The Cookie Monster button on the toolbar allows you to see permissions for first party and third party cookies and to change them.

https://addons.mozilla.org/firefox/addon/cookie-monster/

Sample screen shot attached -- the option to "Apply cookie settings to both HTTP and HTTPS" is turned on, which streamlines the menu. With this option you don't have to set/modify permissions for both HTTP or HTTPS on the same site.

more options

Thanks, jscher2000, but those didn't work. I appreciate your help.

more options

april1820 said

Thanks, jscher2000, but those didn't work.

So for example, you set Firefox to allow persistent cookies from SiteA, you logged into SiteA, then exited Firefox. At the next startup, SiteA did not find its cookie and asked you to log in again. Is that the scenario?

Next time, after you start Firefox and before you return to SiteA, check whether the cookie is present or has been cleared. You can view a list of your cookies from either:

  • Options page, Privacy panel, Show Cookies button
  • Page Info, Security panel, View Cookies button (change the site at the top to your SiteA)

If the cookie was cleared, the problem usually is one of the following:

  • Firefox set to clear history when it closes, with the Cookies box checked -- you MUST uncheck this
  • Exception was not effective because it doesn't cover the relevant domain -- try using the Permissions panel of the Page Info dialog rather than typing into the Exceptions dialog manually, or check the site's cookies after they are set to see whether any unusual addresses are involved
  • Add-on that clears cookies -- disable any such add-ons
  • External cleaning/privacy software that clears cookies - make an exception for Firefox
more options

So for example, you set Firefox to allow persistent cookies from SiteA, you logged into SiteA, then exited Firefox. At the next startup, SiteA did not find its cookie and asked you to log in again. Is that the scenario?

That is the scenario.

I have to clear cookies every time I exit Firefox. I cannot get hotmail to stay actively logged in. I cannot get any website to stay actively logged in. I have done everything you have said and nothing works.

So I can't keep active logins with cookies checked, correct? I think that is my problem and I have to live with it because it must stay checked.

more options

Is this what your settings look like?

more options

april1820 said

So I can't keep active logins with cookies checked, correct? I think that is my problem and I have to live with it because it must stay checked.

Why must you use the "Clear history when Firefox closes" feature to clear cookies???

The idea of the settings I use is that Firefox will simply discard the session cookies and keep the persistent cookies automatically without your having to use the Clear history feature. Did you test that?

Note: "Active Logins" refers to an old-style form of authentication that is separate from cookies.

more options

I have to clear cookies every time I close Firefox because of the survey websites I use. I would like to keep my search and history. I did try everything you have suggested and nothing worked. My active login for hotmail was not active anymore every time I closed Firefox and reopened it. Even though I have hotmail as an allowed exception and I have active logins unchecked.

more options

I just unchecked clear history when Firefox closes, exited Firefox, came back in and hotmail still isn't keeping me logged in. Also, when I uncheck clear history when Firefox closes and open Firefox again, it reverts all of my settings back to Firefox will remember history. So then I have to clear cookies manually etc. I am so frustrated. I give up.

more options

Firefox should remember your "Keep until" setting. And as long as you do not clear "site preferences" Firefox should remember the exceptions you create for sites you WANT to be able to set persistent cookies. If you decide to try again, let us know.

One other possible option would be to fill your surveys in a private window. Regular windows share one cookie jar, and private windows share a second cookie jar. That second jar is destroyed when you close the last private window. A new one is started the next time you launch a private window. That may allow you to do your surveys in a way that doesn't affect all other sites. (This assumes you do not need to save history related to the surveys, because history isn't saved in private windows, either.)

Please note: private windows have tracking protection turned on by default. If that interferes with your surveys, you can disable that feature. This article has more information: What happened to Tracking Protection?.