X
Tap here to go to the mobile version of the site.

Support Forum

Even with popups allowed and redirects allowed, gmail links are blocked by Firefox. How do we fix this?

Posted

By the way, this error shows in the header as "Firefox has prevented this site from opening a pop-up window." It does not say that Firefox has prevented this page from redirecting to another page, the workaround that used to "fix" the "pop-up" issue, but put the browser at risk from real unwanted redirects. Why was firefox "seeing" the redirect as a "pop-up" in the first place? In any case, it's a moot point, as now, firefox sees the gmail link as something other than a redirect or pop-up because unchecking either of these settings doesn't fix the problem.

Using 50.0 beta

By the way, this error shows in the header as "Firefox has prevented this site from opening a pop-up window." It does not say that Firefox has prevented this page from redirecting to another page, the workaround that used to "fix" the "pop-up" issue, but put the browser at risk from real unwanted redirects. Why was firefox "seeing" the redirect as a "pop-up" in the first place? In any case, it's a moot point, as now, firefox sees the gmail link as something other than a redirect or pop-up because unchecking either of these settings doesn't fix the problem. Using 50.0 beta

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 23.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0

More Information

FredMcD
  • Top 10 Contributor
4274 solutions 59937 answers

You are using a beta version so there may be bugs.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

You are using a beta version so there may be bugs. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

Thanks. It doesn't help for all links (like the ones in your email), but does for some other links. I still get the blocked pop-up error, but it opens a new tab with the link.

Also, I can right click and "open link in a new tab" and that works. Less easy than just clicking the link, but less bother than copy/pasting the link. So, I can live with it. Thanks again.

Thanks. It doesn't help for all links (like the ones in your email), but does for some other links. I still get the blocked pop-up error, but it opens a new tab with the link. Also, I can right click and "open link in a new tab" and that works. Less easy than just clicking the link, but less bother than copy/pasting the link. So, I can live with it. Thanks again.

Question owner

Just restarted with add-ons enabled. Oddly, now it seems to work the same as in safe mode. Some, but not all links will open in a new tab. The right click open in new tab is ok for a workaround.

Just restarted with add-ons enabled. Oddly, now it seems to work the same as in safe mode. Some, but not all links will open in a new tab. The right click open in new tab is ok for a workaround.
FredMcD
  • Top 10 Contributor
4274 solutions 59937 answers

It might be Safe Mode fixed a bad file.

It might be Safe Mode fixed a bad file.