Search Support

Remove new "Recently Bookmarked" section from Bookmarks Menu in Firefox 49

  • 6 replies
  • 28 have this problem
  • 16128 views
  • Last reply by jscher2000

more options

Firefox 49 introduced a new section to the Bookmarks Menu -- both the one that drops from the toolbar button and the one on the classic menu bar. It says Recently Bookmarked and is followed by the five most recently added bookmarks. How to remove it?

(Yes, it's a little obnoxious to create a new question to answer it, but I think it's the best way to help spread this information to anyone searching for it.)

Modified by jscher2000

Chosen solution

You can hide the gray heading Recently Bookmarked and following five bookmarks using one of these methods (apparently not all work on Mac):

(1) Context Menu

Right-click the "Recently Bookmarked" text and choose Hide Recently Bookmarked from the bottom of the right-click context menu (see attached screenshot)

Note: A user reported this doesn't work on the Bookmarks Menu on the main menu bar on Mac, only the bookmarks menu that drops from the toolbar button, which is pictured in the screenshot.

(2) Directly Edit a Preference

The menu item switches a hidden preference from true to false, and you can do that directly as follows:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste book and pause while the list is filtered

(C) Double-click the browser.bookmarks.showRecentlyBookmarked preference to switch the value from true to false

Read this answer in context 👍 98

All Replies (6)

more options

Chosen Solution

You can hide the gray heading Recently Bookmarked and following five bookmarks using one of these methods (apparently not all work on Mac):

(1) Context Menu

Right-click the "Recently Bookmarked" text and choose Hide Recently Bookmarked from the bottom of the right-click context menu (see attached screenshot)

Note: A user reported this doesn't work on the Bookmarks Menu on the main menu bar on Mac, only the bookmarks menu that drops from the toolbar button, which is pictured in the screenshot.

(2) Directly Edit a Preference

The menu item switches a hidden preference from true to false, and you can do that directly as follows:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste book and pause while the list is filtered

(C) Double-click the browser.bookmarks.showRecentlyBookmarked preference to switch the value from true to false

more options

Hello again jscher 2000.....sorry to ask this here, but I can't find a solution, except back in 2013....and the recommendations didn't work...I have the problem of the full screen. Cannot access Bookmarks either. I was in Firefox options for fonts/colours obviously hit something I shouldn't have, & it all went viral..lol... I will update you on my current situation. I an now seriously sight challenged. My WIN10 theme is black background with lime green text, & a light teal blue in there too, (don't really know where this comes in, either).... Back in July 2016, I bought a new computer tower & monitor, the tower is WIN 10 Home 64 bit, Acer TC-710, with a Samsung 24 inch monitor. I found I couldn't read much with the current profile, so have been tweaking it ever since. It's a minefield for someone as un-techie as me! I have no idea exactly WHAT I am changing, when I change it, so it's all trial & error, and, if you didn't know, WIN 10 is def not user friendly. I was in the middle of experimenting last evening when I had to shut down, so wasn't sure what I was gonna get this morning.... I now have the full screen in Firefox, which is my main problem right now, 'cos I need to be able to access Tools > Add ons, to maybe undo what I did.....I am trying to give you as much info as I can so you can give me a fix...I tried the options in your 2013 responses, (was very informative BTW), but did not work, 'cos I have another problem, I cannot see what is in some link boxes or drop down menus, & if I click on a link, when I want to click on that link again, it's gone, (a little problem I am having with log in to my Bank!) I have to mouse over where I think the link is &, well, guess, when the pointer changes to a hand...sigh....add-ons I am using in conjunction with the WIN 10 and Firefox options are,Theme font & size changer, (Baris Derin), and another one I cannot remember the name of, (the icon is a stylised "T") ....I tried No Squint, but disabled it, clashed with the other 2, I think I had the "T" add-on disabled before it all went West.... Please, can you help me, you have been amazingly helpful so far, so sorry for this long post, but I am desperate... As a nice gift for myself this morning, when I opened up the monitor, it was all blank, just had to guess again, (it was about 10 mins of slight panic before I realised this was the problem, groan..)...also my Desktop display was all weird, with lots of missing links....

I need to be able to get into WIN 10 to be able to try & reverse what I did, just so I can do some work today! If you need any more info, please let me know....

I hope you can help & maybe place this Q in the correct place for me.... Thank You so much Kind regards...

Sylvia aka Slim Sylv

more options

Oh, I remembered the name of the other add-on, it is called "No Small Text 4.7', developer is Peter J Sloetjes....which is so difficult to edit, I disabled it in frustration, and would Love to know how to use it, but Peter just doesn't seem to be able to explain how to programme it to people like me, a novice! Thanks, jscher 2000.... Sylvia

more options

Hi Sylvia, if Firefox has switched from regular view to full screen view, here are the ways to switch it back:

  • Keyboard shortcuts:
    • Windows: press the F11 key on the keyboard
    • Mac: press Command+Shift+f on the keyboard
  • Mouse technique: slide the mouse pointer all the way to the top of the screen and the toolbar area should slide down, then either:
    • right-click a blank area of the tab bar (or the "+" button) > Exit Full Screen Mode
    • click the "3-bar" menu button, then click the Full Screen button to toggle it off

Hopefully one of those will work for you.

more options

Oh, so sorry, did I forget to tell you that none of the suggested basic fixes did not work? Please forgive me... So, any other things to try? (I did like the options you gave in the 2013 post & will print them out when I can get it all back to normal)...Oh, the sounds came back, (for the caps lock) just then! Maybe it is trying to fix itself! I have to log off now, but will await your reply with bated breath... Thanks so much Sylvia

more options

Hi Sylvia, could you start a new question? I don't think your problems are connected to this poster's question.