Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does my bookmarks menu show recently bookmarked pages three times??

  • 16 replies
  • 18 have this problem
  • 1209 views
  • Last reply by janfol

more options

Since upgrading to the newest Firefox last night, my bookmarks menu now repeats itself. It shows 'recently added' bookmarks (which I don't want to see at all) and then offers two MORE chances to look at them. This pushes my actual bookmarks way down the page and has totally screwed up the way I work. Not happy. Can anybody help?

I'm sending a screen shot of the problem menu.

Attached screenshots

Chosen solution

To Janfol (question owner): right-click = control-click on a Mac.

I have exactly the same problem, which must have been an unannounced "improvement" in Firefox 49.0, since it appeared as soon as I updated to 49.0. There is now an unwanted "Recently Bookmarked" list with the last 5 entries in prime position at the top of my bookmarks list with no apparent option to suppress them. And it is not even a folder with the list (as it is in the identical entry at the bottom of Bookmarks): the whole list is presented.

What's the problem with this? (for those unconvinced this is even an issue) I use Firefox because of ease of organizing bookmarks; runs rings around Safari in that regard. My bookmarks list is designed to fit conveniently into my screen real estate, and get me quickly to where I need to go by only containing relevant entries (almost all are folders). Suddenly Firefox adds the most recent 5 bookmarks in prime position (top of the list). Are these even relevant? No, some might be one-use only, one is there by mistake (went to the wrong site), etc. And they still appear at the bottom also in a folder, so anyone who really wants to use this Recently Bookmarked list can easily get to it. Bad UI decision by Firefox.

I've quickly reverted to Firefox 48.0, which I grabbed from one of my other Macs. That's where I'll stay until the problem is fixed. I will have to reinstall Firefox 49.0 to see if the suggested contextual menu option to hide this "Feature" is present on Macs. Has anyone tried this?

Finally: I did NOT see the 3 entries you have, just twice: once at the top (new) and once at the bottom (by default, the last entry, just below Recent Tags).

Read this answer in context 👍 1

All Replies (16)

more options

I'm not sure about you, But this happened to me before Because of Sync. Try this :

1- Disconnect your browser from your sync account. In preferences under Sync tab, Under "Firefox Account" click "Disconnect...".

2- Remove your synced data on Server : To do so you have two Option : A) Change you sync account Password, B) Delete and Recreate your Sync Account.

2- Organize your browser data and Bookmarks the way you like. Remove additional bookmarks and Re-organize them all, Check to see if any other data is also Duplicated (Like Passwords etc.).

3- After re-organization Connect you sync account again (Or create it again if you have deleted it on step 1).

4- Sync and it should be fine.

This was what worked for me Months ago. Let me know if this can solve your problem.

more options

It can also happen if you refreshed Firefox.


Security Issue: Update your Flash Player Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 23.0.0.162 Flash Player (Linux) Version 11.2.202.635

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Hi - Thanks guys, but no, these don't work. I haven't ever signed up for a Sync account, and when I go to that page in Preferences, it merely asks me to open an account. There is no 'disconnect' option. Dang. I was hoping this would work for me, Dante Marshall, but it doesn't. Sadly. Thanks for trying.

As to the suggestion you offered, Fred McD, also not applicable. Not only have I not refreshed Firefox (I merely installed the newest version yesterday, but I have a Mac Mini running El Capitan, so the Windows things aren't applicable to me. But thanks for trying!

more options

That part of the message is for Windows and Macs. Update your outdated flash player.

more options

Thanks again, Fred McD. But my Flash Player was recently updated and is the current one.

I did manage to go in to Bookmarks/Bookmarks menu and manually delete the Recently Bookmarked and New Tabs sections (twice) but the recently bookmarked stuff still appears at the top of the page and I can't get rid of it. So this means the bookmarks I like to use frequently are being pushed further and further down the page, every time I add a new one. This is new.

more options

Could be caused by a corrupt Places file.

Install and run this extension whoch will check for database integrity. https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/

more options

janfol said

I haven't ever signed up for a Sync account, and when I go to that page in Preferences, it merely asks me to open an account. There is no 'disconnect' option.

Taking another look at your attached image, I saw duplicated bookmarks look like to be only those which a fresh installation of Firefox have !

Have you been backing up and restoring your data Locally ? Like copying your Firefox Data folder or etc. ?

Another possibility is that those Data are duplicated every time you Backed up (If you did of course !)

Still I'm not sure ! It's just a possibility :/

more options

Regarding the gray heading Recently Bookmarked followed by five bookmarks, you can suppress that using one of these methods (apparently not all work on Mac):

(1) Context Menu

Right-click the "Recently Bookmarked" text and choose Hide Recently Bookmarks from the bottom of the right-click context menu (see attached screenshot)

(2) Directly Edit a Preference

The menu item switches a hidden preference from true to false, and you can do that directly as follows:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste book and pause while the list is filtered

(C) Double-click the browser.bookmarks.showRecentlyBookmarked preference to switch the value from true to false

Unfortunately, that won't clear up the other issue, but hopefully it helps a little.

more options

Hi all, and thanks for the suggestions.

Dante Marshall - I'll keep an eye on the situation when I do backups. I do full system backups on a hard drive a couple of times a month, and back up all created files on flash drives and a second hard drive whenever I make changes. I haven't done any new backups since I installed the latest version of Firefox a couple of days ago, though.

I was able to go into the Bookmarks section and manually delete the two

extra Recently Bookmarked and New Tabs headings.  What I'm left with is simply the list of my Recently Bookmarked locations at the top of my ordinary list.  I don't want these at all, and am not sure if this is part of the new and improved Firefox, or whether there is something wrong with my version of it.  Have you got a list of Recently Bookmarked sites in your Bookmarks section?

jsher2000, thank you for that interesting potential solution. I'll see if I can make it work on my Mac. I'll have to figure out right-clicking, but I know there is a way to do it. It's just that I don't really use right-clicking on my Mac and my mouse is a single-click mouse. But it's do-able. I'll have a go at it. It sounds as if that's where the solution will lie. Thanks!

more options

Chosen Solution

To Janfol (question owner): right-click = control-click on a Mac.

I have exactly the same problem, which must have been an unannounced "improvement" in Firefox 49.0, since it appeared as soon as I updated to 49.0. There is now an unwanted "Recently Bookmarked" list with the last 5 entries in prime position at the top of my bookmarks list with no apparent option to suppress them. And it is not even a folder with the list (as it is in the identical entry at the bottom of Bookmarks): the whole list is presented.

What's the problem with this? (for those unconvinced this is even an issue) I use Firefox because of ease of organizing bookmarks; runs rings around Safari in that regard. My bookmarks list is designed to fit conveniently into my screen real estate, and get me quickly to where I need to go by only containing relevant entries (almost all are folders). Suddenly Firefox adds the most recent 5 bookmarks in prime position (top of the list). Are these even relevant? No, some might be one-use only, one is there by mistake (went to the wrong site), etc. And they still appear at the bottom also in a folder, so anyone who really wants to use this Recently Bookmarked list can easily get to it. Bad UI decision by Firefox.

I've quickly reverted to Firefox 48.0, which I grabbed from one of my other Macs. That's where I'll stay until the problem is fixed. I will have to reinstall Firefox 49.0 to see if the suggested contextual menu option to hide this "Feature" is present on Macs. Has anyone tried this?

Finally: I did NOT see the 3 entries you have, just twice: once at the top (new) and once at the bottom (by default, the last entry, just below Recent Tags).

more options

I've marked this problem as 'solved,' to keep other people from attempting to solve it along with me, but it's not. However, it's clearly not the users who are at fault. I found another thread where tons of people are having exactly the same problem since the recent upgrade. (Thread is titled: How do I get rid of the "Recently Bookmarked" section in the bookmarks toolbar?) I, along with all the other disgruntled people, want Mozilla to fix this. It's not something we did, it's something they did.

Is there any way to rattle their cages and get them to fix this? I absolutely hate this system of 'forum problem solving,' because there is no option other than 'problem solved, problem not solved.' And if you choose 'problem not solved' then lots of other people weigh in with solutions that aren't really what is needed, when it's actually a system fault, glitch or bug. And choosing 'problem solved' implies that you're going away happy. You're damned if you do, damned if you don't.

Anyway, thanks for trying to help. We await developments.

more options

Thanks for fast feedback. I can only suggest everyone hitting Firefox with feedback – go to "Submit Feedback" in the Help menu. If they get enough complaints, it should get their attention.

more options

Just did. Here's hoping. Thanks for the support. It helps to know I'm not the only one annoyed by this.

more options

Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for what you want.

more options

Here's the easy solution (no code). Mozilla won't win any awards for a clear UI with this one. It comes from entries late 9/21/16 on this thread: https://support.mozilla.org/en-US/questions/1120624 I've just re-upgraded to Firefox 49.0 on my Mac running OS 10.11 and can confirm it works.

  • Look for the Bookmarks entry icons in the Bookmarks Toolbar (the dual icons are a blue star and something that looks like a suitcase to its right).
  • Click on the "suitcase" (icon for your bookmarks list) to open your bookmarks list.
  • Control-click (right-click) anywhere in this dropdown bookmarks list, and in the resulting contextual menu "Hide Recently Bookmarked" will be the last entry. Selecting it does hide the 5 recently bookmarked entries at the top of the Bookmarks menu, but the folder at the bottom remains in case you need it. This action is reversible.

About as obscure a procedure as you could want; at least the option should also be in the bookmarks editing window (under Show All Bookmarks); it isn't, I've looked.

more options

Did what you suggested, WiscEric, and it worked. But it ONLY works by clicking the little suitcase icon next to the star. It does NOT work, accessing Bookmarks from the main Firefox/File/Edit/View/History/Bookmarks/Tools/Window/Help menu bar at the top of the screen.

Good grief. What a palaver.

Anyway, thanks! Problem really IS solved.

Modified by janfol