Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

unable to update software, permissions

  • 6 replies
  • 1 has this problem
  • 7 views
  • Last reply by James

more options

I keep getting error message: Software update, unable to update, a recommended security and stability update is available but you do not have the permissions required to install it...

I am the administrator, and I'm logged in to the administrator account.

The latest version of Firefox that shows as available to me is 43.0.1 I have installed and re-installed it several times.

I have Vista, 32 bit.

I also keep getting Flash error messages, and cannot update that either, assuming that problem is related to this.

Any help you can give me is appreciated. Thank you.

All Replies (6)

more options

Firefox 43.0.1 is very old.

Have you tried downloading the current full installer?

more options

I have done this. All it offers me from that page is 43.0.1 I don't know why that page only seems able to offer me that version.

more options

I have since found Firefox 48.0 here: http://mozilla_firefox.en.downloadastro.com/

I have downloaded what I guess is an exe setup file for it, but it will not run.

Thank you for the quick response.

more options

WilkesJournal said

I have done this. All it offers me from that page is 43.0.1 I don't know why that page only seems able to offer me that version.

Download and install this. After, go to Menu > Help > About Firefox This will check for updates.

more options

WilkesJournal said

I have since found Firefox 48.0 here: http://mozilla_firefox.en.downloadastro.com/

My WebOfTrust gives a bad review for this site.

more options

WilkesJournal said

I have done this. All it offers me from that page is 43.0.1 I don't know why that page only seems able to offer me that version.

WinXP and Vista users are served Firefox 43.0.1 for a reason. Firefox 43.0.2 and newer setups (both stub and full) on Windows is signed due to Microsoft requirement. WinXP users need SP3 to run 43.0.2 and newer setups even though current versions can run with SP2 aster updating internally starting with 43.0.1. Windows Vista users needs to have Vista updated with updates like KB2763674 to run 43.0.2 and newer setups.

It is not possible to tell by user-agents on WinXP on what SP they have and on Vista on whether they have KB2763674 installed or not.

https://support.mozilla.org/en-US/kb/get-latest-version-firefox-windows-xp-vista


WilkesJournal said

I have since found Firefox 48.0 here: http://mozilla_firefox.en.downloadastro.com/ I have downloaded what I guess is an exe setup file for it, but it will not run.

That is a random unofficial download site and the Firefox file I got is only 986 KB in size which is large for a online stub installer and really small for for a full setup.

See https://archive.mozilla.org/pub/firefox/releases/48.0.2/win32/en-US/ and download the larger setup file.

Modified by James