X
Tap here to go to the mobile version of the site.

Support Forum

Firefox lags every few seconds

Posted

Firefox lags for 5 seconds every 30 second interval. It happens when I am using the browser for several hours. Restarting the firefox solves the problem, but I can't just always restart it due to I have multiple tabs opened that I use for monitoring some business stats. Flash player plugin (set to ask to activate) is always updated and I'm sure that it's not the reason of the said issue. I don't have any extensions. What is the problem?

PS: I'm also using the latest version of firefox.

Thank you.

Firefox lags for 5 seconds every 30 second interval. It happens when I am using the browser for several hours. Restarting the firefox solves the problem, but I can't just always restart it due to I have multiple tabs opened that I use for monitoring some business stats. Flash player plugin (set to ask to activate) is always updated and I'm sure that it's not the reason of the said issue. I don't have any extensions. What is the problem? PS: I'm also using the latest version of firefox. Thank you.

Chosen solution

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194
  • 5.1.41212.0
  • Unity Player 5.2.3f1

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

FredMcD
  • Top 10 Contributor
4306 solutions 60440 answers

capssniffer said

It happens when I am using the browser for several hours

That will make it harder to discover the problem.

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.


https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

''capssniffer [[#question-1136472|said]]'' <blockquote> It happens when I am using the browser for several hours </blockquote> That will make it harder to discover the problem. Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox. ------------------- '''https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently''' '''https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster''' '''https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix''' '''https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding''' '''https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding'''

Question owner

If I turn off the "hardware acceleration" in firefox, what will be the effects in the graphical content of each web pages? Thanks.

If I turn off the "hardware acceleration" in firefox, what will be the effects in the graphical content of each web pages? Thanks.
FredMcD
  • Top 10 Contributor
4306 solutions 60440 answers

Chosen Solution

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.