Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

64-bit Firefox doesn't work properly with djshop.de / dj-shop.at

  • 9 replies
  • 2 have this problem
  • 4 views
  • Last reply by dadreamer

more options

I'm experiencing some issues on djshop.de / dj-shop.at with latest Firefox 64-bit and Waterfox also. The player on this website doesn't play any sounds. But it works successfully on 32-bit FF, IE or Google Chrome. I've been told that it is Firefox issue as there's no problem on other browsers.

Same thread on WF reddit: https://www.reddit.com/r/waterfox/comments/4z17mq/waterfox_doesnt_work_properly_with_djshopde/

Chosen solution

Decent60 said

[Update]
I was able to get it to work on Firefox v48.0.1 by making Flash "Never Activate" and reloading the page. Disabling it on the page and reloading made no difference tho. Which was strange.

The difference is that unless you use Never Activate, the site knows you have Flash and may stubbornly hold out for it.

You can hide all plugins from sites using a userscript (e.g., Hide All Plugins), or presumably an extension, but I haven't seen any built-in way to hide one plugin from a site while keeping it visible to other sites. Maybe someday.

Read this answer in context 👍 1

All Replies (9)

more options

hi if you disable the flash-plugin on that site (via the lego-like icon on the left of the address bar), media content seems to play fine on the site through html5...

more options

Does Firefox display the "speaker" icon on the page's tab or respond when you click to mute/unmute it?

Do you use the Flash protected mode? This can be toggled on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then try the opposite setting for "Enable Adobe Flash protected mode" and try that and see whether it helps.

When turning protected mode off, all Flash needs to be unloaded for at least 3 minutes in all tabs. Or you can exit and restart Firefox.

more options

philipp How can I enable HTML5 mode for that site?.. Do I need to install some plugins for it?

jscher2000 No, there's no such icon when I try to play sound. I tried to disable/enable Shockwave Flash Player and tried to reinstall it from adobe.com. It all gives nothing. On the Plugins page I don't have "special" settings for flash player. There are "Never activate", "Ask to activate" and "Always activate" options and plugin's info.

more options

Hi dadreamer, on 32-bit Firefox, when you follow the little "More" link for Flash you can access the settings in the attached screen shot. Not on 64-bit?

more options

jscher2000 I don't have such setting there. Using latest FF v48.0.1.

Modified by dadreamer

more options

Something's obviously different with 64-bit Flash + 64-bit Firefox, but I haven't searched for details.

more options

I was assisting dadreamer on another forum. There are some things that needs to be noted here:

  1. dadreamer stated they were able to get this to work on Firefox v47.0.1 32-bit.
  2. Firefox 48.0.1 64-bit doesn't work, even on a brand new installation/profile.
  3. Mute button works, so does changing the volume and adding the item to the cart (all are in the same <div> container)
  4. Tested this out with Flash protection enabled (through about:config) with no change
  5. Firefox v47 64-bit does work just fine once Flash was disabled and running HTML5 but couldn't reproduce it with Firefox v48.0.1


It's a bit odd because, although the player in Firefox is showing up behind objects on the page, in Firefox v47 it still plays with Flash player disabled.

[Update] I was able to get it to work on Firefox v48.0.1 by making Flash "Never Activate" and reloading the page. Disabling it on the page and reloading made no difference tho. Which was strange.

Modified by Decent60

more options

Chosen Solution

Decent60 said

[Update]
I was able to get it to work on Firefox v48.0.1 by making Flash "Never Activate" and reloading the page. Disabling it on the page and reloading made no difference tho. Which was strange.

The difference is that unless you use Never Activate, the site knows you have Flash and may stubbornly hold out for it.

You can hide all plugins from sites using a userscript (e.g., Hide All Plugins), or presumably an extension, but I haven't seen any built-in way to hide one plugin from a site while keeping it visible to other sites. Maybe someday.

more options

Decent60 Obviously it's not an option for me as it disables Flash Player on all sites. But yes, that works.

jscher2000 It's the best solution for now. So, I'm stopping at Hide All Plugins script as a workaround until FF development team will fix this bug or whatever it is.