X
Tap here to go to the mobile version of the site.

Support Forum

SSL: "I understand the risks" is missing when connecting to youtube.com

Posted

I am running into un-bypassable SSL errors with youtube.com. There is no "I understand the risks" option. The reason for the errors is lack of a real time clock on my system. I want to troubleshoot the lack of a bypass.

This page claims Youtube uses HSTS, whatever that is, which is not bypassable. That is not true because Qupzilla bypasses all SSL errors fine with a single setting "Ignore all SSL warnings". Chromium has the startup switch --ignore-certificate-errors which does the same thing.

I have already tried the "skip cert errors" plugin with no luck. How may I, the user, direct this open source software to do what I ask of it?

I am running into un-bypassable SSL errors with youtube.com. There is no "I understand the risks" option. The reason for the errors is lack of a real time clock on my system. I want to troubleshoot the lack of a bypass. This page claims Youtube uses HSTS, whatever that is, which is not bypassable. That is not true because Qupzilla bypasses all SSL errors fine with a single setting "Ignore all SSL warnings". Chromium has the startup switch --ignore-certificate-errors which does the same thing. I have already tried the "skip cert errors" plugin with no luck. How may I, the user, direct this open source software to do what I ask of it?

Additional System Details

Installed Plug-ins

  • Mime Type x-skype for Skype Buttons

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.8.0

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

HSTS is "strict transport security" which Firefox interprets to mean "no exceptions." Other browsers are less "strict."

I'm not clear on what your clock comment means. Are you getting a time-dependent error message? Can't you have the correct time even without a working real-time clock, or is that not how it works??

HSTS is "strict transport security" which Firefox interprets to mean "no exceptions." Other browsers are less "strict." I'm not clear on what your clock comment means. Are you getting a time-dependent error message? Can't you have the correct time even without a working real-time clock, or is that not how it works??

Question owner

Thanks for the replies.

Starting in safe mode has no effect. The problem remains.

Thanks for the replies. Starting in safe mode has no effect. The problem remains.