X
Tap here to go to the mobile version of the site.

Support Forum

Failed to load the Facebook SDK

Posted

Linking Twitter to Facebook results in message "Failed to load the Facebook SDK". Login from Twitter to Facebook account 'hangs'. Clearing cookies, disabling firewall and antivirus etc. does not help. According to forums etc lots of users have this problem, but no solution. Problem does NOT appear when I use Edge or IE11. Firefox is on latest level.

Linking Twitter to Facebook results in message "Failed to load the Facebook SDK". Login from Twitter to Facebook account 'hangs'. Clearing cookies, disabling firewall and antivirus etc. does not help. According to forums etc lots of users have this problem, but no solution. Problem does NOT appear when I use Edge or IE11. Firefox is on latest level.

Chosen solution

No private window is used. Have a look at http://stackoverflow.com/questions/33855626/firefox-blocking-facebook-js for an explanation. I changed default.trackingprotection.enabled to false in about:config, reloaded the Twitter-page and it did the trick. And in Options - Privacy the "Use Tracking protection in Private Windows" checkbox is still checked. This solved my problem. And... the are lots of issues known if you do not use the exact search phrase. Also with Chrome it seems to be a well known problem.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20045
  • Citrix Receiver Plugin (Win32)
  • Citrix URL-Redirection Helper Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.8.158
  • 5.1.50428.0
  • VLC media player Web Plugin

Application

  • Firefox 48.0b5
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
  • Support URL: https://support.mozilla.org/1/firefox/48.0/WINNT/en-US/

Extensions

  • Bookmarks Checker - check for bad links 5.8.1 (firefoxbookmarkchecker@everhelper.me)
  • DownThemAll! 2.0.19 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Firefox Hello 1.4.2 (loop@mozilla.org)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Password Exporter 1.3.2 ({B17C1C5A-04B1-11DB-9804-B622A1EF5492})
  • Pocket 1.0.3b1 (firefox@getpocket.com)
  • Pocket 3.0.6.1-signed (isreaditlater@ideashower.com)
  • uBlock Origin 1.7.6 (uBlock0@raymondhill.net)
  • Video DownloadHelper 5.6.1 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Flash and Video Download 1.84 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a}) (Inactive)
  • Lightbeam 1.3.0.1-signed (jid1-F9UJ2thwoAm5gQ@jetpack) (Inactive)
  • Norton Identity Safe 2016.7.0.62 ({C1A2A613-35F1-4FCF-B27F-2840527B6556}) (Inactive)
  • WhatsApp Panel 1.1.1.1-signed.1-signed (whatsapppanel@alejandrobrizuela.com.ar) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 22d6103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 11-18-2015
  • driverDate2:
  • driverVersion: 20.19.15.4331
  • driverVersion2:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; D3D11 blacklisted with DLL igd10iumd32.dll (20.19.15.4331); Using D3D9 API
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

It's strange, when I Google for the past 12 months there are no results for that exact phrase with Firefox:

https://www.google.com/search?tbs=qdr%3Ay&q=firefox+"Failed+to+load+the+Facebook+SDK"

Can you rule out Tracking Protection as an issue? Tracking Protection is applied by default in private windows. When Firefox blocks tracking sites, perhaps including the FB connect script, you should see a shield icon to the left of the address. This article has more info on how the feature works and the steps to make an exception for a site: What happened to Tracking Protection?.

It's strange, when I Google for the past 12 months there are no results for that exact phrase with Firefox: [https://www.google.com/search?tbs=qdr%3Ay&q=firefox+%22Failed+to+load+the+Facebook+SDK%22 https://www.google.com/search?tbs=qdr%3Ay&q=firefox+"Failed+to+load+the+Facebook+SDK"] Can you rule out Tracking Protection as an issue? Tracking Protection is applied by default in private windows. When Firefox blocks tracking sites, perhaps including the FB connect script, you should see a shield icon to the left of the address. This article has more info on how the feature works and the steps to make an exception for a site: [[Tracking Protection in Private Browsing]].

Chosen Solution

No private window is used. Have a look at http://stackoverflow.com/questions/33855626/firefox-blocking-facebook-js for an explanation. I changed default.trackingprotection.enabled to false in about:config, reloaded the Twitter-page and it did the trick. And in Options - Privacy the "Use Tracking protection in Private Windows" checkbox is still checked. This solved my problem. And... the are lots of issues known if you do not use the exact search phrase. Also with Chrome it seems to be a well known problem.

No private window is used. Have a look at http://stackoverflow.com/questions/33855626/firefox-blocking-facebook-js for an explanation. I changed default.trackingprotection.enabled to false in about:config, reloaded the Twitter-page and it did the trick. And in Options - Privacy the "Use Tracking protection in Private Windows" checkbox is still checked. This solved my problem. And... the are lots of issues known if you do not use the exact search phrase. Also with Chrome it seems to be a well known problem.
jscher2000
  • Top 10 Contributor
8634 solutions 70618 answers

Rick26 said

I changed default.trackingprotection.enabled to false in about:config, reloaded the Twitter-page and it did the trick.

I assume you mean

privacy.trackingprotection.enabled

which is "false" by default. I don't know how that got turned on in your Firefox.

If you want to keep tracking protection on for most sites, you could try using the shield icon to turn it off just for Twitter and other sites where you share your FB profile as your login method.

''Rick26 [[#answer-894648|said]]'' <blockquote> I changed default.trackingprotection.enabled to false in about:config, reloaded the Twitter-page and it did the trick.</blockquote> I assume you mean privacy.trackingprotection.enabled which is "false" by default. I don't know how that got turned on in your Firefox. If you want to keep tracking protection on for most sites, you could try using the shield icon to turn it off just for Twitter and other sites where you share your FB profile as your login method.