X
Tap here to go to the mobile version of the site.

Support Forum

Firefox will not play flash video's even when using freshplayerplugin wrapper setup.

Posted

When I try to run flash video's in Linux with Firefox setup with the freshplayerplugin wrapper the video player still say's I do not have the current version of flash running. What I want to know is why this is happening and how to fix it. In windows Firefox runs these video's correctly. The site in question is: http://xfinitytv.comcast.net/watch/Made-by-Destruction/6538990914276572112/705425475864/Coins%2C-Speakers%2C-and-Race-Cars/videos

What is the fix if there is one or am I just going to have to view them from windows.

When I try to run flash video's in Linux with Firefox setup with the freshplayerplugin wrapper the video player still say's I do not have the current version of flash running. What I want to know is why this is happening and how to fix it. In windows Firefox runs these video's correctly. The site in question is: http://xfinitytv.comcast.net/watch/Made-by-Destruction/6538990914276572112/705425475864/Coins%2C-Speakers%2C-and-Race-Cars/videos What is the fix if there is one or am I just going to have to view them from windows.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 11.92.2 for Mozilla browsers
  • np-mswmp
  • Shockwave Flash 22.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

I tried your link and got; Subscription Required

As to Linux, make sure the current (just updated) version is installed.

Flash Player (Linux) Version 11.2.202.626

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

I tried your link and got; Subscription Required As to Linux, make sure the current (just updated) version is installed. Flash Player (Linux) '''Version 11.2.202.626''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. ---------------- See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11286 answers

The freshplayerplugin wrapper as you may know makes use of the Pepper Flash from Chrome or Chromium installed on system.

Is your Chrome or Chromium browser up to date to have up to date Pepper Flash?

If you have the NPAPI Flash Plugin 11.2.x installed then Firefox may be using that either instead or has not detected the freshplayerplugin.

I have not used the freshplayerplugin for some months but I remember they both could not be active at same time.

The freshplayerplugin wrapper as you may know makes use of the Pepper Flash from Chrome or Chromium installed on system. Is your Chrome or Chromium browser up to date to have up to date Pepper Flash? If you have the NPAPI Flash Plugin 11.2.x installed then Firefox may be using that either instead or has not detected the freshplayerplugin. I have not used the freshplayerplugin for some months but I remember they both could not be active at same time.
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11286 answers

FredMcD said

As to Linux, make sure the current (just updated) version is installed. Flash Player (Linux) Version 11.2.202.626 Note: Other software is offered in the download.

I guess the freshplayerplugin was not enough of a clue that this was not about the NPAPI Flash Plugin 11.2.x. But then with you never having used Linux you may not have heard of the freshplayerplugin wrapper method.

Also there is no extra software in Mac OSX or Linux Flash Player downloads as you need to tailor your post to the OS.

''FredMcD [[#answer-888831|said]]'' <blockquote>As to Linux, make sure the current (just updated) version is installed. Flash Player (Linux) '''Version 11.2.202.626''' '''Note: Other software''' is offered in the download.</blockquote> I guess the freshplayerplugin was not enough of a clue that this was not about the NPAPI Flash Plugin 11.2.x. But then with you never having used Linux you may not have heard of the freshplayerplugin wrapper method. Also there is no extra software in Mac OSX or Linux Flash Player downloads as you need to tailor your post to the OS.

Modified by James