Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Keep Firefox from automatically updating

  • 5 replies
  • 1 has this problem
  • 3 views
  • Last reply by James

more options

Already checked a bunch of help articles:

https://support.mozilla.org/en-US/questions/1003777 https://support.mozilla.org/en-US/questions/1113663 https://support.mozilla.org/en-US/kb/install-older-version-of-firefox https://support.mozilla.org/en-US/kb/advanced-panel-settings-in-firefox#w_update-tab https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service https://support.mozilla.org/en-US/questions/1003777

We need to use Firefox 33.0.1 for testing, but every time my tools use Firefox, the next time I find it has upgraded to 45.

In preferences I have set to never update, turned off search engine updates, and in the config page, have made sure the app.update.auto/enabled/silent are all false.

I am running on a Mac 10.11, I have renamed my original latest Firefox installation, and install the oldest in the default path for our tools to detect.

I see the maintenance service only exists for Windows computers, and I do not see any update folders in Firefox's application or Application Support directories.

This update will happen even when I don't restart my computer, or open Firefox manually in between test runs.

All Replies (5)

more options

Hi, try to change the app.update.url preference to an empty string (in about:config). Any luck ?

Otherwise try the

app.update.auto/enabled/silent to false (as you said) but... lock it.

thank you

more options

Tried the lock article you posted along with repeating the usual steps we both mentioned. An update still occurred at some point from yesterday until now.

Note when I tried to prepare the preferences being locked, I did not see them appear in italics when opening the "about:config" page in FireFox when opening it after the changes were made.

Here is how I laid out the files per that article's information: /Applications/Firefox.app/ ├── Contents ├── ├── ... ├── defaults │   └── pref │   └── local-settings.js ├── mozilla.cfg └── precomplete

53 directories, 184 files

Now that I have begun to post this update, I saw a similar "defaults/pref" folder path under "Contents/MacOS". Now with taking the Installation Directory article less literally, I have moved the files in a couple of folder levels, while also making some redundancies:

/Applications/Firefox.app/ ├── Contents ├── ... │   ├── MacOS │   │   ├── ... │   │   ├── defaults │   │   │   └── pref │   │   │   └── channel-prefs.js │   │   │   └── local-settings.js │   │   ├── ... │   │   ├── firefox │   │   ├── firefox-bin │   │   ├── ... │   │   ├── mozilla.cfg │   │   ├── ... ├── defaults │   └── pref │   └── local-settings.js ├── mozilla.cfg └── precomplete

53 directories, 186 files

The files deeper in the application's sub folder hierarchy seem to take effect, and not those in the "Firefox.app/" root.

I will wait to see if this update occurs in the next few days. I have now also cleared and locked the "app.update.url" property using the same strategy.

No computer restarts have been done, only putting it to sleep (closing the MacBook's lid).

FYI, I am trying to keep FireFox version 33.1, but it keeps updating to 45.0.1, and now 46.

Also, in case someone runs into the same error I did: When opening Firefox after making some of these related changes and a error box appears relating to JavaScript and AutoConfig. This even appeared 3 times. The problem was I had used the '0' value for some of my preference lock lines (3 of them) that I read in the locking article as an example, but I was dealing with booleans, so I had to use 'false' (unquoted) instead, and then it would work fine. I attached a picture for reference.

Modified by Pysis

more options

Yup, it still updated to 46.0.1 =/

We're accumulating some useful info though :)

more options

Any luck if you UNcheck the “install app updates", App Store preference panel > Uncheck the “Install app updates".

thanks

more options

The old Firefox 33.0.1 has not been supported since the old Firefox 34.0 was Released and why such a specific old version to test with?

Are you using the old Firefox 33.0.1 and current 46.0.1 on same Mac as perhaps you are sharing the same Profile between the two when they should be using separate Profiles.