Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Paragraph mode automatically inserts two lines in new emails - the first in "paragraph" and the second in "body text"

  • 9 replies
  • 5 have this problem
  • 8 views
  • Last reply by jscher2000

more options

When using the new paragraph mode, all my emails begin with two blank lines. The top line is in "paragraph" and the second is in "body text". Removing the checkbox beside "When using paragraph format, the enter key creates a new paragraph" sets new emails back to "body text" and I only have a single line. With this option unchecked, I can manually change to "paragraph" in the composition window and only have a single line. Any idea why having "paragraph" as the default inserts the extra line? Could there be some other setting I'm missing that's causing this to happen?

All Replies (9)

more options

In earlier versions of Thunderbird, the Enter key inserted a line break rather than creating a new paragraph. Now Enter creates a new paragraph and Shift+Enter inserts a break between lines in the same paragraph. This was changed to conform with the way most HTML editors work now. See: New in Thunderbird 45.0.

If you prefer the old way, there is a checkbox for that in the Options/Preferences dialog:

Windows: "3-bar" menu button (or Tools menu) > Options Mac: "3-bar" menu button (or Thunderbird menu) > Preferences

At the top click Composition, then the General mini-tab

At the bottom of the HTML section, uncheck the box next to "When using paragraph format, the enter key creates a new paragraph" and click OK to save the change.

Here's a picture if that doesn't seem to track on your Thunderbird: https://support.cdn.mozilla.net/media/uploads/images/2016-05-03-09-51-16-401fcd.png

more options

Okay, I think there's been a bit of a miscommunication here. I understand what the new paragraph feature is and how to turn it off. The issue is that with this feature enabled, all new emails start with TWO blank lines. The first is in "paragraph." I move down a line, and the second is in "body text." Screenshot

EDIT: I was playing around with some other settings, and this behavior only occurs when using an email signature (text or image).

Modified by allieoop

more options

allieoop said

When using the new paragraph mode, all my emails begin with two blank lines. The top line is in "paragraph" and the second is in "body text". Removing the checkbox beside "When using paragraph format, the enter key creates a new paragraph" sets new emails back to "body text" and I only have a single line. With this option unchecked, I can manually change to "paragraph" in the composition window and only have a single line. Any idea why having "paragraph" as the default inserts the extra line? Could there be some other setting I'm missing that's causing this to happen?


Consider looking at your compose in html settings when using a image or signature that can cause weird wrapping behavior.

more options

Corey 'linuxmodder' Sheldon said

Consider looking at your compose in html settings when using a image or signature that can cause weird wrapping behavior.

Well, turning off "Compose in HTML" eliminates the behavior, but then I can't compose in HTML (which is not good for me). I tried adjusting the HTML settings under Global Composition (using fixed/variable width and all the different size options) and still no joy. Looks like my best bet at this point is just to turn off the paragraph thing for the time being and double space my paragraphs myself if necessary.

more options

allieoop said

Corey 'linuxmodder' Sheldon said
Consider looking at your compose in html settings when using a image or signature that can cause weird wrapping behavior.

Well, turning off "Compose in HTML" eliminates the behavior, but then I can't compose in HTML (which is not good for me). I tried adjusting the HTML settings under Global Composition (using fixed/variable width and all the different size options) and still no joy. Looks like my best bet at this point is just to turn off the paragraph thing for the time being and double space my paragraphs myself if necessary.

Yes curiosity here, how come not composing in html is not workable for you?

more options

Corey 'linuxmodder' Sheldon said

allieoop said
Corey 'linuxmodder' Sheldon said
Consider looking at your compose in html settings when using a image or signature that can cause weird wrapping behavior.

Well, turning off "Compose in HTML" eliminates the behavior, but then I can't compose in HTML (which is not good for me). I tried adjusting the HTML settings under Global Composition (using fixed/variable width and all the different size options) and still no joy. Looks like my best bet at this point is just to turn off the paragraph thing for the time being and double space my paragraphs myself if necessary.

Yes curiosity here, how come not composing in html is not workable for you?

Not workable is a bit of an overstatement I guess. I can compose without the HTML, but there are instances where using the formatting (bold, italics, etc.) comes in quite handy, and I'd hate to give up that option. Also, turning off HTML disables the paragraph thing anyway, so I gain nothing by doing so.

more options

Your insight about the signature seems important. It sounds as though there could be a conflict with the initial cursor placement between the new paragraph feature and the legacy signature feature. The cursor should be in that starting paragraph and not below it, whether you have a signature defined or not. At least, that's what I would want to happen.

(I don't have Thunderbird on this computer, so it would be a while before I could experiment.)

more options

jscher2000 said

Your insight about the signature seems important. It sounds as though there could be a conflict with the initial cursor placement between the new paragraph feature and the legacy signature feature. The cursor should be in that starting paragraph and not below it, whether you have a signature defined or not. At least, that's what I would want to happen. (I don't have Thunderbird on this computer, so it would be a while before I could experiment.)

The cursor is in the starting paragraph to begin with. That extra line is just tacked on after it for some strange reason.

more options

allieoop said

The cursor is in the starting paragraph to begin with. That extra line is just tacked on after it for some strange reason.

Oh. It makes sense to have a separation between where you are typing and the signature. An actual line break tag was previously necessary to separate the signature. Now that's arguably dispensable because the bottom margin of the paragraph element pushes the signature down, but my guess is that the code which inserts the signature doesn't check whether a line break is still necessary.