X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird 45.0 composition window, default style is "Paragraph" instead of "Body Text"

Posted

https://www.mozilla.org/en-US/thunderbird/45.0/releasenotes/ has: "Return/Enter in composer will now insert a new paragraph by default (shift-Enter will insert a line break)"

First, thanks for documenting this. Second, thanks for support all these years. Third, is there a way to set the default back to "Body Text"?

Even worse, I can't even change it back to "Body Text" without first typing some of the email body.

Thanks.

https://www.mozilla.org/en-US/thunderbird/45.0/releasenotes/ has: "Return/Enter in composer will now insert a new paragraph by default (shift-Enter will insert a line break)" First, thanks for documenting this. Second, thanks for support all these years. Third, is there a way to set the default back to "Body Text"? Even worse, I can't even change it back to "Body Text" without first typing some of the email body. Thanks.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

christ1
  • Top 10 Contributor
2039 solutions 14808 answers

Chosen Solution

See https://support.mozilla.org/en-US/kb/new-thunderbird-45#w_mail-composition

Helpful Reply

christ1 said

See https://support.mozilla.org/en-US/kb/new-thunderbird-45#w_mail-composition

Thanks, this will work.

Additional feedback below.

Lin above says: "The Thunderbird composition window now functions more like a word processor in that pressing the "Enter" key inserts a new paragraph, pressing "Shift+Enter" inserts a new line. This new behavior can be switched off in the Thunderbird > Preferences > Composition > General tab."

It's ok that "Paragraph" mode Enter-Key inserts a new paragraph. What was not ok was making "Paragraph" mode the default. When I uncheck "When using paragraph format, they enter key creates a new paragraph", great, it makes the default style "Body Text" again. It also makes "Paragraph" mode act differently. IMO, you would be better off just allowing folks to set the default mode than making "Paragraph" mode work differently.

''christ1 [[#answer-869992|said]]'' <blockquote> See https://support.mozilla.org/en-US/kb/new-thunderbird-45#w_mail-composition </blockquote> Thanks, this will work. Additional feedback below. Lin above says: ''"The Thunderbird composition window now functions more like a word processor in that pressing the "Enter" key inserts a new paragraph, pressing "Shift+Enter" inserts a new line. This new behavior can be switched off in the Thunderbird > Preferences > Composition > General tab."'' It's ok that "Paragraph" mode Enter-Key inserts a new paragraph. What was not ok was making "Paragraph" mode the default. When I uncheck ''"When using paragraph format, they enter key creates a new paragraph''", great, it makes the default style "Body Text" again. It also makes "Paragraph" mode act differently. IMO, you would be better off just allowing folks to set the default mode than making "Paragraph" mode work differently.
Huusoku 0 solutions 5 answers

Helpful Reply

long_time_tbird_user said

What was not ok was making "Paragraph" mode the default. ... IMO, you would be better off just allowing folks to set the default mode than making "Paragraph" mode work differently.

X2. I _rarely_ log into this support forum. I have been very annoyed by this new "Paragraph" default behavior I searched and searched and found the solution to uncheck Composition > General | "When using paragraph format, ..." which actually now has restored "Body Text" by default, which is the expected behavior of mine ever since I became a Thunderbird user back with version 1.5.

DUMB move Thunderbird. The only way this makes sense is if it was a 10-year standing bug that was only now fixed. Otherwise the move is horrible for anyone who has been using TB for a while.

Mozilla, please do not forget that open source & community driven software attracts users like myself who were fed up with corporate, closed, low or poor configuration software. Usability IS the #1 driving force you guys have against such software as MS Outlook. When you take that away you become just another corporate software and when changes are literally forced upon an end user such as myself it is one more reason to look in the other direction for "small community software" again.

Having said that, I love TB and love FX. I have donated to the foundation before and may do so again. Please keep up the good work. Just don't force things on us and expect us to not notice.

Respectfully submitted, Huusoku

''long_time_tbird_user [[#answer-870002|said]]'' <blockquote> What was not ok was making "Paragraph" mode the default. ... IMO, you would be better off just allowing folks to set the default mode than making "Paragraph" mode work differently. </blockquote> X2. I _rarely_ log into this support forum. I have been very annoyed by this new "Paragraph" default behavior I searched and searched and found the solution to uncheck Composition > General | "When using paragraph format, ..." which actually now has restored "Body Text" by default, which is the expected behavior of mine ever since I became a Thunderbird user back with version 1.5. DUMB move Thunderbird. The only way this makes sense is if it was a 10-year standing bug that was only now fixed. Otherwise the move is horrible for anyone who has been using TB for a while. Mozilla, please do not forget that open source & community driven software attracts users like myself who were fed up with corporate, closed, low or poor configuration software. Usability IS the #1 driving force you guys have against such software as MS Outlook. When you take that away you become just another corporate software and when changes are literally forced upon an end user such as myself it is one more reason to look in the other direction for "small community software" again. Having said that, I love TB and love FX. I have donated to the foundation before and may do so again. Please keep up the good work. Just don't force things on us and expect us to not notice. Respectfully submitted, Huusoku

Modified by Huusoku

Msca 0 solutions 1 answers

Huusoku said

I searched and searched and found the solution to uncheck Composition > General | "When using paragraph format, ..." which actually now has restored "Body Text" by default

That's the solution that worked for me, Thank you Huusoku!

''Huusoku [[#answer-874813|said]]'' <blockquote> I searched and searched and found the solution to uncheck Composition > General | "When using paragraph format, ..." which actually now has restored "Body Text" by default </blockquote> That's the solution that worked for me, Thank you Huusoku!
RJGnyc 0 solutions 13 answers
It's ok that "Paragraph" mode Enter-Key inserts a new paragraph. What was not ok was making "Paragraph" mode the default. When I uncheck "When using paragraph format, they enter key creates a new paragraph", great, it makes the default style "Body Text" again. It also makes "Paragraph" mode act differently. IMO, you would be better off just allowing folks to set the default mode than making "Paragraph" mode work differently.

I agree.

Now I'm curious -- how does the "Paragraph" mode act differently?

<blockquote> It's ok that "Paragraph" mode Enter-Key inserts a new paragraph. What was not ok was making "Paragraph" mode the default. When I uncheck ''"When using paragraph format, they enter key creates a new paragraph''", great, it makes the default style "Body Text" again. It also makes "Paragraph" mode act differently. IMO, you would be better off just allowing folks to set the default mode than making "Paragraph" mode work differently. </blockquote> I agree. Now I'm curious -- how does the "Paragraph" mode act differently?

Modified by RJGnyc

Question owner

RJGnyc said

how does the "Paragraph" mode act differently?

Mozilla folks added this knob under Preferences->Composition "When using paragraph format, the enter key creates a new paragraph." and made it the default (it is checked "on" by default).

When you compose new message, the default format is now "Paragraph". When you hit <enter> in the body of the email in "Paragraph" mode, it puts an extra space between the previous line and the new one you are about to type.

This is all fine and dandy and is how Paragraph mode should work, IMO. To me, this behavior DEFINES Paragraph mode.

To answer your question "how does the Paragraph mode act differently?"

When you deselect the knob: "When using paragraph format, the enter key creates a new paragraph." it makes Paragraph mode act differently. Now you do not get the extra space when you it <enter>.

I don't like Paragraph mode. I like "Body Text" mode.

When you deselect the knob: "When using paragraph format, the enter key creates a new paragraph." it ALSO makes the defaults "Body Text" mode when composing a new email.

I'm happy that I get the default mode I want.

My only suggestion here is that the new knob should have been called:

"When composing a new email, the default mode is: <choice>"

and default should have been "Body Text" like it has been for a long time now. "Paragraph" mode would be one of the choices and if you choose that mode, it should add new space like it is supposed to. I think it was wrong to provide a knob to change the behavior of "Paragraph" mode. That seemed like the wrong way to provide the previous behavior.

''RJGnyc [[#answer-888557|said]]'' <blockquote> how does the "Paragraph" mode act differently? </blockquote> Mozilla folks added this knob under Preferences->Composition "When using paragraph format, the enter key creates a new paragraph." and made it the default (it is checked "on" by default). When you compose new message, the default format is now "Paragraph". When you hit <enter> in the body of the email in "Paragraph" mode, it puts an extra space between the previous line and the new one you are about to type. This is all fine and dandy and is how Paragraph mode should work, IMO. To me, this behavior DEFINES Paragraph mode. To answer your question "how does the Paragraph mode act differently?" When you deselect the knob: "When using paragraph format, the enter key creates a new paragraph." it makes Paragraph mode act differently. Now you do not get the extra space when you it <enter>. I don't like Paragraph mode. I like "Body Text" mode. When you deselect the knob: "When using paragraph format, the enter key creates a new paragraph." it '''''ALSO''''' makes the defaults "Body Text" mode when composing a new email. I'm happy that I get the default mode I want. My only suggestion here is that the new knob should have been called: "When composing a new email, the default mode is: <choice>" and default should have been "Body Text" like it has been for a long time now. "Paragraph" mode would be one of the choices and if you choose that mode, it should add new space like it is supposed to. I think it was wrong to provide a knob to change the behavior of "Paragraph" mode. That seemed like the wrong way to provide the previous behavior.
DanskerDave 0 solutions 1 answers

Firstly: the option shouldn't have been changed. The majority of people just want to use Enter as usual.

Secondly: the "solution" isn't a solution at all, not even a workaround. It fundamentally changes the behaviour of the Paragraph format.

What is required is: a) reinstatement of the old behaviour b) an option to allow people to switch from Body Text -> Paragraph

Firstly: the option shouldn't have been changed. The majority of people just want to use Enter as usual. Secondly: the "solution" isn't a solution at all, not even a workaround. It fundamentally changes the behaviour of the Paragraph format. What is required is: a) reinstatement of the old behaviour b) an option to allow people to switch from Body Text -> Paragraph

Question owner

DanskerDave said

Firstly: the option shouldn't have been changed.

If you change "option" to "default", I agree.

'DanskerDave said

b) an option to allow people to switch from Body Text -> Paragraph

The option exists as part of composition windows. The problem is: the default is now Paragraph mode. I think b) above should be:

b) under Thunderbird -> Preferences -> Composition

Replace: "When using paragraph format, the enter key creates a new paragraph" with a drop down chooser (like the one in Composition Window) labeled: "When starting Composition Window, use this as the default format". I believe the default should be Body Text (as it has been for years).

''DanskerDave [[#answer-896661|said]]'' <blockquote> Firstly: the option shouldn't have been changed. </blockquote> If you change "option" to "default", I agree. 'DanskerDave [[#answer-896661|said]]'' <blockquote> b) an option to allow people to switch from Body Text -> Paragraph </blockquote> The option exists as part of composition windows. The problem is: the '''''default''''' is now Paragraph mode. I think ''' b) ''' above should be: b) under Thunderbird -> Preferences -> Composition Replace: "When using paragraph format, the enter key creates a new paragraph" with a drop down chooser (like the one in Composition Window) labeled: "When starting Composition Window, use this as the default format". I believe the default should be Body Text (as it has been for years).
gmeades 0 solutions 11 answers

Why couldn't anyone simply say -

TO CHANGE THE DEFAULT COMPOSITION TYPE BACK TO "BODY TEXT"

'1. Go to the main Thunderbird window and select the following from the menu bar -Tools > Options > Composition > General tab,

2. Uncheck the box that says "when using paragraph format, pressing the enter key creates a new paragraph'.

Doing this will change the default composition type from "paragraph" back to "body text", and make the enter key to provide single spacing rather than double spacing again.

Was that really too hard for anyone to do...?

....and as others have mentioned - whoever thought changing the default composition type to paragraph, altering the way the enter key works to double space every time it is pressed needs to take some time off from coding, as they've clearly lost the ability to understand how the majority of Thunderbird users use the program and expect the enter key to function.

99% of users expect and rely on the enter key to provide single spacing when it is pressed.

Allowing the small percentage of users who want to alter the way the enter key functions, to double space when it is pressed, should be a modification to the default configuration which those users elect to do if they wish to change the normal functioning of the enter key, and NOT the default setting for the program.

Why couldn't anyone simply say - '''TO CHANGE THE DEFAULT COMPOSITION TYPE BACK TO "BODY TEXT"''' ''''1. Go to the main Thunderbird window and select the following from the menu bar -Tools > Options > Composition > General tab, '''2. Uncheck the box that says "when using paragraph format, pressing the enter key creates a new paragraph'.''' '''Doing this will change the default composition type from "paragraph" back to "body text", and make the enter key to provide single spacing rather than double spacing again.''' Was that really too hard for anyone to do...? ....and as others have mentioned - whoever thought changing the default composition type to paragraph, altering the way the enter key works to double space every time it is pressed needs to take some time off from coding, as they've clearly lost the ability to understand how the majority of Thunderbird users use the program and expect the enter key to function. 99% of users expect and rely on the enter key to provide single spacing when it is pressed. Allowing the small percentage of users who want to alter the way the enter key functions, to double space when it is pressed, should be a modification to the default configuration which those users elect to do if they wish to change the normal functioning of the enter key, and NOT the default setting for the program.

Modified by gmeades