X
Tap here to go to the mobile version of the site.

Support Forum

Can't change font

Posted

I recently refreshed Firefox, and found myself suddenly dealing with an inability to clearly see and read what the letters on my screen were. I tried to change the font back to what it was, and that failed. I thought maybe refreshing again would fix the problem (I'm and optimist), but no. Changing the setting in options changes nothing in my browser. It's irritating because I don't like other browsers, but unless this can be corrected, I may have to find a new one.

I recently refreshed Firefox, and found myself suddenly dealing with an inability to clearly see and read what the letters on my screen were. I tried to change the font back to what it was, and that failed. I thought maybe refreshing again would fix the problem (I'm and optimist), but no. Changing the setting in options changes nothing in my browser. It's irritating because I don't like other browsers, but unless this can be corrected, I may have to find a new one.

Additional System Details

Installed Plug-ins

  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • iTunes Detector Plug-in
  • mydlink services plugin

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • Ghostery 6.2.0 (firefox@ghostery.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Speed Dial 0.9.6.18 ({64161300-e22b-11db-8314-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0f31
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 8-17-2015
  • driverDate2:
  • driverVersion: 10.18.10.4276
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4272 solutions 59923 answers

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Mac You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 Mac You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Question owner

I've actually made sure that websites can choose their own font. It's not helping the situation any, sadly. Somehow, the refresh caused this. I've scoured the boards for ideas on how to fix the problem before posting, and none of the suggestions has worked. Hence my frustration. I now have to have my zoom at 150% to clearly read my homepage. Otherwise text is all spindly and scrunched.

I've actually made sure that websites can choose their own font. It's not helping the situation any, sadly. Somehow, the refresh caused this. I've scoured the boards for ideas on how to fix the problem before posting, and none of the suggestions has worked. Hence my frustration. I now have to have my zoom at 150% to clearly read my homepage. Otherwise text is all spindly and scrunched.
jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

Is this problem helped at all by using the zoom feature to enlarge page contents? You're probably familiar, but just in case, you can enlarge page contents using either:

  • hold down Ctrl and tap the + key a couple times
  • click the "3-bar" menu button, then look for the row similar to
    - | 100% | +
    and use the + button there (the value in the center acts as a reset button)

If larger fonts still look bad, could you describe the problem in more detail? For example, spindly, pixelated, badly spaced, etc. And perhaps give the URL of a page where this is at its worst and indicate the most problematic part of the page.

Note: If you use a Windows "high contrast" theme, Firefox normally suppresses background colors and that can break some pages where the background color is essential for contrast (for avoiding black on black, for example). You may need custom settings assistance in that case.

Note: If the problem affects the toolbar area, then you may need an add-on for that. Here's one that lets you upsize toolbar and menu text and choose your own font for those without affecting web pages: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/

Is this problem helped at all by using the zoom feature to enlarge page contents? You're probably familiar, but just in case, you can enlarge page contents using either: * hold down Ctrl and tap the + key a couple times * click the "3-bar" menu button, then look for the row similar to <br><code>- | 100% | +</code> <br>and use the + button there (the value in the center acts as a reset button) If larger fonts still look bad, could you describe the problem in more detail? For example, spindly, pixelated, badly spaced, etc. And perhaps give the URL of a page where this is at its worst and indicate the most problematic part of the page. Note: If you use a Windows "high contrast" theme, Firefox normally suppresses background colors and that can break some pages where the background color is essential for contrast (for avoiding black on black, for example). You may need custom settings assistance in that case. Note: If the problem affects the toolbar area, then you may need an add-on for that. Here's one that lets you upsize toolbar and menu text and choose your own font for those without affecting web pages: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/
jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

Hi LakeSpirit, sorry I didn't see your last post when I was composing mine. Are the fonts in your toolbar area a good size, it's just fonts in web pages?

  • Just web pages: try one of these to set a higher "default" zoom level so you don't have to zoom manually on every site:
Hi LakeSpirit, sorry I didn't see your last post when I was composing mine. Are the fonts in your toolbar area a good size, it's just fonts in web pages? * '''Just web pages:''' try one of these to set a higher "default" zoom level so you don't have to zoom manually on every site: ** [https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ Default FullZoom Level] ** [https://addons.mozilla.org/firefox/addon/zoom-page/ Zoom Page] (includes "fit to window" feature) ** [https://addons.mozilla.org/firefox/addon/nosquint/ NoSquint] * '''Everything:''' There is a global setting in the [https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ Theme Font & Size Changer] extension I mentioned before.

Question owner

Zooming in actually makes it more pronounced and annoying. I don't use a high contrast theme, and this affects all areas of the screen. It often even cancels out the selected text of websites. The text is spindly, pixelated, and badly spaced to the point that I laughed when I read that. It even happens here, but zooming in is necessary to correct the spacing issues to read things clearly.

Zooming in actually makes it more pronounced and annoying. I don't use a high contrast theme, and this affects all areas of the screen. It often even cancels out the selected text of websites. The text is spindly, pixelated, and badly spaced to the point that I laughed when I read that. It even happens here, but zooming in is necessary to correct the spacing issues to read things clearly.
jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

Hmm, could you check whether any font rendering preferences have been modified from their default values. It seems unlikely after a Refresh, but just in case:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste font_r and pause while the list is filtered

(3) If any are bolded and "user set" you can right-click > Reset them

You probably need to exit and start Firefox back up again to see any difference.


Blocky character edges can point to a change to the gfx.font_rendering.cleartype_params.rendering_mode preference. Here's my understanding of what the numbers do (as of Firefox 45):

//     -1 or 0 = use default for font & size;
//     4 = Natural;
//     5 = Natural Symmetric
=> Sub-pixel anti-aliasing/positioning (smoothest)
//     1 = aliased;
//     2 = GDI Classic;
=> GDI emulation (whole pixel rendering -- blocky)
//     3 = GDI Natural Widths;
=> GDI emulation with natural widths (?)
Hmm, could you check whether any font rendering preferences have been modified from their default values. It seems unlikely after a Refresh, but just in case: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''font_r''' and pause while the list is filtered (3) If any are bolded and "user set" you can right-click > Reset them You probably need to exit and start Firefox back up again to see any difference. ---- Blocky character edges can point to a change to the '''gfx.font_rendering.cleartype_params.rendering_mode''' preference. Here's my understanding of what the numbers do (as of Firefox 45): // -1 or 0 = use default for font & size; // 4 = Natural; // 5 = Natural Symmetric => Sub-pixel anti-aliasing/positioning (smoothest) // 1 = aliased; // 2 = GDI Classic; => GDI emulation (whole pixel rendering -- blocky) // 3 = GDI Natural Widths; => GDI emulation with natural widths (?)

Question owner

The Theme Font Size Changer has corrected the issues in my bar, but I'm still having issues with pages. And everything with my config checks out at default, where I like it. I'm honestly bit even sure what font is being used, but it's not Arial like I prefer.

The Theme Font Size Changer has corrected the issues in my bar, but I'm still having issues with pages. And everything with my config checks out at default, where I like it. I'm honestly bit even sure what font is being used, but it's not Arial like I prefer.
jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

You can try forcing Arial on all sites by flipping the setting Fred mentioned. In other words, do not let pages choose their own fonts. This may break icons on some sites.

Alternately, if the problem is mostly with downloadable fonts like the "Open Sans" font used on this site, you could instead try disabling downloaded fonts. (This may also break icons on some sites, but Firefox might grab the icon files even with this setting changed when it's obvious they are icons.) This may have closer fidelity to the intended design.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fonts and pause while the list is filtered

(3) Double-click the gfx.downloadable_fonts.enabled preference to switch it from true to false

Then reload the problem page bypassing the cache using Ctrl+Shift+r and Firefox should use a "fallback" font stored on your system instead of the site's preferred downloadable font.

Any improvement?

You can try forcing Arial on all sites by flipping the setting Fred mentioned. In other words, do not let pages choose their own fonts. This may break icons on some sites. Alternately, if the problem is mostly with downloadable fonts like the "Open Sans" font used on this site, you could instead try disabling downloaded fonts. (This may also break icons on some sites, but Firefox might grab the icon files even with this setting changed when it's obvious they are icons.) This may have closer fidelity to the intended design. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''fonts''' and pause while the list is filtered (3) Double-click the '''gfx.downloadable_fonts.enabled''' preference to switch it from true to false Then reload the problem page bypassing the cache using Ctrl+Shift+r and Firefox should use a "fallback" font stored on your system instead of the site's preferred downloadable font. Any improvement?