X
Tap here to go to the mobile version of the site.

Support Forum

How to enable TLS 1.2 in firefox 18.0.1

Posted

I have firefox 18.0.1 on windows OS. And there is a problem with TSL 1.2. In about:config this is all what I have regarding TLS:

security.enable_tls;true security.enable_tls_session_tickets;true services.sync.prefs.sync.security.enable_tls;true

There is no security.tls.version.max.

In Options-->Advanced-->Encryption there is only "Use TLS 1.0"

How to enable TLS 1.2?

I have firefox 18.0.1 on windows OS. And there is a problem with TSL 1.2. In about:config this is all what I have regarding TLS: security.enable_tls;true security.enable_tls_session_tickets;true services.sync.prefs.sync.security.enable_tls;true There is no security.tls.version.max. In Options-->Advanced-->Encryption there is only "Use TLS 1.0" How to enable TLS 1.2?
Attached screenshots

Chosen solution

hi matko7, firefox 18 is unsuppported and contains dozens of highly critical security vulnerabilities that are exploited on the web. tls 1.2 wasn't present in firefox 18 either, so please update firefox to the latest version!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 21.0 r0
  • Google Update
  • 5.1.41212.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • Citrix URL-Redirection Helper Plugin
  • Citrix Receiver Plugin (Win32)
  • VLC media player Web Plugin
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

{"libraryVersions": {"NSSSMIME": {"minVersion": "3.14.1.0 Basic ECC", "version": "3.14.1.0 Basic ECC"}, "NSSUTIL": {"minVersion": "3.14.1.0", "version": "3.14.1.0"}, "NSS": {"minVersion": "3.14.1.0 Basic ECC", "version": "3.14.1.0 Basic ECC"}, "NSSSSL": {"minVersion": "3.14.1.0 Basic ECC", "version": "3.14.1.0 Basic ECC"}, "NSPR": {"minVersion": "4.9.4", "version": "4.9.4"}}, "javaScript": {"incrementalGCEnabled": true}, "accessibility": {"forceDisabled": 0, "isActive": false}, "application": {"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0", "supportURL": "http://support.mozilla.org/1/firefox/18.0.1/WINNT/en-US/", "version": "18.0.1", "name": "Firefox"}, "modifiedPreferences": {"security.warn_viewing_mixed": false, "browser.places.smartBookmarksVersion": 4, "network.cookie.prefsMigrated": true, "browser.link.open_newwindow": 2, "browser.cache.disk.capacity": 358400, "browser.startup.homepage_override.buildID": "20130116073211", "browser.cache.disk.smart_size.first_run": false, "places.history.expiration.transient_current_max_pages": 104858, "browser.startup.homepage_override.mstone": "18.0.1", "dom.disable_open_during_load": false, "browser.tabs.warnOnClose": false, "extensions.lastAppVersion": "18.0.1", "browser.cache.disk.smart_size_cached_value": 358400, "gfx.direct3d.prefer_10_1": true, "browser.cache.disk.smart_size.use_old_max": false, "browser.startup.homepage": "http://internal.ericsson.com/", "privacy.sanitize.migrateFx3Prefs": true, "network.dns.disablePrefetch": true, "places.database.lastMaintenance": 1463125568}, "extensions": [{"version": "4.5.6", "name": "FoxyProxy Standard", "isActive": true, "id": "foxyproxy@eric.h.jung"}, {"version": "1.1a.1-signed.1-signed", "name": "Troubleshooter", "isActive": true, "id": "troubleshooter@mozilla.org"}], "graphics": {"directWriteEnabled": false, "driverDate": "10-7-2013", "adapterVendorID2": "", "driverVersion": "9.18.10.3324", "webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics 4600)", "driverDate2": "", "adapterDeviceID": "0x0416", "adapterDescription": "Intel(R) HD Graphics 4600", "directWriteVersion": "6.2.9200.17568", "driverVersion2": "", "adapterVendorID": "0x8086", "direct2DEnabled": false, "adapterRAM": "Unknown", "adapterDrivers2": "", "isGPU2Active": false, "adapterRAM2": "", "numTotalWindows": 2, "direct2DEnabledMessage": ["blockedDriver"], "info": {"AzureContentBackend": "none", "AzureCanvasBackend": "cairo", "AzureFallbackCanvasBackend": "none"}, "numAcceleratedWindows": 2, "windowLayerManagerType": "Direct3D 9", "adapterDeviceID2": "", "adapterDrivers": "igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32", "adapterDescription2": ""}}

philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23502 answers

Chosen Solution

hi matko7, firefox 18 is unsuppported and contains dozens of highly critical security vulnerabilities that are exploited on the web. tls 1.2 wasn't present in firefox 18 either, so please update firefox to the latest version!

hi matko7, firefox 18 is unsuppported and contains dozens of highly critical security vulnerabilities that are exploited on the web. tls 1.2 wasn't present in firefox 18 either, so please [https://www.mozilla.org/firefox/update/ update firefox to the latest version]!

Modified by philipp

Question owner

Ok. It is solved in newer version.

Thx

Ok. It is solved in newer version. Thx
James
  • Top 25 Contributor
  • Moderator
1602 solutions 11327 answers

TLS 1.2 support was added as of Gecko 24.0 or Firefox 24.0 as the old Firefox 18.0.1 did not support TLS 1.2.

TLS 1.2 support was added as of Gecko 24.0 or Firefox 24.0 as the old Firefox 18.0.1 did not support TLS 1.2.