X
Tap here to go to the mobile version of the site.

Support Forum

Firefox is always on top and can't switch to other applications!

Posted

I am using Firefox 46.0.1 on windows 10. All of sudden FF is always on top and i can't switch to any other running applications.

When i minimize FF, everything is working properly.

I Checked the forum here and tried almost every suggested solution but the problem is still there.

I disabled all addons and the problem remained, I unchecked the "user Hardware acceleration" and the problem remained. I even refreshed FF and started from scratch and the problem is the same.

It's really so annoying!

I am using Firefox 46.0.1 on windows 10. All of sudden FF is always on top and i can't switch to any other running applications. When i minimize FF, everything is working properly. I Checked the forum here and tried almost every suggested solution but the problem is still there. I disabled all addons and the problem remained, I unchecked the "user Hardware acceleration" and the problem remained. I even refreshed FF and started from scratch and the problem is the same. It's really so annoying!

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.15
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • Media Go Detector Plug-in
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • LastPass Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealTimes Download Plugin
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • Yahoo Application State Plugin version 1.0.0.7
  • iTunes Detector Plug-in

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom)
  • DownThemAll! 2.0.19 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • DownThemAll! AntiContainer 1.5 (anticontainer@downthemall.net)
  • DownThemAll! v3.0b6 Windows 10 FIX 1.0.1 (dta3noaero@vano)
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • IDM integration 6.25.16 (mozilla_cc2@internetdownloadmanager.com)
  • LastPass 3.3.1 (support@lastpass.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Pure URL 1.2.4.1-signed.1-signed (pure-url@jetpack)
  • Skype 8.1.0.9134 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2: NVIDIA GeForce GT 630M
  • adapterDeviceID: 0x0166
  • adapterDeviceID2: 0x0de9
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 181d103c
  • adapterSubsysID2: 181d103c
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 8-17-2015
  • driverDate2: 4-27-2016
  • driverVersion: 10.18.10.4276
  • driverVersion2: 10.18.13.6510
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
Phoxuponyou 51 solutions 517 answers

I am not aware that Firefox has this ability natively, so this might be something gone wrong in Windows' window order arrangement.

According to https://social.technet.microsoft.com/Forums/en-US/c667c9f0-0ad9-497f-b084-6e1d3fbc87ec/windows-stuck-in-always-on-top-mode?forum=WinPreview2014General, you might want to try messing with the windows by way of cascading or stacking. This might break the deadlock on one window being given constant front stage priority.

I am not aware that Firefox has this ability natively, so this might be something gone wrong in Windows' window order arrangement. According to https://social.technet.microsoft.com/Forums/en-US/c667c9f0-0ad9-497f-b084-6e1d3fbc87ec/windows-stuck-in-always-on-top-mode?forum=WinPreview2014General, you might want to try messing with the windows by way of cascading or stacking. This might break the deadlock on one window being given constant front stage priority.

Question owner

Hello Phoxuponyou, I tried what you said and still it didn't do any thing. The problem is still the same. If I want to switch to another application, I have to minimize FF to the taskbar first!

Hello Phoxuponyou, I tried what you said and still it didn't do any thing. The problem is still the same. If I want to switch to another application, I have to minimize FF to the taskbar first!
Phoxuponyou 51 solutions 517 answers

Okay, so you tried reordering (repeatedly I hope) and restoring the window size (reducing from Maximised).

If you go to Task Manager in Windows (press Ctrl+Shift+Esc), go to the Processes tab, right-click the Firefox instance and select Bring to Front from the drop-down menu, does that break the deadlock? How about if you do it with another program?

PS. Try putting Firefox in fullscreen and back again as well: press F11 to toggle fullscreen mode (https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_miscellaneous).

Okay, so you tried reordering (repeatedly I hope) and restoring the window size (reducing from Maximised). If you go to Task Manager in Windows (press Ctrl+Shift+Esc), go to the ''Processes'' tab, right-click the Firefox instance and select ''Bring to Front'' from the drop-down menu, does that break the deadlock? How about if you do it with another program? PS. Try putting Firefox in fullscreen and back again as well: press F11 to toggle fullscreen mode (https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_miscellaneous).

Modified by Phoxuponyou

Question owner

Yes, i tried repeatedly but still nothing.

I Tried to "Bring to Front" from task manager and nothing. The Deadlock is still there.

I also tried switching the Fullscreen and back but also nothing.

Yes, i tried repeatedly but still nothing. I Tried to "Bring to Front" from task manager and nothing. The Deadlock is still there. I also tried switching the Fullscreen and back but also nothing.
Phoxuponyou 51 solutions 517 answers

Wow. That's pretty much the options I know of in Firefox and Windows exhausted. If you're not running any software that would do this on behalf of Windows/Firefox, I think I'm all out.

"Have you turning the computer off, then turning it back on again?" @.@

Wow. That's pretty much the options I know of in Firefox and Windows exhausted. If you're not running any software that would do this on behalf of Windows/Firefox, I think I'm all out. ''"Have you turning the computer off, then turning it back on again?"'' @.@

Question owner

Well, thanks for your assistance. I don't have any software or add on that do this with FF!

Yes the problem happened a couple of days ago and i was trying to solve it myself but in vain.

I did turn off the computer several times.

Well, thanks for your assistance. I don't have any software or add on that do this with FF! Yes the problem happened a couple of days ago and i was trying to solve it myself but in vain. I did turn off the computer several times.
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia


https://support.microsoft.com

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' ----------- https://support.microsoft.com

Question owner

Hello Fred, I started the computer in safe mode with networking as you said and the problem is gone.

However, when i booted the computer normally, the problem appeared again!

Hello Fred, I started the computer in safe mode with networking as you said and the problem is gone. However, when i booted the computer normally, the problem appeared again!
Phoxuponyou 51 solutions 517 answers

Since this is the case, I'll quote what Microsoft say about Windows' Safe Mode:

" Safe mode is a troubleshooting option for Windows that starts your computer in a limited state. Only the basic files and drivers necessary to run Windows are started. The words Safe Mode appear in the corners of your monitor to identify which Windows mode you're using.

If an existing problem doesn't reappear when you start in safe mode, you can eliminate the default settings and basic device drivers as possible causes. If you don't know the cause of the problem, you can use the process of elimination to help you find the problem. Try starting all of the programs you commonly use, including the programs in your Startup folder, one by one to see if a program might be the cause of the problem."

Ergo: you have an external cause for the issue that is not a default setting or basic driver (or one of the Windows sub-programs that start in Safe Mode). Time to go through your programs.

Since this is the case, I'll quote what Microsoft say about Windows' Safe Mode: " Safe mode is a troubleshooting option for Windows that starts your computer in a limited state. Only the basic files and drivers necessary to run Windows are started. The words Safe Mode appear in the corners of your monitor to identify which Windows mode you're using. If an existing problem doesn't reappear when you start in safe mode, you can eliminate the default settings and basic device drivers as possible causes. If you don't know the cause of the problem, you can use the process of elimination to help you find the problem. Try starting all of the programs you commonly use, including the programs in your Startup folder, one by one to see if a program might be the cause of the problem." Ergo: you have an external cause for the issue that is not a default setting or basic driver (or one of the Windows sub-programs that start in Safe Mode). Time to go through your programs.

Question owner

well, this is strange. I didn't install anything new since long time ago. Only windows updates and my VGA card driver update!

well, this is strange. I didn't install anything new since long time ago. Only windows updates and my VGA card driver update!
Phoxuponyou 51 solutions 517 answers

The darndest things happen with software all the time - it's part of the fun (yay customisation), and part of the pain (innumerable factors).

My immediate thoughts go to antivirus, as they are a prominent group of troublemakers; AV has a lot of control and keeps its fingers in every cookie jar, literal or figurative. Which one do you use and could you try updating its software version manually? What else do you have running?

PS. When I say manually, I mean manually. Automation is known to mess up, and automatic updates may have updated software you have installed long ago, resulting in the current issue.

The darndest things happen with software all the time - it's part of the fun (yay customisation), and part of the pain (innumerable factors). My immediate thoughts go to antivirus, as they are a prominent group of troublemakers; AV has a lot of control and keeps its fingers in every cookie jar, literal or figurative. Which one do you use and could you try updating its software version manually? What else do you have running? PS. When I say manually, I mean manually. Automation is known to mess up, and automatic updates may have updated software you have installed long ago, resulting in the current issue.

Question owner

I use Symantec End point protection and i use the latest version. I also have Outlook running, cc cleaner and IDM. thats' it.

I use Symantec End point protection and i use the latest version. I also have Outlook running, cc cleaner and IDM. thats' it.
Phoxuponyou 51 solutions 517 answers

IDM as in Internet Download Manager? We could start by disabling that, as it is not essential but it is browsing related.

Symantec is high-risk as well, first because it's Symantec (their approach is less than flexible) and second because it is a corporate product (have had some bad things happen with endpoint-style products and new product versions).

IDM as in Internet Download Manager? We could start by disabling that, as it is not essential but it is browsing related. Symantec is high-risk as well, first because it's Symantec (their approach is less than flexible) and second because it is a corporate product (have had some bad things happen with endpoint-style products and new product versions).
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Disable the suspects one after the other. As a test, disable your protection programs.

Disable the suspects one after the other. As a test, disable your protection programs.

Question owner

Hello, First sorry for being late in replying.

I disabled almost everything one by one and even the SEP client and nothing, the problem still exists.

Hello, First sorry for being late in replying. I disabled almost everything one by one and even the SEP client and nothing, the problem still exists.