X
Tap here to go to the mobile version of the site.

Support Forum

Firefox interface fonts are too small, and I can't find a fix...

Posted

I'm having a problem with the interface fonts on Firefox 46.0 on Linux (in this case, Kubuntu 16.04). They are far too small for my 24" 1920x1200 monitor.

Before I upgraded to version 46 I was using the Theme Font & Size Changer add-on by Baris Derin. Unfortunately, the latest release (45.4) no longer supports Linux (why, I don't know, but this is a problem). I attempted to install an older version of the add-on (43.4) but this doesn't seem to work. I can't find it anywhere in Firefox other than in my Add-ons Manager. I can't load up the configuration for it through the manager.

So, now I am stuck with tiny fonts, and it's hard to read.

I have read some references to setting the fonts in the userChrome.css file, but I can't seem to find a chrome folder on my machine. Does Firefox support this, still?

This has to be a common problem, and I hope there is a solution -- but I can't find one that works.

I'm having a problem with the interface fonts on Firefox 46.0 on Linux (in this case, Kubuntu 16.04). They are far too small for my 24" 1920x1200 monitor. Before I upgraded to version 46 I was using the Theme Font & Size Changer add-on by Baris Derin. Unfortunately, the latest release (45.4) no longer supports Linux (why, I don't know, but this is a problem). I attempted to install an older version of the add-on (43.4) but this doesn't seem to work. I can't find it anywhere in Firefox other than in my Add-ons Manager. I can't load up the configuration for it through the manager. So, now I am stuck with tiny fonts, and it's hard to read. I have read some references to setting the fonts in the userChrome.css file, but I can't seem to find a chrome folder on my machine. Does Firefox support this, still? This has to be a common problem, and I hope there is a solution -- but I can't find one that works.

Chosen solution

jscher2000 said

Crotalidae75 said
I tried adjusting "layout.css.devPixelsPerPx" but it only affects the body fonts, and not the menu, tabs, or location bar.

It should be global, hmm. A while ago, there were some threads complaining that on Linux, this did not work as smoothly as on other OS'es -- that various intermediate sizes were not supported. I think setting it to 2 might work, but that may well be too large.

Do you want to try version 45.1 of the extension? It's available on the "versions" page here: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/ (March 22, 2016)

It's not, apparently, but I found something that does work.

I created a userChrome.css file with this code in it --

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

* {font-size: 18px !important;

}

It works just fine. Now my fonts are like the way they used to be before I upgraded. I found this solution in another post similar to this one, with the same problem, from a few years back.

[https://support.mozilla.org/en-US/que.../947261]

All I had to do is create a sub-folder named "chrome" in my /.mozilla/firefox/profile folder, and put that file in it.

Read this answer in context 0

Additional System Details

Installed Plug-ins

Tab Mix Plus 0.4.2.2 Classic Theme Restorer 1.50 NoSquint 2.1.9.1-signed.1-signed Oldbar 1.21-signed.1-signed

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

FredMcD
  • Top 10 Contributor
3227 solutions 43528 answers

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html
jscher2000
  • Top 10 Contributor
6742 solutions 55106 answers

Firefox has an internal setting that governs both the "chrome" area (toolbars, menus, dialog) and the content area (pages). If you change this, you might need to adjust your global zoom level in NoSquint, but let's give it a try.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.25 for 25% enlargement from the classic default of 96 pixels per inch, and click OK to see whether that's any better. As you can guess, 1.5 gives you a 50% enlargement, and 2.0 doubles the size.

Since you have a very large monitor, I think one of those should do the trick. However, my experience is with Windows and not Linux...

Can you find a multiplier that works well for the chrome area?

Firefox has an internal setting that governs both the "chrome" area (toolbars, menus, dialog) and the content area (pages). If you change this, you might need to adjust your global zoom level in NoSquint, but let's give it a try. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the filter box, type or paste '''pix''' and pause while the list is filtered (3) Double-click '''layout.css.devPixelsPerPx''' and change its value to '''1.25''' for 25% enlargement from the classic default of 96 pixels per inch, and click OK to see whether that's any better. As you can guess, 1.5 gives you a 50% enlargement, and 2.0 doubles the size. Since you have a very large monitor, I think one of those should do the trick. However, my experience is with Windows and not Linux... Can you find a multiplier that works well for the chrome area?

Question owner

jscher2000 said

Firefox has an internal setting that governs both the "chrome" area (toolbars, menus, dialog) and the content area (pages). If you change this, you might need to adjust your global zoom level in NoSquint, but let's give it a try. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the filter box, type or paste pix and pause while the list is filtered (3) Double-click layout.css.devPixelsPerPx and change its value to 1.25 for 25% enlargement from the classic default of 96 pixels per inch, and click OK to see whether that's any better. As you can guess, 1.5 gives you a 50% enlargement, and 2.0 doubles the size. Since you have a very large monitor, I think one of those should do the trick. However, my experience is with Windows and not Linux... Can you find a multiplier that works well for the chrome area?

I tried adjusting "layout.css.devPixelsPerPx" but it only affects the body fonts, and not the menu, tabs, or location bar.

''jscher2000 [[#answer-870905|said]]'' <blockquote> Firefox has an internal setting that governs both the "chrome" area (toolbars, menus, dialog) and the content area (pages). If you change this, you might need to adjust your global zoom level in NoSquint, but let's give it a try. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the filter box, type or paste '''pix''' and pause while the list is filtered (3) Double-click '''layout.css.devPixelsPerPx''' and change its value to '''1.25''' for 25% enlargement from the classic default of 96 pixels per inch, and click OK to see whether that's any better. As you can guess, 1.5 gives you a 50% enlargement, and 2.0 doubles the size. Since you have a very large monitor, I think one of those should do the trick. However, my experience is with Windows and not Linux... Can you find a multiplier that works well for the chrome area? </blockquote> I tried adjusting "layout.css.devPixelsPerPx" but it only affects the body fonts, and not the menu, tabs, or location bar.

Question owner

FredMcD said

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own. You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

That was not what I was asking. I was referring to the interface fonts (menu, tabs, address bar). Those are the ones I need to change.

''FredMcD [[#answer-870898|said]]'' <blockquote> Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html </blockquote> That was not what I was asking. I was referring to the interface fonts (menu, tabs, address bar). Those are the ones I need to change.
jscher2000
  • Top 10 Contributor
6742 solutions 55106 answers

Crotalidae75 said

I tried adjusting "layout.css.devPixelsPerPx" but it only affects the body fonts, and not the menu, tabs, or location bar.

It should be global, hmm. A while ago, there were some threads complaining that on Linux, this did not work as smoothly as on other OS'es -- that various intermediate sizes were not supported. I think setting it to 2 might work, but that may well be too large.

Do you want to try version 45.1 of the extension? It's available on the "versions" page here: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/ (March 22, 2016)

''Crotalidae75 [[#answer-870919|said]]'' <blockquote> I tried adjusting "layout.css.devPixelsPerPx" but it only affects the body fonts, and not the menu, tabs, or location bar. </blockquote> It should be global, hmm. A while ago, there were some threads complaining that on Linux, this did not work as smoothly as on other OS'es -- that various intermediate sizes were not supported. I think setting it to 2 might work, but that may well be too large. Do you want to try version 45.1 of the extension? It's available on the "versions" page here: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/ (March 22, 2016)

Chosen Solution

jscher2000 said

Crotalidae75 said
I tried adjusting "layout.css.devPixelsPerPx" but it only affects the body fonts, and not the menu, tabs, or location bar.

It should be global, hmm. A while ago, there were some threads complaining that on Linux, this did not work as smoothly as on other OS'es -- that various intermediate sizes were not supported. I think setting it to 2 might work, but that may well be too large.

Do you want to try version 45.1 of the extension? It's available on the "versions" page here: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/ (March 22, 2016)

It's not, apparently, but I found something that does work.

I created a userChrome.css file with this code in it --

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

* {font-size: 18px !important;

}

It works just fine. Now my fonts are like the way they used to be before I upgraded. I found this solution in another post similar to this one, with the same problem, from a few years back.

[https://support.mozilla.org/en-US/que.../947261]

All I had to do is create a sub-folder named "chrome" in my /.mozilla/firefox/profile folder, and put that file in it.

''jscher2000 [[#answer-870933|said]]'' <blockquote> ''Crotalidae75 [[#answer-870919|said]]'' <blockquote> I tried adjusting "layout.css.devPixelsPerPx" but it only affects the body fonts, and not the menu, tabs, or location bar. </blockquote> It should be global, hmm. A while ago, there were some threads complaining that on Linux, this did not work as smoothly as on other OS'es -- that various intermediate sizes were not supported. I think setting it to 2 might work, but that may well be too large. Do you want to try version 45.1 of the extension? It's available on the "versions" page here: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/versions/ (March 22, 2016) </blockquote> It's not, apparently, but I found something that does work. I created a userChrome.css file with this code in it -- ''@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */ * {font-size: 18px !important; }'' It works just fine. Now my fonts are like the way they used to be before I upgraded. I found this solution in another post similar to this one, with the same problem, from a few years back. [[https://support.mozilla.org/en-US/questions/947261|https://support.mozilla.org/en-US/questions/947261]] All I had to do is create a sub-folder named "chrome" in my /.mozilla/firefox/''profile'' folder, and put that file in it.
FredMcD
  • Top 10 Contributor
3227 solutions 43528 answers

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know.