Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I am composing a message Thunderbird doublespaces every time I hit the Enter key, and I can't find an option for single spacing, which I sometimes want

  • 22 replies
  • 152 have this problem
  • 1033 views
  • Last reply by gmeades

more options

I think that this problem arose only with the most recent update to Thunderbird, which I installed yesterday or today (April 22). When I hit the Enter key Thunderbird automatically doublespaces, which is fine for text as it separates paragraphs. However, I also will sometimes type my name, address, and telephone number at the end of the message, using Enter for each to line, and I cannot find a way to make Thunderbird singlespace at that time. Word processors usually have a "line" option that allows for this (at least WordPerfect, which is still the best word processor, does). I'd much rather have Enter do only a single space; I can always hit it twice to double space between paragraphs (I've been doing that since I first used an electric rather than manual typewriter).

Chosen solution

If you keep the default setting for Enter to start a new paragraph (under Tools/Options/Composition/General/HTML), then Shift-Enter will create a single space. Or, change the style in the Write window from Paragraph to Body Text.

Read this answer in context 👍 52

All Replies (2)

more options

Thanks for your replies guys. I'm running Windows 7 Pro 64 bit OS.

There's realy no need to kick this dead horase any longer. THe problem has gone away when I opened a new message and went to tools/options/composition, then unchecked the box in the HTML section. It now uses body text and single spaces.

I'm still pretty steamed at Mozilla coders for making such a simple and often used task so much more difficult that it should be.

Have a great day and thanls again all.

more options

@F5Loar - well, that's some good news there. I'm glad to hear you were able to fix it on your machine. We should make a very clear note that -

The setting to uncheck in Windows 7 64-bit is located as a menu item on a New Message window at tools/options/composition on the HTML tab

I'm sure that will help others having this problem, as pretty much everyone has this problem, since some bonehead at Mozilla thought this rarely used option to change the way the enter key functions should be made the default setting for ALL users, making ALL users (except a tiny few) have to either find a solution, or learn to live with having to change their composition style in every single message they will ever write from whenever this change was put in place until who the heck knows when.

In any case, I'm glad to hear you got it working properly on your machine, and undoubtedly your post will have contributed to others running Win 7 64-bit who are also looking for a solution to this most vexing of problems the Mozilla developers have created.

Hopefully, at some point, Mozilla will realize just how boneheaded a move it was to change the enter key function, and return it to the behavior that nearly all (99.9%) of users expect and use when composing emails.

You would think the least they could have done would have been to at least provide the solutions that we've all discovered and posted here on this thread, just in case users did want to change the behavior of the enter key back to how it's operated in Mozilla for the past 20 years or so, as well as the way it behaves by default in every other application that exists on the planet.

This used to be considered one of Microsoft's "Development Standards" that all developers were supposed to follow back when I worked as an IT Professional years ago. Apparently the MS Development Standards aren't as well known as they used to be. Such things as the "_" "double squares" and "x" being located in the upper right corner of a window; the menu bar being located at the top of the page; the enter key providing single spacing. Those were all "standards" that Microsoft established, and was something all developers learned as standard programming practices. Were those standards still adhered to, no one would be having this problem that's come up with the release of these more recent versions of T-Bird at all. Oh, well...

Can't wait for the next person to come along and report that the fix that's worked for every single person on this thread at this point doesn't work on their machine... ;-)

Later...!

Modified by gmeades

  1. 1
  2. 2